]> git.pld-linux.org Git - packages/qscintilla2.git/blame - qscintilla2.spec
- fix failure to link python* packages to the lib (Closes: debian #751239)
[packages/qscintilla2.git] / qscintilla2.spec
CommitLineData
9ee0f3af 1#
47f45644 2# TODO:
a9a3cc91 3# - fix building with qscintilla2(-devel) installed, remove BC
d86befc1 4# - how to successfully prepend -I../Qt4Qt5 before system qt include in qmake?
47f45644 5# - QScintilla2 for Qt3 (does it make any sense nowadays?)
9ee0f3af 6#
d86befc1
JB
7# Conditonal build:
8%bcond_without python2 # CPython 2.x module
9%bcond_without python3 # CPython 3.x module
10%bcond_without qt4 # Qt4 library and modules
11%bcond_without qt5 # Qt5 library and modules
12
13%define scintilla_ver 3.3.6
14%define sip_ver 4.16
d7dc8e14
JB
15%define pyqt4_ver 4.8.2
16%define pyqt5_ver 5.0
9ee0f3af 17Summary: QScintilla2 - a port to Qt of the Scintilla editing component
0bd4b1b2 18Summary(pl.UTF-8): QScintilla2 - port komponentu edytora Scintilla dla biblioteki Qt
9ee0f3af 19Name: qscintilla2
d86befc1 20Version: 2.8.4
23821e39 21Release: 3
ece58d84 22License: GPL v2 or GPL v3 with Riverbank GPL Exception v1.1
9ee0f3af 23Group: X11/Libraries
69587943 24Source0: http://downloads.sourceforge.net/pyqt/QScintilla-gpl-%{version}.tar.gz
d86befc1 25# Source0-md5: 28aec903ff48ae541295a4fb9c96f8ea
9b858b8d 26Patch0: %{name}-internal_build.patch
d86befc1
JB
27Patch1: %{name}-multiqt.patch
28Patch2: %{name}-make.patch
29Patch3: %{name}-outoftree.patch
d7dc8e14 30Patch4: %{name}-qt5.patch
1dd6bff8 31Patch5: %{name}-mkspecs-dir.patch
23821e39 32Patch6: %{name}-link.patch
9b858b8d 33URL: http://www.riverbankcomputing.co.uk/software/qscintilla/
d86befc1 34%if %{with python2}
d86befc1
JB
35BuildRequires: python-sip-devel >= 2:%{sip_ver}
36%endif
37%if %{with python3}
d86befc1
JB
38BuildRequires: python3-sip-devel >= 2:%{sip_ver}
39%endif
9ee0f3af 40BuildRequires: rpm-pythonprov
2b7936b6 41BuildRequires: rpmbuild(macros) >= 1.558
d86befc1
JB
42%if %{with qt4}
43BuildRequires: QtDesigner-devel >= 4.8
44BuildRequires: QtGui-devel >= 4.8
45BuildRequires: qt4-build >= 4.8
46BuildRequires: qt4-qmake >= 4.8
d7dc8e14
JB
47BuildRequires: sip-PyQt4 >= %{pyqt4_ver}
48%if %{with python2}
49BuildRequires: python-PyQt4 >= %{pyqt4_ver}
50%endif
51%if %{with python3}
52BuildRequires: python3-PyQt4 >= %{pyqt4_ver}
53%endif
d86befc1
JB
54%endif
55%if %{with qt5}
56BuildRequires: Qt5Designer-devel >= 5
57BuildRequires: Qt5Gui-devel >= 5
d7dc8e14
JB
58BuildRequires: Qt5PrintSupport-devel >= 5
59BuildRequires: Qt5Widgets-devel >= 5
d86befc1
JB
60BuildRequires: qt5-build >= 5
61BuildRequires: qt5-qmake >= 5
d7dc8e14
JB
62BuildRequires: sip-PyQt5 >= %{pyqt5_ver}
63%if %{with python2}
64BuildRequires: python-PyQt5 >= %{pyqt5_ver}
65%endif
66%if %{with python3}
67BuildRequires: python3-PyQt5 >= %{pyqt5_ver}
68%endif
d86befc1 69%endif
1dd6bff8
JB
70BuildConflicts: qscintilla2-devel < %{version}
71%{?with_qt4:BuildConflicts: qscintilla2-qt4-devel < %{version}}
72%{?with_qt5:BuildConflicts: qscintilla2-qt5-devel < %{version}}
9ee0f3af
KK
73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75%define _sipfilesdir %{_datadir}/sip
76
77%description
78QScintilla2 is a port to Qt of the Scintilla editing component.
79This version of QScintilla is based on Scintilla v%{scintilla_ver}.
80
d2b29e31 81%description -l pl.UTF-8
23949924
JB
82QScintilla2 to port komponentu edytora Scintilla dla biblioteki Qt.
83Ta wersja QScintilli jest oparta na Scintilli %{scintilla_ver}.
84
d7dc8e14
JB
85%package apidocs
86Summary: QScintilla2 API documentation
87Summary(pl.UTF-8): Dokumentacja API biblioteki QScintilla2
88Group: Documentation
89
90%description apidocs
91QScintilla2 API documentation.
92
93%description apidocs -l pl.UTF-8
94Dokumentacja API biblioteki QScintilla2.
95
96%package qt4
97Summary: QScintilla2 - a port to Qt 4 of the Scintilla editing component
98Summary(pl.UTF-8): QScintilla2 - port komponentu edytora Scintilla dla biblioteki Qt 4
99Group: X11/Libraries
d7dc8e14
JB
100%ifarch %{x8664} ppc64 s390x sparc64
101Provides: libqscintilla2.so.11()(64bit)
102%else
103Provides: libqscintilla2.so.11
104%endif
105Obsoletes: qscintilla2 < 2.8.4
106
107%description qt4
108QScintilla2 is a port to Qt of the Scintilla editing component.
109This version of QScintilla is based on Scintilla v%{scintilla_ver}.
110
111This package contains the Qt 4 port.
112
113%description qt4 -l pl.UTF-8
114QScintilla2 to port komponentu edytora Scintilla dla biblioteki Qt.
115Ta wersja QScintilli jest oparta na Scintilli %{scintilla_ver}.
116
117Ten pakiet zawiera port Qt 4.
118
119%package qt4-devel
120Summary: Development files for the QScintilla2 Qt 4 library
121Summary(pl.UTF-8): Pliki nagłówkowe biblioteki QScintilla2 dla Qt 4
9ee0f3af 122Group: X11/Development/Libraries
d7dc8e14
JB
123Requires: %{name}-qt4 = %{version}-%{release}
124Requires: QtGui-devel >= 4
125Obsoletes: qscintilla2-devel < 2.8.4
9ee0f3af 126
d7dc8e14 127%description qt4-devel
9ee0f3af 128This package contains the header files necessary to develop
d7dc8e14 129applications using QScintilla2 for Qt 4.
9ee0f3af 130
d7dc8e14 131%description qt4-devel -l pl.UTF-8
d2b29e31 132Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów z
d7dc8e14 133użyciem komponentu QScintilla2 dla Qt 4.
23949924 134
9ee0f3af
KK
135%package -n QtDesigner-plugin-%{name}
136Summary: QScintilla2 plugin for Qt Designer
0bd4b1b2 137Summary(pl.UTF-8): Wtyczka QScintilla2 dla Qt Designera
9ee0f3af 138Group: X11/Development/Libraries
d7dc8e14
JB
139Requires: %{name}-qt4 = %{version}-%{release}
140Requires: QtDesigner >= 4
9ee0f3af
KK
141
142%description -n QtDesigner-plugin-%{name}
143QScintilla2 plugin for Qt Designer that allows QScintilla instances
144to be included in GUI designs just like any other Qt widget.
145
d7dc8e14
JB
146This package contains the Qt 4 version.
147
d2b29e31
JR
148%description -n QtDesigner-plugin-%{name} -l pl.UTF-8
149Wtyczka WScintilla2 dla Qt Designera pozwalająca na włączanie
150instancji QScintilli w projekty GUI w ten sam sposób, co inne widgety
23949924
JB
151Qt.
152
d7dc8e14
JB
153Ten pakiet zawiera wersję dla Qt 4.
154
155%package -n sip-PyQt4-%{name}
156Summary: Python bindings for the QScintilla2 - SIP development files
157Summary(pl.UTF-8): Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne SIP
158Group: Development/Languages/Python
159Requires: sip-PyQt4 >= %{pyqt4_ver}
160Obsoletes: python-qscintilla2-devel < 2.8.4
161
162%description -n sip-PyQt4-%{name}
163Python bindings for the QScintilla2 - SIP development files.
164
165%description -n sip-PyQt4-%{name} -l pl.UTF-8
166Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne
167SIP.
168
169%package -n python-PyQt4-%{name}
170Summary: Python 2 bindings for the QScintilla2 (PyQt4 version)
171Summary(pl.UTF-8): Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt4)
9ee0f3af 172Group: Libraries/Python
d7dc8e14 173Requires: %{name}-qt4 = %{version}-%{release}
d86befc1 174%requires_ge python-PyQt4
d7dc8e14
JB
175Obsoletes: python-qscintilla2 < 2.8.4
176
177%description -n python-PyQt4-%{name}
178Python 2 bindings for the QScintilla2 (PyQt4 version).
179
180%description -n python-PyQt4-%{name} -l pl.UTF-8
181Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt4).
182
183%package -n python3-PyQt4-%{name}
184Summary: Python 3 bindings for the QScintilla2 (PyQt4 version)
185Summary(pl.UTF-8): Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt4)
186Group: Libraries/Python
187Requires: %{name}-qt4 = %{version}-%{release}
188%requires_ge python3-PyQt4
189
190%description -n python3-PyQt4-%{name}
191Python 3 bindings for the QScintilla2 (PyQt4 version).
192
193%description -n python3-PyQt4-%{name} -l pl.UTF-8
194Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt4).
195
196%package qt5
197Summary: QScintilla2 - a port to Qt 5 of the Scintilla editing component
198Summary(pl.UTF-8): QScintilla2 - port komponentu edytora Scintilla dla biblioteki Qt 5
199Group: X11/Libraries
d7dc8e14
JB
200
201%description qt5
202QScintilla2 is a port to Qt of the Scintilla editing component.
203This version of QScintilla is based on Scintilla v%{scintilla_ver}.
204
205This package contains the Qt 5 port.
206
207%description qt5 -l pl.UTF-8
208QScintilla2 to port komponentu edytora Scintilla dla biblioteki Qt.
209Ta wersja QScintilli jest oparta na Scintilli %{scintilla_ver}.
210
211Ten pakiet zawiera port Qt 5.
212
213%package qt5-devel
214Summary: Development files for the QScintilla2 Qt 5 library
215Summary(pl.UTF-8): Pliki nagłówkowe biblioteki QScintilla2 dla Qt 5
216Group: X11/Development/Libraries
217Requires: %{name}-qt5 = %{version}-%{release}
218Requires: Qt5Gui-devel >= 5
219Obsoletes: qscintilla2-devel < 2.8.4
220
221%description qt5-devel
222This package contains the header files necessary to develop
223applications using QScintilla2 for Qt 5.
224
225%description qt5-devel -l pl.UTF-8
226Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów z
227użyciem komponentu QScintilla2 dla Qt 5.
228
229%package -n Qt5Designer-plugin-%{name}
230Summary: QScintilla2 plugin for Qt Designer
231Summary(pl.UTF-8): Wtyczka QScintilla2 dla Qt Designera
232Group: X11/Development/Libraries
233Requires: %{name}-qt5 = %{version}-%{release}
234Requires: Qt5Designer >= 5
235
236%description -n Qt5Designer-plugin-%{name}
237QScintilla2 plugin for Qt Designer that allows QScintilla instances
238to be included in GUI designs just like any other Qt widget.
239
240This package contains the Qt 5 version.
9ee0f3af 241
d7dc8e14
JB
242%description -n Qt5Designer-plugin-%{name} -l pl.UTF-8
243Wtyczka WScintilla2 dla Qt Designera pozwalająca na włączanie
244instancji QScintilli w projekty GUI w ten sam sposób, co inne widgety
245Qt.
9ee0f3af 246
d7dc8e14 247Ten pakiet zawiera wersję dla Qt 5.
23949924 248
d7dc8e14
JB
249%package -n sip-PyQt5-%{name}
250Summary: Python bindings for the QScintilla2 - SIP development files
251Summary(pl.UTF-8): Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne SIP
9ee0f3af 252Group: Development/Languages/Python
d7dc8e14
JB
253Requires: sip-PyQt5 >= %{pyqt5_ver}
254
255%description -n sip-PyQt5-%{name}
256Python bindings for the QScintilla2 - SIP development files.
9ee0f3af 257
d7dc8e14
JB
258%description -n sip-PyQt5-%{name} -l pl.UTF-8
259Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne
260SIP.
9ee0f3af 261
d7dc8e14
JB
262%package -n python-PyQt5-%{name}
263Summary: Python 2 bindings for the QScintilla2 (PyQt5 version)
264Summary(pl.UTF-8): Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt5)
265Group: Libraries/Python
266Requires: %{name}-qt5 = %{version}-%{release}
267%requires_ge python-PyQt5
268
269%description -n python-PyQt5-%{name}
270Python 2 bindings for the QScintilla2 (PyQt5 version).
271
272%description -n python-PyQt5-%{name} -l pl.UTF-8
273Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt5).
274
275%package -n python3-PyQt5-%{name}
276Summary: Python 3 bindings for the QScintilla2 (PyQt5 version)
277Summary(pl.UTF-8): Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt5)
278Group: Libraries/Python
279Requires: %{name}-qt5 = %{version}-%{release}
280%requires_ge python3-PyQt5
281
282%description -n python3-PyQt5-%{name}
283Python 3 bindings for the QScintilla2 (PyQt5 version).
284
285%description -n python3-PyQt5-%{name} -l pl.UTF-8
286Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt5).
23949924 287
9ee0f3af 288%prep
db7bb55a 289%setup -q -n QScintilla-gpl-%{version}
9ee0f3af 290%patch0 -p1
d86befc1
JB
291%patch1 -p1
292%patch2 -p1
293%patch3 -p1
d7dc8e14 294%patch4 -p1
1dd6bff8 295%patch5 -p1
23821e39 296%patch6 -p1
9ee0f3af
KK
297
298%build
d86befc1
JB
299for qt in %{?with_qt4:qt4} %{?with_qt5:qt5} ; do
300install -d build-${qt}/{Qt4Qt5,designer-Qt4Qt5,Python2,Python3}
301cd build-${qt}/Qt4Qt5
1dd6bff8
JB
302qmake-${qt} ../../Qt4Qt5/qscintilla.pro \
303 $(test "$qt" = "qt4" || echo QMAKE_MKSPECS=%{_libdir}/$qt/mkspecs)
439a2c93 304%{__make}
d86befc1
JB
305cd ../designer-Qt4Qt5
306qmake-${qt} ../../designer-Qt4Qt5/designer.pro
9ee0f3af 307%{__make}
d86befc1 308cd ..
9ee0f3af 309
d86befc1
JB
310%if %{with python2}
311cd Python2
47f45644
JB
312# setup PATH to get proper qmake
313# pass --apidir because configure.py default is inconsistent with sources (no /qsci subdir)
d86befc1
JB
314PATH=%{_libdir}/${qt}/bin:$PATH \
315%{__python} ../../Python/configure.py \
316 --verbose \
9ee0f3af 317 -c -j 3 \
d86befc1 318 -n ../../Qt4Qt5 \
47f45644 319 -o ../Qt4Qt5 \
d7dc8e14
JB
320 --apidir=%{_datadir}/${qt}/qsci \
321 --pyqt=PyQt${qt#qt}
9ee0f3af 322%{__make}
d86befc1
JB
323cd ..
324%endif
325%if %{with python3}
326cd Python3
327PATH=%{_libdir}/${qt}/bin:$PATH \
328%{__python3} ../../Python/configure.py \
329 --verbose \
330 -c -j 3 \
331 -n ../../Qt4Qt5 \
332 -o ../Qt4Qt5 \
d7dc8e14
JB
333 --apidir=%{_datadir}/${qt}/qsci \
334 --pyqt=PyQt${qt#qt}
d86befc1
JB
335%{__make}
336cd ..
337%endif
338cd ..
339done
9ee0f3af
KK
340
341%install
342rm -rf $RPM_BUILD_ROOT
343
d86befc1
JB
344for qt in %{?with_qt4:qt4} %{?with_qt5:qt5} ; do
345%{__make} -C build-${qt}/Qt4Qt5 install \
9ee0f3af 346 INSTALL_ROOT=$RPM_BUILD_ROOT
d86befc1 347%{__make} -C build-${qt}/designer-Qt4Qt5 install \
9ee0f3af 348 INSTALL_ROOT=$RPM_BUILD_ROOT
d86befc1
JB
349%if %{with python3}
350%{__make} -C build-${qt}/Python3 install \
47f45644 351 INSTALL_ROOT=$RPM_BUILD_ROOT
d86befc1
JB
352%endif
353%if %{with python2}
354%{__make} -C build-${qt}/Python2 install \
355 INSTALL_ROOT=$RPM_BUILD_ROOT
356%endif
357done
9ee0f3af 358
d7dc8e14
JB
359# unnecessary symlink
360%{__rm} $RPM_BUILD_ROOT%{_libdir}/libqscintilla2*.so.11.3
361
362%if %{with qt4}
363# move Qt4 translations to PLD-specific directory scheme
9ee0f3af
KK
364for file in $RPM_BUILD_ROOT%{_datadir}/locale/*.qm
365do
23949924
JB
366 lang=`echo $file | sed -r 's:.*/[a-zA-Z]*_(.*).qm:\1:'`
367 [ "$lang" == "pt_br" ] && lang=pt_BR
368 install -d $RPM_BUILD_ROOT%{_datadir}/locale/$lang/LC_MESSAGES
369 mv -f $file $RPM_BUILD_ROOT%{_datadir}/locale/$lang/LC_MESSAGES/qscintilla2.qm
9ee0f3af
KK
370done
371
d7dc8e14
JB
372# compatibility symlinks
373ln -sf $(basename $RPM_BUILD_ROOT%{_libdir}/libqscintilla2-qt4.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libqscintilla2.so.11
374ln -sf $(basename $RPM_BUILD_ROOT%{_libdir}/libqscintilla2-qt4.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libqscintilla2.so
375%endif
47f45644 376
9ee0f3af
KK
377%clean
378rm -rf $RPM_BUILD_ROOT
379
d7dc8e14
JB
380%post qt4 -p /sbin/ldconfig
381%postun qt4 -p /sbin/ldconfig
382
383%post qt5 -p /sbin/ldconfig
384%postun qt5 -p /sbin/ldconfig
9ee0f3af 385
d7dc8e14
JB
386%files apidocs
387%defattr(644,root,root,755)
388%doc doc/{Scintilla,html-Qt4Qt5}
389
390%if %{with qt4}
391%files qt4
9ee0f3af 392%defattr(644,root,root,755)
ece58d84 393%doc GPL_EXCEPTION.TXT NEWS OPENSOURCE-NOTICE.TXT README
d7dc8e14
JB
394%attr(755,root,root) %{_libdir}/libqscintilla2-qt4.so.*.*.*
395%attr(755,root,root) %ghost %{_libdir}/libqscintilla2-qt4.so.11
396# compatibility symlink
397%attr(755,root,root) %{_libdir}/libqscintilla2.so.11
739c851d 398%lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/qscintilla2.qm
9ee0f3af 399%lang(de) %{_datadir}/locale/de/LC_MESSAGES/qscintilla2.qm
12a74d0d 400%lang(es) %{_datadir}/locale/es/LC_MESSAGES/qscintilla2.qm
9ee0f3af
KK
401%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/qscintilla2.qm
402%lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/qscintilla2.qm
82fa3613
KK
403%dir %{_datadir}/qt4/qsci
404%dir %{_datadir}/qt4/qsci/api
d7dc8e14
JB
405%dir %{_datadir}/qt4/qsci/api/python
406%{_datadir}/qt4/qsci/api/python/Python-*.api
407%{_datadir}/qt4/qsci/api/python/QScintilla2.api
9ee0f3af 408
d7dc8e14 409%files qt4-devel
9ee0f3af 410%defattr(644,root,root,755)
d7dc8e14
JB
411%attr(755,root,root) %{_libdir}/libqscintilla2-qt4.so
412# compatibility symlink
9ee0f3af
KK
413%attr(755,root,root) %{_libdir}/libqscintilla2.so
414%{_includedir}/qt4/Qsci
d86befc1 415%{_datadir}/qt4/mkspecs/features/qscintilla2.prf
9ee0f3af
KK
416
417%files -n QtDesigner-plugin-%{name}
9a281e92 418%defattr(644,root,root,755)
ece58d84 419%attr(755,root,root) %{_libdir}/qt4/plugins/designer/libqscintillaplugin.so
9ee0f3af 420
d7dc8e14
JB
421%files -n sip-PyQt4-%{name}
422%defattr(644,root,root,755)
423%{_sipfilesdir}/PyQt4/Qsci
424
425%if %{with python2}
426%files -n python-PyQt4-%{name}
9ee0f3af 427%defattr(644,root,root,755)
ece58d84 428%attr(755,root,root) %{py_sitedir}/PyQt4/Qsci.so
d7dc8e14 429%endif
9ee0f3af 430
d7dc8e14
JB
431%if %{with python3}
432%files -n python3-PyQt4-%{name}
9ee0f3af 433%defattr(644,root,root,755)
d7dc8e14
JB
434%attr(755,root,root) %{py3_sitedir}/PyQt4/Qsci.so
435%endif
436%endif
437
438%if %{with qt5}
439%files qt5
440%defattr(644,root,root,755)
441%doc GPL_EXCEPTION.TXT NEWS OPENSOURCE-NOTICE.TXT README
442%attr(755,root,root) %{_libdir}/libqscintilla2-qt5.so.*.*.*
443%attr(755,root,root) %ghost %{_libdir}/libqscintilla2-qt5.so.11
444%lang(cs) %{_datadir}/qt5/translations/qscintilla_cs.qm
445%lang(de) %{_datadir}/qt5/translations/qscintilla_de.qm
446%lang(es) %{_datadir}/qt5/translations/qscintilla_es.qm
447%lang(fr) %{_datadir}/qt5/translations/qscintilla_fr.qm
448%lang(pt_BR) %{_datadir}/qt5/translations/qscintilla_pt_br.qm
449%dir %{_datadir}/qt5/qsci
450%dir %{_datadir}/qt5/qsci/api
451%dir %{_datadir}/qt5/qsci/api/python
452%{_datadir}/qt5/qsci/api/python/Python-*.api
453%{_datadir}/qt5/qsci/api/python/QScintilla2.api
454
455%files qt5-devel
456%defattr(644,root,root,755)
457%attr(755,root,root) %{_libdir}/libqscintilla2-qt5.so
458%{_includedir}/qt5/Qsci
1dd6bff8 459%{_libdir}/qt5/mkspecs/features/qscintilla2.prf
d7dc8e14
JB
460
461%files -n Qt5Designer-plugin-%{name}
462%defattr(644,root,root,755)
463%attr(755,root,root) %{_libdir}/qt5/plugins/designer/libqscintillaplugin.so
464
465%files -n sip-PyQt5-%{name}
466%defattr(644,root,root,755)
467%{_sipfilesdir}/PyQt5/Qsci
468
469%if %{with python2}
470%files -n python-PyQt5-%{name}
471%defattr(644,root,root,755)
472%attr(755,root,root) %{py_sitedir}/PyQt5/Qsci.so
473%endif
474
475%if %{with python3}
476%files -n python3-PyQt5-%{name}
477%defattr(644,root,root,755)
478%attr(755,root,root) %{py3_sitedir}/PyQt5/Qsci.so
479%endif
480%endif
This page took 0.172228 seconds and 4 git commands to generate.