]> git.pld-linux.org Git - packages/qscintilla2.git/blame - qscintilla2.spec
- fix qt config file syntax
[packages/qscintilla2.git] / qscintilla2.spec
CommitLineData
47f45644 1# TODO:
a9a3cc91 2# - fix building with qscintilla2(-devel) installed, remove BC
d86befc1 3# - how to successfully prepend -I../Qt4Qt5 before system qt include in qmake?
9ee0f3af 4#
d86befc1
JB
5# Conditonal build:
6%bcond_without python2 # CPython 2.x module
7%bcond_without python3 # CPython 3.x module
8%bcond_without qt4 # Qt4 library and modules
9%bcond_without qt5 # Qt5 library and modules
10
11%define scintilla_ver 3.3.6
ff1f7c20
MK
12%define sip_ver 4.19
13%define pyqt4_ver 4.12
586987ee 14%define pyqt5_ver 5.7.1
9ee0f3af 15Summary: QScintilla2 - a port to Qt of the Scintilla editing component
0bd4b1b2 16Summary(pl.UTF-8): QScintilla2 - port komponentu edytora Scintilla dla biblioteki Qt
9ee0f3af 17Name: qscintilla2
586987ee 18Version: 2.9.1
181d1f5e 19Release: 7
c333e7e3 20License: GPL v3
9ee0f3af 21Group: X11/Libraries
586987ee
MK
22Source0: http://downloads.sourceforge.net/pyqt/QScintilla-gpl-%{version}.tar.gz
23# Source0-md5: 38e6248cb970adf6d05aea7d94f1288e
9b858b8d 24Patch0: %{name}-internal_build.patch
d86befc1
JB
25Patch1: %{name}-multiqt.patch
26Patch2: %{name}-make.patch
27Patch3: %{name}-outoftree.patch
d7dc8e14 28Patch4: %{name}-qt5.patch
c333e7e3 29Patch5: %{name}-link.patch
0279988b 30Patch6: python-install.patch
9b858b8d 31URL: http://www.riverbankcomputing.co.uk/software/qscintilla/
d86befc1 32%if %{with python2}
d86befc1
JB
33BuildRequires: python-sip-devel >= 2:%{sip_ver}
34%endif
35%if %{with python3}
d86befc1
JB
36BuildRequires: python3-sip-devel >= 2:%{sip_ver}
37%endif
9ee0f3af 38BuildRequires: rpm-pythonprov
2b7936b6 39BuildRequires: rpmbuild(macros) >= 1.558
d86befc1
JB
40%if %{with qt4}
41BuildRequires: QtDesigner-devel >= 4.8
42BuildRequires: QtGui-devel >= 4.8
43BuildRequires: qt4-build >= 4.8
44BuildRequires: qt4-qmake >= 4.8
d7dc8e14
JB
45BuildRequires: sip-PyQt4 >= %{pyqt4_ver}
46%if %{with python2}
47BuildRequires: python-PyQt4 >= %{pyqt4_ver}
48%endif
49%if %{with python3}
50BuildRequires: python3-PyQt4 >= %{pyqt4_ver}
51%endif
d86befc1
JB
52%endif
53%if %{with qt5}
54BuildRequires: Qt5Designer-devel >= 5
55BuildRequires: Qt5Gui-devel >= 5
d7dc8e14 56BuildRequires: Qt5PrintSupport-devel >= 5
0279988b 57BuildRequires: Qt5UiTools-devel >= 5
d7dc8e14 58BuildRequires: Qt5Widgets-devel >= 5
d86befc1
JB
59BuildRequires: qt5-build >= 5
60BuildRequires: qt5-qmake >= 5
d7dc8e14
JB
61BuildRequires: sip-PyQt5 >= %{pyqt5_ver}
62%if %{with python2}
63BuildRequires: python-PyQt5 >= %{pyqt5_ver}
64%endif
65%if %{with python3}
66BuildRequires: python3-PyQt5 >= %{pyqt5_ver}
67%endif
d86befc1 68%endif
1dd6bff8
JB
69BuildConflicts: qscintilla2-devel < %{version}
70%{?with_qt4:BuildConflicts: qscintilla2-qt4-devel < %{version}}
71%{?with_qt5:BuildConflicts: qscintilla2-qt5-devel < %{version}}
9ee0f3af
KK
72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74%define _sipfilesdir %{_datadir}/sip
75
76%description
77QScintilla2 is a port to Qt of the Scintilla editing component.
78This version of QScintilla is based on Scintilla v%{scintilla_ver}.
79
d2b29e31 80%description -l pl.UTF-8
23949924
JB
81QScintilla2 to port komponentu edytora Scintilla dla biblioteki Qt.
82Ta wersja QScintilli jest oparta na Scintilli %{scintilla_ver}.
83
d7dc8e14
JB
84%package apidocs
85Summary: QScintilla2 API documentation
86Summary(pl.UTF-8): Dokumentacja API biblioteki QScintilla2
87Group: Documentation
95bdea1a
ER
88%if "%{_rpmversion}" >= "5"
89BuildArch: noarch
90%endif
d7dc8e14
JB
91
92%description apidocs
93QScintilla2 API documentation.
94
95%description apidocs -l pl.UTF-8
96Dokumentacja API biblioteki QScintilla2.
97
98%package qt4
99Summary: QScintilla2 - a port to Qt 4 of the Scintilla editing component
100Summary(pl.UTF-8): QScintilla2 - port komponentu edytora Scintilla dla biblioteki Qt 4
101Group: X11/Libraries
d7dc8e14
JB
102%ifarch %{x8664} ppc64 s390x sparc64
103Provides: libqscintilla2.so.11()(64bit)
104%else
105Provides: libqscintilla2.so.11
106%endif
107Obsoletes: qscintilla2 < 2.8.4
108
109%description qt4
110QScintilla2 is a port to Qt of the Scintilla editing component.
111This version of QScintilla is based on Scintilla v%{scintilla_ver}.
112
113This package contains the Qt 4 port.
114
115%description qt4 -l pl.UTF-8
116QScintilla2 to port komponentu edytora Scintilla dla biblioteki Qt.
117Ta wersja QScintilli jest oparta na Scintilli %{scintilla_ver}.
118
119Ten pakiet zawiera port Qt 4.
120
121%package qt4-devel
122Summary: Development files for the QScintilla2 Qt 4 library
123Summary(pl.UTF-8): Pliki nagłówkowe biblioteki QScintilla2 dla Qt 4
9ee0f3af 124Group: X11/Development/Libraries
d7dc8e14
JB
125Requires: %{name}-qt4 = %{version}-%{release}
126Requires: QtGui-devel >= 4
127Obsoletes: qscintilla2-devel < 2.8.4
9ee0f3af 128
d7dc8e14 129%description qt4-devel
9ee0f3af 130This package contains the header files necessary to develop
d7dc8e14 131applications using QScintilla2 for Qt 4.
9ee0f3af 132
d7dc8e14 133%description qt4-devel -l pl.UTF-8
d2b29e31 134Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów z
d7dc8e14 135użyciem komponentu QScintilla2 dla Qt 4.
23949924 136
9ee0f3af
KK
137%package -n QtDesigner-plugin-%{name}
138Summary: QScintilla2 plugin for Qt Designer
0bd4b1b2 139Summary(pl.UTF-8): Wtyczka QScintilla2 dla Qt Designera
9ee0f3af 140Group: X11/Development/Libraries
d7dc8e14
JB
141Requires: %{name}-qt4 = %{version}-%{release}
142Requires: QtDesigner >= 4
9ee0f3af
KK
143
144%description -n QtDesigner-plugin-%{name}
145QScintilla2 plugin for Qt Designer that allows QScintilla instances
146to be included in GUI designs just like any other Qt widget.
147
d7dc8e14
JB
148This package contains the Qt 4 version.
149
d2b29e31
JR
150%description -n QtDesigner-plugin-%{name} -l pl.UTF-8
151Wtyczka WScintilla2 dla Qt Designera pozwalająca na włączanie
152instancji QScintilli w projekty GUI w ten sam sposób, co inne widgety
23949924
JB
153Qt.
154
d7dc8e14
JB
155Ten pakiet zawiera wersję dla Qt 4.
156
157%package -n sip-PyQt4-%{name}
158Summary: Python bindings for the QScintilla2 - SIP development files
159Summary(pl.UTF-8): Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne SIP
160Group: Development/Languages/Python
161Requires: sip-PyQt4 >= %{pyqt4_ver}
162Obsoletes: python-qscintilla2-devel < 2.8.4
163
164%description -n sip-PyQt4-%{name}
165Python bindings for the QScintilla2 - SIP development files.
166
167%description -n sip-PyQt4-%{name} -l pl.UTF-8
168Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne
169SIP.
170
171%package -n python-PyQt4-%{name}
172Summary: Python 2 bindings for the QScintilla2 (PyQt4 version)
173Summary(pl.UTF-8): Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt4)
9ee0f3af 174Group: Libraries/Python
d7dc8e14 175Requires: %{name}-qt4 = %{version}-%{release}
d86befc1 176%requires_ge python-PyQt4
d7dc8e14
JB
177Obsoletes: python-qscintilla2 < 2.8.4
178
179%description -n python-PyQt4-%{name}
180Python 2 bindings for the QScintilla2 (PyQt4 version).
181
182%description -n python-PyQt4-%{name} -l pl.UTF-8
183Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt4).
184
185%package -n python3-PyQt4-%{name}
186Summary: Python 3 bindings for the QScintilla2 (PyQt4 version)
187Summary(pl.UTF-8): Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt4)
188Group: Libraries/Python
189Requires: %{name}-qt4 = %{version}-%{release}
190%requires_ge python3-PyQt4
191
192%description -n python3-PyQt4-%{name}
193Python 3 bindings for the QScintilla2 (PyQt4 version).
194
195%description -n python3-PyQt4-%{name} -l pl.UTF-8
196Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt4).
197
198%package qt5
199Summary: QScintilla2 - a port to Qt 5 of the Scintilla editing component
200Summary(pl.UTF-8): QScintilla2 - port komponentu edytora Scintilla dla biblioteki Qt 5
201Group: X11/Libraries
d7dc8e14
JB
202
203%description qt5
204QScintilla2 is a port to Qt of the Scintilla editing component.
205This version of QScintilla is based on Scintilla v%{scintilla_ver}.
206
207This package contains the Qt 5 port.
208
209%description qt5 -l pl.UTF-8
210QScintilla2 to port komponentu edytora Scintilla dla biblioteki Qt.
211Ta wersja QScintilli jest oparta na Scintilli %{scintilla_ver}.
212
213Ten pakiet zawiera port Qt 5.
214
215%package qt5-devel
216Summary: Development files for the QScintilla2 Qt 5 library
217Summary(pl.UTF-8): Pliki nagłówkowe biblioteki QScintilla2 dla Qt 5
218Group: X11/Development/Libraries
219Requires: %{name}-qt5 = %{version}-%{release}
220Requires: Qt5Gui-devel >= 5
221Obsoletes: qscintilla2-devel < 2.8.4
222
223%description qt5-devel
224This package contains the header files necessary to develop
225applications using QScintilla2 for Qt 5.
226
227%description qt5-devel -l pl.UTF-8
228Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów z
229użyciem komponentu QScintilla2 dla Qt 5.
230
231%package -n Qt5Designer-plugin-%{name}
232Summary: QScintilla2 plugin for Qt Designer
233Summary(pl.UTF-8): Wtyczka QScintilla2 dla Qt Designera
234Group: X11/Development/Libraries
235Requires: %{name}-qt5 = %{version}-%{release}
236Requires: Qt5Designer >= 5
237
238%description -n Qt5Designer-plugin-%{name}
239QScintilla2 plugin for Qt Designer that allows QScintilla instances
240to be included in GUI designs just like any other Qt widget.
241
242This package contains the Qt 5 version.
9ee0f3af 243
d7dc8e14
JB
244%description -n Qt5Designer-plugin-%{name} -l pl.UTF-8
245Wtyczka WScintilla2 dla Qt Designera pozwalająca na włączanie
246instancji QScintilli w projekty GUI w ten sam sposób, co inne widgety
247Qt.
9ee0f3af 248
d7dc8e14 249Ten pakiet zawiera wersję dla Qt 5.
23949924 250
d7dc8e14
JB
251%package -n sip-PyQt5-%{name}
252Summary: Python bindings for the QScintilla2 - SIP development files
253Summary(pl.UTF-8): Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne SIP
9ee0f3af 254Group: Development/Languages/Python
d7dc8e14
JB
255Requires: sip-PyQt5 >= %{pyqt5_ver}
256
257%description -n sip-PyQt5-%{name}
258Python bindings for the QScintilla2 - SIP development files.
9ee0f3af 259
d7dc8e14
JB
260%description -n sip-PyQt5-%{name} -l pl.UTF-8
261Wiązania Pythona dla komponentu QScintilla2 - pliki programistyczne
262SIP.
9ee0f3af 263
d7dc8e14
JB
264%package -n python-PyQt5-%{name}
265Summary: Python 2 bindings for the QScintilla2 (PyQt5 version)
266Summary(pl.UTF-8): Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt5)
267Group: Libraries/Python
268Requires: %{name}-qt5 = %{version}-%{release}
269%requires_ge python-PyQt5
270
271%description -n python-PyQt5-%{name}
272Python 2 bindings for the QScintilla2 (PyQt5 version).
273
274%description -n python-PyQt5-%{name} -l pl.UTF-8
275Wiązania Pythona 2 dla komponentu QScintilla2 (wersja dla PyQt5).
276
277%package -n python3-PyQt5-%{name}
278Summary: Python 3 bindings for the QScintilla2 (PyQt5 version)
279Summary(pl.UTF-8): Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt5)
280Group: Libraries/Python
281Requires: %{name}-qt5 = %{version}-%{release}
282%requires_ge python3-PyQt5
283
284%description -n python3-PyQt5-%{name}
285Python 3 bindings for the QScintilla2 (PyQt5 version).
286
287%description -n python3-PyQt5-%{name} -l pl.UTF-8
288Wiązania Pythona 3 dla komponentu QScintilla2 (wersja dla PyQt5).
23949924 289
9ee0f3af 290%prep
586987ee 291%setup -q -n QScintilla-gpl-%{version}
9ee0f3af 292%patch0 -p1
586987ee 293%patch1 -p1
d86befc1 294%patch2 -p1
586987ee 295%patch3 -p1
d7dc8e14 296%patch4 -p1
1dd6bff8 297%patch5 -p1
0279988b 298%patch6 -p1
9ee0f3af
KK
299
300%build
d86befc1
JB
301for qt in %{?with_qt4:qt4} %{?with_qt5:qt5} ; do
302install -d build-${qt}/{Qt4Qt5,designer-Qt4Qt5,Python2,Python3}
303cd build-${qt}/Qt4Qt5
1dd6bff8
JB
304qmake-${qt} ../../Qt4Qt5/qscintilla.pro \
305 $(test "$qt" = "qt4" || echo QMAKE_MKSPECS=%{_libdir}/$qt/mkspecs)
439a2c93 306%{__make}
d86befc1
JB
307cd ../designer-Qt4Qt5
308qmake-${qt} ../../designer-Qt4Qt5/designer.pro
9ee0f3af 309%{__make}
d86befc1 310cd ..
9ee0f3af 311
d86befc1
JB
312%if %{with python2}
313cd Python2
47f45644
JB
314# setup PATH to get proper qmake
315# pass --apidir because configure.py default is inconsistent with sources (no /qsci subdir)
d86befc1
JB
316PATH=%{_libdir}/${qt}/bin:$PATH \
317%{__python} ../../Python/configure.py \
318 --verbose \
9ee0f3af 319 -c -j 3 \
d86befc1 320 -n ../../Qt4Qt5 \
47f45644 321 -o ../Qt4Qt5 \
d7dc8e14
JB
322 --apidir=%{_datadir}/${qt}/qsci \
323 --pyqt=PyQt${qt#qt}
9ee0f3af 324%{__make}
d86befc1
JB
325cd ..
326%endif
327%if %{with python3}
328cd Python3
329PATH=%{_libdir}/${qt}/bin:$PATH \
330%{__python3} ../../Python/configure.py \
331 --verbose \
332 -c -j 3 \
333 -n ../../Qt4Qt5 \
334 -o ../Qt4Qt5 \
d7dc8e14
JB
335 --apidir=%{_datadir}/${qt}/qsci \
336 --pyqt=PyQt${qt#qt}
d86befc1
JB
337%{__make}
338cd ..
339%endif
340cd ..
341done
9ee0f3af
KK
342
343%install
344rm -rf $RPM_BUILD_ROOT
345
d86befc1
JB
346for qt in %{?with_qt4:qt4} %{?with_qt5:qt5} ; do
347%{__make} -C build-${qt}/Qt4Qt5 install \
9ee0f3af 348 INSTALL_ROOT=$RPM_BUILD_ROOT
d86befc1 349%{__make} -C build-${qt}/designer-Qt4Qt5 install \
9ee0f3af 350 INSTALL_ROOT=$RPM_BUILD_ROOT
d86befc1
JB
351%if %{with python3}
352%{__make} -C build-${qt}/Python3 install \
47f45644 353 INSTALL_ROOT=$RPM_BUILD_ROOT
d86befc1
JB
354%endif
355%if %{with python2}
356%{__make} -C build-${qt}/Python2 install \
357 INSTALL_ROOT=$RPM_BUILD_ROOT
358%endif
359done
9ee0f3af 360
d7dc8e14 361# unnecessary symlink
c333e7e3 362%{__rm} $RPM_BUILD_ROOT%{_libdir}/libqscintilla2*.so.12.0
d7dc8e14
JB
363
364%if %{with qt4}
365# move Qt4 translations to PLD-specific directory scheme
9ee0f3af
KK
366for file in $RPM_BUILD_ROOT%{_datadir}/locale/*.qm
367do
23949924
JB
368 lang=`echo $file | sed -r 's:.*/[a-zA-Z]*_(.*).qm:\1:'`
369 [ "$lang" == "pt_br" ] && lang=pt_BR
370 install -d $RPM_BUILD_ROOT%{_datadir}/locale/$lang/LC_MESSAGES
c333e7e3 371 %{__mv} $file $RPM_BUILD_ROOT%{_datadir}/locale/$lang/LC_MESSAGES/qscintilla2.qm
9ee0f3af
KK
372done
373
d7dc8e14
JB
374# compatibility symlinks
375ln -sf $(basename $RPM_BUILD_ROOT%{_libdir}/libqscintilla2-qt4.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libqscintilla2.so.11
376ln -sf $(basename $RPM_BUILD_ROOT%{_libdir}/libqscintilla2-qt4.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libqscintilla2.so
377%endif
47f45644 378
9ee0f3af
KK
379%clean
380rm -rf $RPM_BUILD_ROOT
381
d7dc8e14
JB
382%post qt4 -p /sbin/ldconfig
383%postun qt4 -p /sbin/ldconfig
384
385%post qt5 -p /sbin/ldconfig
386%postun qt5 -p /sbin/ldconfig
9ee0f3af 387
d7dc8e14
JB
388%files apidocs
389%defattr(644,root,root,755)
390%doc doc/{Scintilla,html-Qt4Qt5}
391
392%if %{with qt4}
393%files qt4
9ee0f3af 394%defattr(644,root,root,755)
c333e7e3 395%doc NEWS README
d7dc8e14 396%attr(755,root,root) %{_libdir}/libqscintilla2-qt4.so.*.*.*
c333e7e3 397%attr(755,root,root) %ghost %{_libdir}/libqscintilla2-qt4.so.12
d7dc8e14
JB
398# compatibility symlink
399%attr(755,root,root) %{_libdir}/libqscintilla2.so.11
739c851d 400%lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/qscintilla2.qm
9ee0f3af 401%lang(de) %{_datadir}/locale/de/LC_MESSAGES/qscintilla2.qm
12a74d0d 402%lang(es) %{_datadir}/locale/es/LC_MESSAGES/qscintilla2.qm
9ee0f3af
KK
403%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/qscintilla2.qm
404%lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/qscintilla2.qm
82fa3613
KK
405%dir %{_datadir}/qt4/qsci
406%dir %{_datadir}/qt4/qsci/api
d7dc8e14
JB
407%dir %{_datadir}/qt4/qsci/api/python
408%{_datadir}/qt4/qsci/api/python/Python-*.api
409%{_datadir}/qt4/qsci/api/python/QScintilla2.api
9ee0f3af 410
d7dc8e14 411%files qt4-devel
9ee0f3af 412%defattr(644,root,root,755)
d7dc8e14
JB
413%attr(755,root,root) %{_libdir}/libqscintilla2-qt4.so
414# compatibility symlink
9ee0f3af
KK
415%attr(755,root,root) %{_libdir}/libqscintilla2.so
416%{_includedir}/qt4/Qsci
d86befc1 417%{_datadir}/qt4/mkspecs/features/qscintilla2.prf
9ee0f3af
KK
418
419%files -n QtDesigner-plugin-%{name}
9a281e92 420%defattr(644,root,root,755)
ece58d84 421%attr(755,root,root) %{_libdir}/qt4/plugins/designer/libqscintillaplugin.so
9ee0f3af 422
d7dc8e14
JB
423%files -n sip-PyQt4-%{name}
424%defattr(644,root,root,755)
425%{_sipfilesdir}/PyQt4/Qsci
426
427%if %{with python2}
428%files -n python-PyQt4-%{name}
9ee0f3af 429%defattr(644,root,root,755)
ece58d84 430%attr(755,root,root) %{py_sitedir}/PyQt4/Qsci.so
d7dc8e14 431%endif
9ee0f3af 432
d7dc8e14
JB
433%if %{with python3}
434%files -n python3-PyQt4-%{name}
9ee0f3af 435%defattr(644,root,root,755)
d7dc8e14
JB
436%attr(755,root,root) %{py3_sitedir}/PyQt4/Qsci.so
437%endif
438%endif
439
440%if %{with qt5}
441%files qt5
442%defattr(644,root,root,755)
c333e7e3 443%doc NEWS README
d7dc8e14 444%attr(755,root,root) %{_libdir}/libqscintilla2-qt5.so.*.*.*
c333e7e3 445%attr(755,root,root) %ghost %{_libdir}/libqscintilla2-qt5.so.12
d7dc8e14
JB
446%lang(cs) %{_datadir}/qt5/translations/qscintilla_cs.qm
447%lang(de) %{_datadir}/qt5/translations/qscintilla_de.qm
448%lang(es) %{_datadir}/qt5/translations/qscintilla_es.qm
449%lang(fr) %{_datadir}/qt5/translations/qscintilla_fr.qm
450%lang(pt_BR) %{_datadir}/qt5/translations/qscintilla_pt_br.qm
451%dir %{_datadir}/qt5/qsci
452%dir %{_datadir}/qt5/qsci/api
453%dir %{_datadir}/qt5/qsci/api/python
454%{_datadir}/qt5/qsci/api/python/Python-*.api
455%{_datadir}/qt5/qsci/api/python/QScintilla2.api
456
457%files qt5-devel
458%defattr(644,root,root,755)
459%attr(755,root,root) %{_libdir}/libqscintilla2-qt5.so
460%{_includedir}/qt5/Qsci
1dd6bff8 461%{_libdir}/qt5/mkspecs/features/qscintilla2.prf
d7dc8e14
JB
462
463%files -n Qt5Designer-plugin-%{name}
464%defattr(644,root,root,755)
465%attr(755,root,root) %{_libdir}/qt5/plugins/designer/libqscintillaplugin.so
466
467%files -n sip-PyQt5-%{name}
468%defattr(644,root,root,755)
469%{_sipfilesdir}/PyQt5/Qsci
470
471%if %{with python2}
472%files -n python-PyQt5-%{name}
473%defattr(644,root,root,755)
474%attr(755,root,root) %{py_sitedir}/PyQt5/Qsci.so
475%endif
476
477%if %{with python3}
478%files -n python3-PyQt5-%{name}
479%defattr(644,root,root,755)
480%attr(755,root,root) %{py3_sitedir}/PyQt5/Qsci.so
481%endif
482%endif
This page took 0.15259 seconds and 4 git commands to generate.