]> git.pld-linux.org Git - packages/python3.git/blame - python3.spec
- fixed {without tests}
[packages/python3.git] / python3.spec
CommitLineData
19221b23 1#
9416f74d
AM
2
3# Conditional build:
4%bcond_with info # info pages (requires emacs)
5%bcond_without tkinter # disables tkinter module building
48e785bb 6%bcond_with tests # disables Python testing
9416f74d 7%bcond_with verbose_tests # runs tests in verbose mode
9416f74d
AM
8#
9# tests which will not work on 64-bit platforms
10%define no64bit_tests test_audioop test_rgbimg test_imageop
11# tests which may fail because of builder environment limitations (no /proc or /dev/pts)
12%define nobuilder_tests test_resource test_openpty test_socket test_nis test_posix test_locale test_pty
48e785bb 13
9416f74d 14# tests which fail because of some unknown/unresolved reason (this list should be empty)
48e785bb
JK
15# test_site: fails because our site.py is patched to include both /usr/share/... and /usr/lib...
16# test_gdb: fails, as the gdb uses old python version
17%define broken_tests test_httpservers test_distutils test_cmd_line test_pydoc test_telnetlib test_zlib test_gdb test_site
9416f74d 18
e612243a 19%define py_ver 3.2
c7fdbe10 20%define py_abi %{py_ver}mu
9416f74d
AM
21%define py_prefix %{_prefix}
22%define py_libdir %{py_prefix}/%{_lib}/python%{py_ver}
c7fdbe10 23%define py_incdir %{_includedir}/python%{py_abi}
9416f74d
AM
24%define py_sitedir %{py_libdir}/site-packages
25%define py_dyndir %{py_libdir}/lib-dynload
26
27Summary: Very high level scripting language with X interface
28Summary(es.UTF-8): Lenguaje script de alto nivel con interfaz X
29Summary(fr.UTF-8): Langage de script de très haut niveau avec interface X
30Summary(pl.UTF-8): Python - język obiektowy wysokiego poziomu
31Summary(pt_BR.UTF-8): Linguagem de programação interpretada de alto nível
32Summary(ru.UTF-8): Язык программирования очень высокого уровня с X-интерфейсом
33Summary(tr.UTF-8): X arayüzlü, yüksek düzeyli, kabuk yorumlayıcı dili
34Summary(uk.UTF-8): Мова програмування дуже високого рівня з X-інтерфейсом
2072c60e 35Name: python3
e612243a 36Version: %{py_ver}.1
12ba957c 37Release: 4
9416f74d
AM
38Epoch: 1
39License: PSF
40Group: Applications
0cf503a8 41Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
58aa28a5 42# Source0-md5: 2cf014296afc18897daa7b79414ad773
a20e3138
AG
43Patch0: %{name}-pythonpath.patch
44Patch1: %{name}-ac_fixes.patch
45Patch2: %{name}-lib64.patch
46Patch3: %{name}-noarch_to_datadir.patch
7dd2ca46 47Patch4: %{name}-bug11254.patch
48e785bb 48Patch5: %{name}-no_cmdline_tests.patch
9416f74d 49URL: http://www.python.org/
7daf2f83 50BuildRequires: autoconf >= 2.65
9416f74d
AM
51BuildRequires: bluez-libs-devel
52BuildRequires: bzip2-devel
53BuildRequires: db-devel >= 4
54%{?with_info:BuildRequires: emacs >= 21}
55BuildRequires: expat-devel >= 1:1.95.7
56BuildRequires: file
57BuildRequires: gdbm-devel >= 1.8.3
58BuildRequires: gmp-devel >= 4.0
3ba70ac2 59BuildRequires: libffi-devel
9416f74d
AM
60BuildRequires: libstdc++-devel
61BuildRequires: ncurses-ext-devel >= 5.2
9416f74d 62BuildRequires: openssl-devel >= 0.9.8
9416f74d
AM
63BuildRequires: readline-devel >= 5.0
64BuildRequires: rpm-pythonprov
65BuildRequires: sed >= 4.0
66BuildRequires: sqlite3-devel >= 3.3.5
91e93ac7 67BuildRequires: tar >= 1:1.22
9416f74d
AM
68%{?with_info:BuildRequires: tetex-makeindex}
69%{?with_tkinter:BuildRequires: tix-devel >= 1:8.1.4-4}
70%{?with_tkinter:BuildRequires: tk-devel >= 8.4.3}
71BuildRequires: zlib-devel
72Requires: %{name}-libs = %{epoch}:%{version}-%{release}
9416f74d 73BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34dfde61 74
8d0b0882 75%define specflags_ppc -D__ppc__=1
34dfde61 76%define specflags_ppc64 -D__ppc64__=1
9416f74d
AM
77
78%if %{with verbose_tests}
79%define test_flags -v -l -x
80%else
f488a705 81%define test_flags -w -l -x
9416f74d
AM
82%endif
83
84%ifarch alpha ia64 ppc64 sparc64 ppc64 %{x8664}
85%define test_list %{nobuilder_tests} %{broken_tests} %{no64bit_tests}
86%else
87%define test_list %{nobuilder_tests} %{broken_tests}
88%endif
89
90%ifarch sparc
91%define test_list %{nobuilder_tests} %{broken_tests} test_fcntl test_ioctl
92%endif
93
94%description
95Python is an interpreted, interactive, object-oriented programming
96language. It incorporates modules, exceptions, dynamic typing, very
97high level dynamic data types, and classes. Python combines remarkable
98power with very clear syntax. It has interfaces to many system calls
99and libraries, as well as to various window systems, and is extensible
100in C or C++. It is also usable as an extension language for
101applications that need a programmable interface. Finally, Python is
102portable: it runs on many brands of UNIX, on the Mac, and on PCs under
103MS-DOS, Windows, Windows NT, and OS/2.
104
105This package contains the Python binary.
106
107%description -l de.UTF-8
108Python ist eine interpretierte, interaktive, objektorientierte
109Programmiersprache, vergleichbar zu Tcl, Perl, Scheme oder Java.
110Python enthält Module, Klassen, Exceptions, High-Level dynamische
111Datentypen und dynamisches Typisieren. Python unterstützt Interfaces
112zu vielen Systemaufrufen und Libraries, sowie verschiedene
113Fenstersysteme (X11, Motif, Tk, Mac und MFC)
114
115Programmierer können neue built-in-Module für Python in C oder C++
116schreiben. Python kann auch als Erweiterungssprache für Applikationen
117benutzt werden, die ein programmierbares Interface brauchen. Dieses
118Paket enthält die meisten Standard-Python-Module, und Module zum
119Ansprechen von Tix (Tk-widget set) und RPM.
120
121%description -l es.UTF-8
122Python es un lenguaje de scripts interpretado orientado a objetos.
123Contiene soporte para carga dinámica de objetos, clases, módulos y
124excepciones.
125
126Es sencillo adicionar interfaces para nuevos sistemas de biblioteca a
127través de código C, tornando Python fácil de usar en ambientes
128particulares/personalizados. Este paquete Python incluye la mayoría de
129los módulos padrón Python, junto con módulos para crear interfaces
130para el conjunto de componentes Tix para Tk y RPM.
131
132%description -l fr.UTF-8
133Python est un langage de script interprété et orienté objet. Il gère
134le chargement dynamique des objets, les classes, les modules et les
135exceptions. L'ajout d'interfaces aux nouvelles bibliothèques systèmes
136avec du code C est simple, ce qui rend Python facile à utiliser dans
137des configs personnalisées.
138
139Ce paquetage Python contient la plupart des modules Python standards,
140ainsi que ceux permettant l'interfaçage avec les widgets Tix pour Tk
141et RPM.
142
143%description -l pl.UTF-8
144Python jest interpretowanym, interaktywnym i zorientowanym obiektowo
145językiem programowania. Jest modularny, obsługuje wyjątki, dynamiczne
146typy, zaawansowane dynamiczne struktury danych i klasy. Python łączy w
147sobie duże możliwości i przejrzystą składnię. Posiada interfejsy do
148wielu wywołań systemowych i bibliotek, w tym również do różnych
149bibliotek okienkowych. Możliwości jego można jeszcze rozszerzać
150poprzez odpowiednie moduły pisane w C lub C++. Python może być również
151użyty jako element aplikacji, którym potrzebny jest interpreter do
152skryptów. I wreszcie, Python jest wieloplatformowy, działa na wielu
153odmianach UNIX-a, Macu oraz PC pod DOS-em, Windows, WindowsNT oraz
154OS/2.
155
156Ten pakiet zawiera binarkę Pythona.
157
158%description -l pt_BR.UTF-8
159Python é uma linguagem de scripts interpretada orientada a objetos.
160Contém suporte para carga dinâmica de objetos, classes, módulos e
161exceções. Adicionar interfaces para novos sistemas de biblioteca
162através de código C é simples, tornando Python fácil de usar em
163ambientes particulares/personalizados.
164
165Este pacote Python inclui a maioria do módulos padrão Python, junto
166com módulos para interfaceamento para o conjunto de componentes Tix
167para Tk e RPM.
168
169%description -l ru.UTF-8
170Python - это интерпретируемый, объектно-ориентированный язык
171программирования. Он поддерживает динамическую загрузку объектов,
172классы, модули и обработку исключительных ситуаций (exceptions).
173Простота добавления интерфейсов к новым системным библиотекам через
174код на языке C делает Python хорошим выбором для использования в
175специальных конфигурациях.
176
177%description -l tr.UTF-8
178Python, nesneye yönelik bir kabuk yorumlayıcıdır. Nesnelerin,
179sınıfların, modüllerin ve aykırı durumların dinamik yüklenmelerine
180destek verir. C koduyla birlikte kullanımı son derece kolaydır. Bu
181paket, standart Python birimlerinin çoğunun yanısıra Tk ve RPM için
182arayüz birimlerini de içerir.
183
184%description -l uk.UTF-8
185Python - це інтерпретована, об'єктно-орієнтована мова програмування.
186Він підтримує динамічну загрузку об'єктів, класи, модулі та обробку
187виключних ситуацій (exceptions). Простота додавання інтерфейсів для
188нових системних бібліотек через код на мові C робить Python добрим
189вибором для використання в спеціальних конфігураціях.
190
191%package libs
192Summary: Python library
193Summary(pl.UTF-8): Biblioteka języka Python
194Group: Libraries/Python
195# broken detection in rpm/pythondeps.sh
196Provides: python(abi) = %{py_ver}
197# for compatibility with existing Ac packages
198Provides: python(bytecode) = %{py_ver}
2072c60e 199%{!?with_info:Obsoletes: python3-doc-info}
9416f74d
AM
200
201%description libs
202Python shared library and very essental modules for Python binary.
203
204%description libs -l pl.UTF-8
205Biblioteka współdzielona języka Python oraz bardzo podstawowe moduły
206dla Pythona.
207
208%package modules
209Summary: Python modules
210Summary(pl.UTF-8): Moduły języka Python
211Group: Libraries/Python
212Requires: %{name}-libs = %{epoch}:%{version}-%{release}
fef40d51 213Obsoletes: python3-modules-sqlite
9416f74d
AM
214
215%description modules
216Python officially distributed modules.
217
218%description modules -l pl.UTF-8
219Oficjalnie rozprowadzane moduły języka Python.
220
2072c60e 221%package -n pydoc3
9416f74d
AM
222Summary: Python interactive module documentation access support
223Summary(pl.UTF-8): Interaktywne korzystanie z dokumentacji modułów języka Python
224Group: Applications
225Requires: %{name}-modules = %{epoch}:%{version}-%{release}
226
2072c60e 227%description -n pydoc3
9416f74d
AM
228Python interactive module documentation access support.
229
2072c60e 230%description -n pydoc3 -l pl.UTF-8
9416f74d
AM
231Interaktywne korzystanie z dokumentacji modułów języka Python.
232
2072c60e 233%package -n idle3
9416f74d
AM
234Summary: IDE for Python language
235Summary(pl.UTF-8): IDE dla języka Python
236Group: Applications
237Requires: %{name}-tkinter = %{epoch}:%{version}-%{release}
238
2072c60e 239%description -n idle3
9416f74d
AM
240IDE for Python language.
241
2072c60e 242%description -n idle3 -l pl.UTF-8
9416f74d
AM
243IDE dla języka Python.
244
245%package devel
246Summary: Libraries and header files for building python code
247Summary(de.UTF-8): Libraries und Header-Dateien zum Erstellen von Python-Code
248Summary(es.UTF-8): Bibliotecas y archivos de inclusión para construir programas en python
249Summary(fr.UTF-8): Bibliothèques et en-têtes pour construire du code python
250Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki Pythona
251Summary(pt_BR.UTF-8): Bibliotecas e arquivos de inclusão para o Python
252Summary(ru.UTF-8): Библиотеки и хедеры для построения кода на языке Python
253Summary(tr.UTF-8): Python ile geliştirme yapmak için gerekli dosyalar
254Summary(uk.UTF-8): Бібліотеки та хедери для програмування на мові Python
255Group: Development/Languages/Python
256Requires: %{name}-libs = %{epoch}:%{version}-%{release}
257
258%description devel
259The Python interpreter is relatively easy to extend with dynamically
260loaded extensions and to embed in other programs. This package
261contains the header files and libraries which are needed to do both of
262these tasks.
263
264%description devel -l de.UTF-8
265Der Python-Interpretierer ist relativ einfach anhand von dynamisch
266ladbaren Erweiterungen auszubauen und läßt sich in andere Programme
267integrieren. Dieses Paket enthält die Header-Dateien und Libraries,
268die für beide Aufgaben erforderlich sind.
269
270%description devel -l es.UTF-8
271El interpretador Python permite incluir con facilidad extensiones
272cargadas dinámicamente. Python es también fácil de ser empotrado en
273otros programas. Este paquete contiene los archivos de inclusión y
274bibliotecas necesarios para estas dos tareas.
275
276%description devel -l fr.UTF-8
277L'interpréteur Python est relativement facile à étendre avec des
278extensions chargées dynamiquement et à insérer dans d'autres
279programmes. Ce paquetage contient les en-têtes et les bibliothèques
280nécessaires à ces deux tâches.
281
282%description devel -l pl.UTF-8
283Interpreter Pythona jest w miarę łatwy do rozszerzania przy pomocy
284dynamicznie ładowanych rozszerzeń napisanych w C lub C++ oraz
285osadzania w innych programach. Ten pakiet zawiera pliki nagłówkowe i
286wszystko inne co potrzebne do tych celów.
287
288%description devel -l pt_BR.UTF-8
289O interpretador Python permite incluir com facilidade extensões
290carregadas dinamicamente. Python é também fácil de ser embutido em
291outros programas. Este pacote contém os arquivos de inclusão e
292bibliotecas necessários para estas duas tarefas.
293
294%description devel -l ru.UTF-8
295Интерпретатор Python относительно легко расширяется при помощи
296динамически загружаемых расширений и встраивается в другие программы.
297Этот пакет содержит хедеры и библиотеки, необходимые для обеих этих
298задач.
299
300%description devel -l tr.UTF-8
301Bu paket, Python ile geliştirme yapılabilmesi için gerekli başlık
302dosyalarını ve kitaplıkları içerir.
303
304%description devel -l uk.UTF-8
305Інтерпретатор Python відносно легко розширюється за допомогою
306розширень з динамічною загрузкою та вбудовується в інші програми. Цей
307пакет містить хедери та бібліотеки, необхідні для обох цих задач.
308
309%package devel-src
310Summary: Python module sources
311Summary(pl.UTF-8): Pliki źródłowe modułów Pythona
312Group: Development/Languages/Python
313Requires: %{name}-modules = %{epoch}:%{version}-%{release}
314
315%description devel-src
316Python module sources.
317
318%description devel-src -l pl.UTF-8
319Pliki źródłowe modułów Pythona.
320
321%package devel-tools
322Summary: Python development tools
323Summary(pl.UTF-8): Narzędzia programistyczne języka Python
324Group: Development/Languages/Python
325Requires: %{name}-modules = %{epoch}:%{version}-%{release}
326
327%description devel-tools
328Python development tools such as profilers and debugger.
329
330%description devel-tools -l pl.UTF-8
331Narzędzia programistyczne języka Python takie jak profiler oraz
332debugger.
333
30b0ff7b
AF
334%package 2to3
335Summary: Automated Python 2 to 3 code translation
0cf503a8 336Summary(pl.UTF-8): Automatyczne tłumaczenie kodu Pythona 2 do 3
30b0ff7b
AF
337Group: Development/Languages/Pythona
338
339%description 2to3
0cf503a8
JB
3402to3 is a Python program that reads Python 2.x source code and applies
341a series of fixers to transform it into valid Python 3.x code. The
342standard library contains a rich set of fixers that will handle almost
343all code. 2to3 supporting library lib2to3 is, however, a flexible and
344generic library, so it is possible to write your own fixers for 2to3.
345lib2to3 could also be adapted to custom applications in which Python
346code needs to be edited automatically.
347
348%description 2to3 -l pl.UTF-8
3492to3 to program w Pythonie czytający od źródłowy w Pythonie 2.x i
350aplikujący serię poprawek przekształcających go w poprawny kod w
351Pythonie 3.x. Biblioteka standardowa zawiera duży zbiór poprawek
352obsługujących większość kodu. Biblioteka wspierająca 2to3 (lib2to3)
353jest jednak elastyczną i ogólną biblioteką, więc można pisać własne
354poprawki dla 2to3. lib2to3 można także zaadaptować na potrzeby
355własnych zastosowań, w których kod w Pythonie musi być modyfikowany
356automatycznie.
30b0ff7b 357
9416f74d
AM
358%package static
359Summary: Static python library
360Summary(pl.UTF-8): Statyczna biblioteka Pythona
361Group: Development/Languages/Python
362Requires: %{name}-devel = %{epoch}:%{version}-%{release}
363
364%description static
365Static python library.
366
367%description static -l pl.UTF-8
368Statyczna biblioteka Pythona.
369
9416f74d
AM
370%package doc-info
371Summary: Documentation on Python in texinfo format
372Summary(pl.UTF-8): Dokumentacja do Pythona w formacie texinfo
373Group: Documentation
374
375%description doc-info
376Documentation on Python in texinfo format.
377
378%description doc-info -l pl.UTF-8
379Dokumentacja do Pythona w formacie texinfo.
380
381%package tkinter
382Summary: Standard Python interface to the Tk GUI toolkit
383Summary(de.UTF-8): Grafische Tk-Schnittstelle für Python
384Summary(es.UTF-8): Interfaz de GUI Tk para Python
385Summary(fr.UTF-8): Interface graphique Tk pour Python
386Summary(pl.UTF-8): Standardowy interfejs Pythona do biblioteki Tk
387Summary(pt_BR.UTF-8): Interface GUI Tk para Phyton
388Summary(tr.UTF-8): Python için grafik kullanıcı arayüzü
389Group: Libraries/Python
390Requires: %{name}-modules = %{epoch}:%{version}-%{release}
391Requires: tcl >= 8.4.3
392Requires: tix >= 1:8.1.4-4
393Requires: tk >= 8.4.3
394
395%description tkinter
396Standard Python interface to the Tk GUI toolkit.
397
398%description tkinter -l de.UTF-8
399Eine grafische Schnittstelle für Python, basierend auf Tcl/Tk, und von
400vielen Konfigurations-Tools genutzt.
401
402%description tkinter -l es.UTF-8
403Una interfaz gráfica para Python, basada en Tcl/Tk, y usada por muchas
404herramientas de configuración.
405
406%description tkinter -l fr.UTF-8
407Interface graphique pour Python, basée sur Tcl/Tk et utilisée par
408beaucoup des outils de configuration.
409
410%description tkinter -l pl.UTF-8
411Standardowy interfejs Pythona do biblioteki Tk.
412
413%description tkinter -l pt_BR.UTF-8
414Uma interface gráfica para Python, baseada em Tcl/Tk, e usada por
415muitas ferramentas de configuração.
416
417%description tkinter -l ru.UTF-8
418Графический интерфейс (GUI) для Python, построенный на Tcl/Tk.
419
420%description tkinter -l tr.UTF-8
421Python için Tcl/Tk'ye dayalı ve pek çok ayarlama aracı tarafından
422kullanılan grafik bir arayüzdür.
423
424%description tkinter -l uk.UTF-8
425Графічний інтерфейс (GUI) для Python, побудований на Tcl/Tk.
426
427%package examples
428Summary: Example programs in Python
429Summary(pl.UTF-8): Przykładowe programy w Pythonie
430Group: Development/Languages/Python
431
432%description examples
433Example programs in Python.
434
435These are for Python 2.3.4, not %{version}.
436
437%description examples -l pl.UTF-8
438Przykładowe programy w Pythonie.
439
440Przykłady te są dla Pythona 2.3.4, nie %{version}.
441
442%prep
0cf503a8 443%setup -q -n Python-%{version}
a20e3138 444%patch0 -p1
30b0ff7b 445%patch1 -p1
e3852288
JB
446%patch2 -p1
447%patch3 -p1
7dd2ca46 448%patch4 -p1
48e785bb 449%patch5 -p1
9416f74d
AM
450
451%build
9416f74d 452%{__autoconf}
31552fa6 453CPPFLAGS="-I/usr/include/ncursesw %{rpmcppflags}"; export CPPFLAGS
9416f74d 454%configure \
3ba70ac2 455 --with-cxx-main="%{__cxx}" \
9416f74d
AM
456 --enable-shared \
457 --enable-ipv6 \
19221b23 458 --with-dbmliborder=gdbm:bdb \
3ba70ac2 459 --with-wide-unicode \
9416f74d
AM
460 --with-signal-module \
461 --with-tsc \
462 --with-threads \
463 --with-doc-strings \
9416f74d 464 --with-fpectl \
3ba70ac2 465 --with-system-ffi \
23f5417d 466 --with-computed-gotos \
9416f74d
AM
467 LINKCC='$(PURIFY) $(CXX)' \
468 LDSHARED='$(CC) $(CFLAGS) -shared' \
469 BLDSHARED='$(CC) $(CFLAGS) -shared' \
470 LDFLAGS="%{rpmcflags} %{rpmldflags}"
471
472%{__make} \
23f5417d 473 OPT="%{rpmcflags} -fno-caller-saves" 2>&1 | awk '
9416f74d
AM
474BEGIN { fail = 0; logmsg = ""; }
475{
476 if ($0 ~ /\*\*\* WARNING:/) {
477 fail = 1;
478 logmsg = logmsg $0;
479 }
480 print $0;
481}
482END { if (fail) { print "\nPROBLEMS FOUND:"; print logmsg; exit(1); } }'
483
484LC_ALL=C
485export LC_ALL
486%if %{with tests}
487binlibdir=`echo build/lib.*`
488%{__make} test \
489 TESTOPTS="%{test_flags} %{test_list}" \
48e785bb 490 TESTPYTHON="LD_LIBRARY_PATH=`pwd` PYTHONHOME=`pwd` PYTHONPATH=`pwd`/Lib:`pwd`/$binlibdir ./python -tt"
9416f74d
AM
491%endif
492
493%install
494rm -rf $RPM_BUILD_ROOT
495install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
12ba957c 496 $RPM_BUILD_ROOT{%{py_sitedir},%{py_sitescriptdir}}/__pycache__ \
9416f74d 497 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
12ba957c 498 $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1} \
9416f74d
AM
499 $RPM_BUILD_ROOT/etc/shrc.d
500
501%{__make} install \
502 DESTDIR=$RPM_BUILD_ROOT
503
504%if %{with info}
505%{__make} -C Doc/info
506install Doc/info/python*info* $RPM_BUILD_ROOT%{_infodir}
507%endif
508
9416f74d 509install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
4449431f 510cp -a Tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
9416f74d
AM
511
512#
513# create several useful aliases, such as timeit.py, profile.py, pdb.py, smtpd.py
514#
515
516# for python devel tools
517for script in timeit profile pdb pstats; do
24586eb0
AM
518 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
519done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d 520
24586eb0
AM
521echo alias pygettext%{py_ver}.py='"pygettext%{py_ver}"' \
522 >> $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh
9416f74d
AM
523
524sed 's/=/ /' \
24586eb0
AM
525 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.sh \
526 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-devel.csh
9416f74d
AM
527
528# for python modules
529for script in smtpd webbrowser; do
24586eb0
AM
530 echo alias ${script}%{py_ver}.py=\"python%{py_ver} -m ${script}\"
531done > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh
9416f74d
AM
532
533sed 's/=/ /' \
24586eb0
AM
534 < $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.sh \
535 > $RPM_BUILD_ROOT/etc/shrc.d/python%{py_ver}-modules.csh
9416f74d
AM
536
537# xgettext specific for Python code
538#
539# we will have two commands: pygettext.py (an alias) and pygettext;
540# this way there are no import (which is impossible now) conflicts and
541# pygettext.py is provided for compatibility
24586eb0
AM
542install Tools/i18n/pygettext.py $RPM_BUILD_ROOT%{_bindir}/pygettext%{py_ver}
543
9416f74d 544# just to cut the noise, as they are not packaged (now)
1843c435 545# first tests (probably could be packaged)
e3852288
JB
546%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/test
547%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/test
548%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/distutils/tests
549%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/email/test
550%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/importlib/test
551%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/lib2to3/tests
552%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/sqlite3/test
553%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/tkinter/test
dceb7408 554%{__rm} -r $RPM_BUILD_ROOT%{py_scriptdir}/unittest/test
9416f74d
AM
555
556# other files
e3852288
JB
557%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/plat-*/regen
558%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/ctypes/macholib/fetch_macholib*
559%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/site-packages/README
560%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/distutils/command/wininst*.exe
561%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.bat
562%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/idlelib/*.pyw
1843c435
JK
563
564# currently provided by python-2to3, consider switching to this one
565%{__rm} $RPM_BUILD_ROOT%{_bindir}/2to3
566
5d1aec43 567# that seems to be only an empty extension template,
568# which seems to be built only {with tests}
569%{__rm} -f $RPM_BUILD_ROOT%{py_dyndir}/xxlimited.*.so
1843c435 570
acd14a9e 571# already in %%doc
e3852288 572%{__rm} $RPM_BUILD_ROOT%{py_scriptdir}/LICENSE.txt
9416f74d
AM
573
574%clean
575rm -rf $RPM_BUILD_ROOT
576
577%post libs -p /sbin/ldconfig
578%postun libs -p /sbin/ldconfig
579
e3852288 580%post doc-info -p /sbin/postshell
a20bb9dc 581-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d 582
e3852288 583%postun doc-info -p /sbin/postshell
a20bb9dc 584-/usr/sbin/fix-info-dir -c %{_infodir}
9416f74d
AM
585
586%files
587%defattr(644,root,root,755)
24586eb0 588%attr(755,root,root) %{_bindir}/python%{py_ver}
c7fdbe10 589%attr(755,root,root) %{_bindir}/python%{py_abi}
306c0f2d 590%attr(755,root,root) %{_bindir}/python3
c7fdbe10
JB
591%{_mandir}/man1/python%{py_ver}.1*
592
593%files libs
594%defattr(644,root,root,755)
595%doc LICENSE
596%attr(755,root,root) %{_libdir}/libpython%{py_abi}.so.*.*
597
598%dir %{py_libdir}
599%dir %{py_dyndir}
600%dir %{py_sitedir}
12ba957c 601%dir %{py_sitedir}/__pycache__
c7fdbe10
JB
602%dir %{py_scriptdir}
603%dir %{py_sitescriptdir}
12ba957c 604%dir %{py_sitescriptdir}/__pycache__
dceb7408 605%{py_scriptdir}/__pycache__
c7fdbe10
JB
606
607# shared modules required by python library
608%attr(755,root,root) %{py_dyndir}/_struct.cpython-*.so
609
610# modules required by python library
dceb7408 611%{py_scriptdir}/_abcoll.py
612%{py_scriptdir}/_weakrefset.py
613%{py_scriptdir}/abc.py
614%{py_scriptdir}/codecs.py
615%{py_scriptdir}/copyreg.py
616%{py_scriptdir}/genericpath.py
617%{py_scriptdir}/locale.py
618%{py_scriptdir}/io.py
619%{py_scriptdir}/posixpath.py
620%{py_scriptdir}/site.py
621%{py_scriptdir}/stat.py
622%{py_scriptdir}/os.py
c7fdbe10 623# needed by the dynamic sys.lib patch
dceb7408 624%{py_scriptdir}/types.py
c7fdbe10
JB
625
626# encodings required by python library
627%dir %{py_scriptdir}/encodings
dceb7408 628%{py_scriptdir}/encodings/__pycache__
629%{py_scriptdir}/encodings/*.py
9416f74d 630
d91cfa38
JK
631%dir %{py_libdir}/config-%{py_abi}
632%attr(755,root,root) %{py_libdir}/config-%{py_abi}/makesetup
633%attr(755,root,root) %{py_libdir}/config-%{py_abi}/install-sh
634%{py_libdir}/config-%{py_abi}/Makefile
635%{py_libdir}/config-%{py_abi}/Setup
636%{py_libdir}/config-%{py_abi}/Setup.config
637%{py_libdir}/config-%{py_abi}/Setup.local
638%{py_libdir}/config-%{py_abi}/config.c
639%{py_libdir}/config-%{py_abi}/config.c.in
640%{py_libdir}/config-%{py_abi}/python.o
641
9416f74d
AM
642%files modules
643%defattr(644,root,root,755)
24586eb0 644/etc/shrc.d/python*-modules*
dceb7408 645%exclude %{py_scriptdir}/_abcoll.py
646%exclude %{py_scriptdir}/_weakrefset.py
647%exclude %{py_scriptdir}/abc.py
648%exclude %{py_scriptdir}/codecs.py
649%exclude %{py_scriptdir}/copyreg.py
650%exclude %{py_scriptdir}/genericpath.py
651%exclude %{py_scriptdir}/io.py
652%exclude %{py_scriptdir}/locale.py
653%exclude %{py_scriptdir}/posixpath.py
654%exclude %{py_scriptdir}/pdb.py
655%exclude %{py_scriptdir}/profile.py
656%exclude %{py_scriptdir}/pstats.py
657%exclude %{py_scriptdir}/pydoc.py
658%exclude %{py_scriptdir}/site.py
659%exclude %{py_scriptdir}/stat.py
660%exclude %{py_scriptdir}/timeit.py
661%exclude %{py_scriptdir}/os.py
662%exclude %{py_scriptdir}/encodings/*.py
663%exclude %{py_scriptdir}/types.py
664
665%{py_scriptdir}/*.py
9416f74d 666
1843c435 667%{py_dyndir}/Python-%{version}-py*.egg-info
9416f74d
AM
668
669#
670# list .so modules to be sure that all of them are built
671#
672
c7fdbe10
JB
673%attr(755,root,root) %{py_dyndir}/_bisect.cpython-*.so
674%attr(755,root,root) %{py_dyndir}/_codecs_cn.cpython-*.so
675%attr(755,root,root) %{py_dyndir}/_codecs_hk.cpython-*.so
676%attr(755,root,root) %{py_dyndir}/_codecs_iso2022.cpython-*.so
677%attr(755,root,root) %{py_dyndir}/_codecs_jp.cpython-*.so
678%attr(755,root,root) %{py_dyndir}/_codecs_kr.cpython-*.so
679%attr(755,root,root) %{py_dyndir}/_codecs_tw.cpython-*.so
680%attr(755,root,root) %{py_dyndir}/_csv.cpython-*.so
681%attr(755,root,root) %{py_dyndir}/_ctypes*.cpython-*.so
682%attr(755,root,root) %{py_dyndir}/_curses_panel.cpython-*.so
683%attr(755,root,root) %{py_dyndir}/_curses.cpython-*.so
684%attr(755,root,root) %{py_dyndir}/_datetime.cpython-*.so
9416f74d 685%ifnarch sparc64
c7fdbe10 686%attr(755,root,root) %{py_dyndir}/_dbm.cpython-*.so
9416f74d 687%endif
c7fdbe10
JB
688%attr(755,root,root) %{py_dyndir}/_elementtree.cpython-*.so
689%attr(755,root,root) %{py_dyndir}/_gdbm.cpython-*.so
690%attr(755,root,root) %{py_dyndir}/_hashlib.cpython-*.so
691%attr(755,root,root) %{py_dyndir}/_heapq.cpython-*.so
692%attr(755,root,root) %{py_dyndir}/_json.cpython-*.so
693%attr(755,root,root) %{py_dyndir}/_lsprof.cpython-*.so
694%attr(755,root,root) %{py_dyndir}/_multibytecodec.cpython-*.so
695%attr(755,root,root) %{py_dyndir}/_multiprocessing.cpython-*.so
696%attr(755,root,root) %{py_dyndir}/_pickle.cpython-*.so
dceb7408 697%attr(755,root,root) %{py_dyndir}/_posixsubprocess.cpython-*.so
c7fdbe10
JB
698%attr(755,root,root) %{py_dyndir}/_random.cpython-*.so
699%attr(755,root,root) %{py_dyndir}/_socket.cpython-*.so
700%attr(755,root,root) %{py_dyndir}/_ssl.cpython-*.so
701%attr(755,root,root) %{py_dyndir}/_testcapi.cpython-*.so
702%attr(755,root,root) %{py_dyndir}/array.cpython-*.so
703%attr(755,root,root) %{py_dyndir}/atexit.cpython-*.so
dceb7408 704%attr(755,root,root) %{py_dyndir}/audioop.cpython-*.so
c7fdbe10
JB
705%attr(755,root,root) %{py_dyndir}/binascii.cpython-*.so
706%attr(755,root,root) %{py_dyndir}/bz2.cpython-*.so
707%attr(755,root,root) %{py_dyndir}/cmath.cpython-*.so
708%attr(755,root,root) %{py_dyndir}/crypt.cpython-*.so
709%attr(755,root,root) %{py_dyndir}/fcntl.cpython-*.so
710%attr(755,root,root) %{py_dyndir}/grp.cpython-*.so
711%attr(755,root,root) %{py_dyndir}/math.cpython-*.so
712%attr(755,root,root) %{py_dyndir}/mmap.cpython-*.so
713%attr(755,root,root) %{py_dyndir}/nis.cpython-*.so
714%attr(755,root,root) %{py_dyndir}/ossaudiodev.cpython-*.so
715%attr(755,root,root) %{py_dyndir}/parser.cpython-*.so
716%attr(755,root,root) %{py_dyndir}/pyexpat.cpython-*.so
717%attr(755,root,root) %{py_dyndir}/readline.cpython-*.so
718%attr(755,root,root) %{py_dyndir}/resource.cpython-*.so
719%attr(755,root,root) %{py_dyndir}/select.cpython-*.so
720%attr(755,root,root) %{py_dyndir}/syslog.cpython-*.so
721%attr(755,root,root) %{py_dyndir}/termios.cpython-*.so
722%attr(755,root,root) %{py_dyndir}/time.cpython-*.so
723%attr(755,root,root) %{py_dyndir}/spwd.cpython-*.so
724%attr(755,root,root) %{py_dyndir}/unicodedata.cpython-*.so
725%attr(755,root,root) %{py_dyndir}/zlib.cpython-*.so
9416f74d
AM
726
727%dir %{py_scriptdir}/plat-*
dceb7408 728%{py_scriptdir}/plat-*/__pycache__
729%{py_scriptdir}/plat-*/*.py
730
731%{py_scriptdir}/concurrent
9416f74d 732
9416f74d
AM
733%dir %{py_scriptdir}/ctypes
734%dir %{py_scriptdir}/ctypes/macholib
dceb7408 735%{py_scriptdir}/ctypes/__pycache__
736%{py_scriptdir}/ctypes/macholib/__pycache__
35ff21ac 737
dceb7408 738%{py_scriptdir}/ctypes/*.py
739%{py_scriptdir}/ctypes/macholib/*.py
acd14a9e 740%doc %{py_scriptdir}/ctypes/macholib/README.ctypes
9416f74d
AM
741
742%dir %{py_scriptdir}/curses
dceb7408 743%{py_scriptdir}/curses/__pycache__
744%{py_scriptdir}/curses/*.py
9416f74d 745
acd14a9e 746%dir %{py_scriptdir}/dbm
dceb7408 747%{py_scriptdir}/dbm/__pycache__
748%{py_scriptdir}/dbm/*.py
acd14a9e 749
9416f74d
AM
750%dir %{py_scriptdir}/distutils
751%dir %{py_scriptdir}/distutils/command
acd14a9e 752%doc %{py_scriptdir}/distutils/README
dceb7408 753%{py_scriptdir}/distutils/__pycache__
754%{py_scriptdir}/distutils/command/__pycache__
755%{py_scriptdir}/distutils/*.py
756%{py_scriptdir}/distutils/command/*.py
acd14a9e 757%{py_scriptdir}/distutils/command/command_template
9416f74d
AM
758
759%dir %{py_scriptdir}/email
760%dir %{py_scriptdir}/email/mime
dceb7408 761%{py_scriptdir}/email/__pycache__
762%{py_scriptdir}/email/mime/__pycache__
763%{py_scriptdir}/email/*.py
764%{py_scriptdir}/email/mime/*.py
9416f74d 765
acd14a9e 766%dir %{py_scriptdir}/html
dceb7408 767%{py_scriptdir}/html/*.py
768%{py_scriptdir}/html/__pycache__
acd14a9e
AF
769
770%dir %{py_scriptdir}/http
dceb7408 771%{py_scriptdir}/http/__pycache__
772%{py_scriptdir}/http/*.py
acd14a9e 773
fef40d51 774%dir %{py_scriptdir}/importlib
dceb7408 775%{py_scriptdir}/importlib/__pycache__
776%{py_scriptdir}/importlib/*.py
fef40d51 777
acd14a9e 778%dir %{py_scriptdir}/json
dceb7408 779%{py_scriptdir}/json/__pycache__
780%{py_scriptdir}/json/*.py
acd14a9e 781
9416f74d 782%dir %{py_scriptdir}/logging
dceb7408 783%{py_scriptdir}/logging/__pycache__
784%{py_scriptdir}/logging/*.py
9416f74d 785
acd14a9e 786%dir %{py_scriptdir}/multiprocessing
dceb7408 787%{py_scriptdir}/multiprocessing/__pycache__
788%{py_scriptdir}/multiprocessing/*.py
acd14a9e 789%dir %{py_scriptdir}/multiprocessing/dummy
dceb7408 790%{py_scriptdir}/multiprocessing/dummy/__pycache__
791%{py_scriptdir}/multiprocessing/dummy/*.py
792
793%{py_scriptdir}/turtledemo
794%{py_scriptdir}/unittest
acd14a9e
AF
795
796%dir %{py_scriptdir}/urllib
dceb7408 797%{py_scriptdir}/urllib/__pycache__
798%{py_scriptdir}/urllib/*.py
acd14a9e 799
9416f74d 800%dir %{py_scriptdir}/wsgiref
dceb7408 801%{py_scriptdir}/wsgiref/__pycache__
802%{py_scriptdir}/wsgiref/*.py
acd14a9e 803%{py_scriptdir}/wsgiref.egg-info
9416f74d
AM
804
805%dir %{py_scriptdir}/xml
806%dir %{py_scriptdir}/xml/dom
807%dir %{py_scriptdir}/xml/etree
808%dir %{py_scriptdir}/xml/parsers
809%dir %{py_scriptdir}/xml/sax
dceb7408 810%{py_scriptdir}/xml/__pycache__
811%{py_scriptdir}/xml/dom/__pycache__
812%{py_scriptdir}/xml/etree/__pycache__
813%{py_scriptdir}/xml/parsers/__pycache__
814%{py_scriptdir}/xml/sax/__pycache__
815%{py_scriptdir}/xml/*.py
816%{py_scriptdir}/xml/dom/*.py
817%{py_scriptdir}/xml/etree/*.py
818%{py_scriptdir}/xml/parsers/*.py
819%{py_scriptdir}/xml/sax/*.py
9416f74d 820
acd14a9e 821%dir %{py_scriptdir}/xmlrpc
dceb7408 822%{py_scriptdir}/xmlrpc/__pycache__
823%{py_scriptdir}/xmlrpc/*.py
acd14a9e 824
c7fdbe10 825%attr(755,root,root) %{py_dyndir}/_sqlite3.cpython-*.so
9416f74d 826%dir %{py_scriptdir}/sqlite3
dceb7408 827%{py_scriptdir}/sqlite3/__pycache__
828%{py_scriptdir}/sqlite3/*.py
9416f74d 829
2072c60e 830%files -n pydoc3
9416f74d 831%defattr(644,root,root,755)
19221b23 832%attr(755,root,root) %{_bindir}/pydoc3
dceb7408 833%attr(755,root,root) %{_bindir}/pydoc3.2
834%{py_scriptdir}/pydoc.py
fef40d51 835%dir %{py_scriptdir}/pydoc_data
dceb7408 836%{py_scriptdir}/pydoc_data/__pycache__
837%{py_scriptdir}/pydoc_data/*.py
838%{py_scriptdir}/pydoc_data/*.css
9416f74d 839
2072c60e 840%files -n idle3
9416f74d 841%defattr(644,root,root,755)
19221b23 842%attr(755,root,root) %{_bindir}/idle3
dceb7408 843%attr(755,root,root) %{_bindir}/idle3.2
9416f74d
AM
844%dir %{py_scriptdir}/idlelib
845%dir %{py_scriptdir}/idlelib/Icons
dceb7408 846%{py_scriptdir}/idlelib/__pycache__
847%{py_scriptdir}/idlelib/*.py
acd14a9e
AF
848%doc %{py_scriptdir}/idlelib/*.txt
849%doc %{py_scriptdir}/idlelib/ChangeLog
9416f74d
AM
850%{py_scriptdir}/idlelib/Icons/*
851%{py_scriptdir}/idlelib/*.def
852
853%files devel
854%defattr(644,root,root,755)
855%doc Misc/{ACKS,NEWS,README,README.valgrind,valgrind-python.supp}
c7fdbe10
JB
856%attr(755,root,root) %{_bindir}/python%{py_ver}-config
857%attr(755,root,root) %{_bindir}/python%{py_abi}-config
858%attr(755,root,root) %{_bindir}/python3-config
859%attr(755,root,root) %{_libdir}/libpython%{py_abi}.so
860%attr(755,root,root) %{_libdir}/libpython3.so
9416f74d
AM
861%dir %{py_incdir}
862%{py_incdir}/*.h
c7fdbe10 863%{_pkgconfigdir}/python-%{py_ver}.pc
c7fdbe10 864
9416f74d
AM
865%files devel-tools
866%defattr(644,root,root,755)
24586eb0 867/etc/shrc.d/python*-devel*
9416f74d 868
24586eb0 869%attr(755,root,root) %{_bindir}/pygettext%{py_ver}
9416f74d 870
dceb7408 871%{py_scriptdir}/pdb.py
872%{py_scriptdir}/profile.py
873%{py_scriptdir}/pstats.py
874%{py_scriptdir}/timeit.py
9416f74d 875
30b0ff7b 876%files 2to3
eb7b678c 877%attr(755,root,root) %{_bindir}/2to3-%{py_ver}
30b0ff7b 878%dir %{py_scriptdir}/lib2to3
dceb7408 879%{py_scriptdir}/lib2to3/__pycache__
30b0ff7b
AF
880%{py_scriptdir}/lib2to3/*.txt
881%{py_scriptdir}/lib2to3/*.pickle
dceb7408 882%{py_scriptdir}/lib2to3/*.py
30b0ff7b 883%dir %{py_scriptdir}/lib2to3/fixes
dceb7408 884%{py_scriptdir}/lib2to3/fixes/__pycache__
be43ead0 885%{py_scriptdir}/lib2to3/fixes/*.py
30b0ff7b 886%dir %{py_scriptdir}/lib2to3/pgen2
dceb7408 887%{py_scriptdir}/lib2to3/pgen2/__pycache__
888%{py_scriptdir}/lib2to3/pgen2/*.py
30b0ff7b 889
9416f74d
AM
890%files static
891%defattr(644,root,root,755)
6eede82b 892%{_libdir}/libpython%{py_abi}.a
9416f74d
AM
893
894%files examples
895%defattr(644,root,root,755)
896%{_examplesdir}/%{name}-%{version}
897
9416f74d
AM
898%if %{with info}
899%files doc-info
900%defattr(644,root,root,755)
901%{_infodir}/*.info*
902%endif
903
904%if %{with tkinter}
905%files tkinter
906%defattr(644,root,root,755)
acd14a9e 907%dir %{py_scriptdir}/tkinter
dceb7408 908%{py_scriptdir}/tkinter/__pycache__
909%{py_scriptdir}/tkinter/*.py
c7fdbe10 910%attr(755,root,root) %{py_dyndir}/_tkinter.cpython-*.so
9416f74d 911%endif
This page took 0.785663 seconds and 4 git commands to generate.