]> git.pld-linux.org Git - packages/python3-tornado.git/blame - python3-tornado.spec
Release 5 (by relup.sh)
[packages/python3-tornado.git] / python3-tornado.spec
CommitLineData
9ede7d1d
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_with tests # tornado tests [use network]
5
6%define module tornado
7Summary: Web framework and asynchronous networking library
8Summary(pl.UTF-8): Szkielet WWW i asynchroniczna biblioteka sieciowa
9Name: python3-tornado
7d8205a1 10Version: 6.1
6e8593fd 11Release: 5
9ede7d1d
JB
12License: Apache v2.0
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/tornado/
15Source0: https://files.pythonhosted.org/packages/source/t/tornado/tornado-%{version}.tar.gz
7d8205a1
JB
16# Source0-md5: f324f5e7607798552359d6ab054c4321
17URL: https://www.tornadoweb.org/
9ede7d1d
JB
18%if %{with python3}
19BuildRequires: python3-devel >= 1:3.5
20BuildRequires: python3-modules >= 1:3.5
21BuildRequires: python3-setuptools
22%if %{with tests}
23# SO_REUSEPORT option
24BuildRequires: uname(release) >= 3.9
25BuildRequires: python3-twisted
26%endif
27%endif
28BuildRequires: rpm-pythonprov
29BuildRequires: rpmbuild(macros) >= 1.714
30BuildRequires: sed >= 4.0
31%if %{with doc}
32BuildRequires: python3-sphinxcontrib-asyncio
33BuildRequires: python3-sphinx_rtd_theme
34BuildRequires: python3-twisted
35BuildRequires: sphinx-pdg-3
36%endif
37Requires: python3-modules >= 1:3.5
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41Tornado is a Python web framework and asynchronous networking library,
42originally developed at FriendFeed. By using non-blocking network I/O,
43Tornado can scale to tens of thousands of open connections, making it
44ideal for long polling, WebSockets, and other applications that
45require a long-lived connection to each user.
46
47%description -l pl.UTF-8
48Tornado to szkielet WWW oraz asynchroniczna biblioteka sieciowa dla
49Pythona, oryginalnie powstałe w FriendFeed. Dzięki użyciu
50nieblokującego sieciowego we/wy, Tornado może się skalować do
51dziesiątek tysięcy otwartych połączeń, co czyni go idealnym do
52zastosowań z długim pobieraniem, WebSockets i innych wymagających
53długotrwałego połączenia z każdym użytkownikiem.
54
55%package apidocs
56Summary: API documentation for Python tornado module
57Summary(pl.UTF-8): Dokumentacja API modułu Pythona tornado
58Group: Documentation
9ede7d1d 59BuildArch: noarch
9ede7d1d
JB
60
61%description apidocs
62API documentation for Python tornado module.
63
64%description apidocs -l pl.UTF-8
65Dokumentacja API modułu Pythona tornado.
66
67%prep
68%setup -q -n tornado-%{version}
69
7d8205a1 70%{__sed} -i -e '1s,/usr/bin/env python3\?,%{__python3},' demos/*/*.py
9ede7d1d
JB
71
72%build
73TORNADO_EXTENSION=1 \
74%py3_build
75
76%if %{with tests}
77cd build-3/lib*
78%{__python3} -m tornado.test.runtests
79cd ../..
80%endif
81
82%if %{with doc}
83sphinx-build-3 -b html -n -d docs/build/doctrees docs docs/build/html
84%endif
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89%py3_install
90# just tornado tests with their data
91%{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/tornado/test
92
93install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94cp -a demos/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%files
100%defattr(644,root,root,755)
101%doc README.rst
102%dir %{py3_sitedir}/tornado
103%attr(755,root,root) %{py3_sitedir}/tornado/speedups.cpython-*.so
104%{py3_sitedir}/tornado/*.py
105%{py3_sitedir}/tornado/py.typed
106%{py3_sitedir}/tornado/platform
107%{py3_sitedir}/tornado/__pycache__
108%{py3_sitedir}/tornado-%{version}-py*.egg-info
109%{_examplesdir}/%{name}-%{version}
110
111%if %{with doc}
112%files apidocs
113%defattr(644,root,root,755)
114%doc docs/build/html/{_images,_modules,_static,guide,releases,*.html,*.js}
115%endif
This page took 0.124583 seconds and 4 git commands to generate.