]> git.pld-linux.org Git - packages/python3-smspdudecoder.git/blame - python3-smspdudecoder.spec
rebuild with python 3.10
[packages/python3-smspdudecoder.git] / python3-smspdudecoder.spec
CommitLineData
40cfb0f8
AM
1# Conditional build:
2%bcond_with tests # unit tests
3
4%define module smspdu
5%define egg_name smspdudecoder
6%define pypi_name smspdudecoder
7Summary: SMS-PDU Decoder
8Name: python3-%{pypi_name}
9Version: 1.1.0
04ceba37 10Release: 4
40cfb0f8
AM
11License: MIT
12Group: Libraries/Python
13Source0: https://github.com/Qotto/smspdudecoder/archive/%{version}.tar.gz
14# Source0-md5: d76e2a506ee62364399cc3e46de41aaf
15URL: https://github.com/Qotto/smspdudecoder/
d72d911d 16BuildRequires: python3-modules >= 1:3.6
40cfb0f8
AM
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.714
19%if %{with tests}
200157a7 20BuildRequires: python3-bitstring
40cfb0f8
AM
21%endif
22BuildRequires: python3-setuptools
efd1539b 23BuildArch: noarch
d72d911d 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40cfb0f8
AM
25
26%description
27This library will help you to decode raw SMS data you can get from a
28GSM modem.
29
30It has some encoding functionality as well.
31
32It is recommended to read GSM 03.40 to facilitate understanding.
33
34%prep
35%setup -q -n %{pypi_name}-%{version}
36
37%build
38%py3_build %{?with_tests:test}
39
40%install
41rm -rf $RPM_BUILD_ROOT
42
43%py3_install
44
45%clean
46rm -rf $RPM_BUILD_ROOT
47
48%files
49%defattr(644,root,root,755)
50%doc README.md
51%{py3_sitescriptdir}/%{module}
52%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.11837 seconds and 4 git commands to generate.