]> git.pld-linux.org Git - packages/python3-setproctitle.git/blame - python3-setproctitle.spec
Up to 1.3.2 (as separate python3-setproctitle.spec)
[packages/python3-setproctitle.git] / python3-setproctitle.spec
CommitLineData
d843bf5f
AM
1Summary: Python module to customize a process title
2Name: python-setproctitle
a6a19f75 3Version: 1.1.10
ee71ec25 4Release: 8
d843bf5f
AM
5License: BSD
6Group: Development/Languages/Python
7URL: http://pypi.python.org/pypi/setproctitle
589c6996 8BuildRequires: rpmbuild(macros) >= 1.710
a6a19f75
AM
9Source0: https://pypi.python.org/packages/5a/0d/dc0d2234aacba6cf1a729964383e3452c52096dc695581248b548786f2b3/setproctitle-%{version}.tar.gz
10# Source0-md5: 2dcdd1b761700a5a13252fea3dfd1977
d843bf5f
AM
11BuildRequires: python-devel
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15Python module allowing a process to change its title as displayed by
16system tool such as ps and top.
17
18It's useful in multiprocess systems, allowing to identify tasks each
19forked process is busy with. This technique has been used by
20PostgreSQL and OpenSSH.
21
22It's based on PostgreSQL implementation which has proven to be
23portable.
24
25%package -n python3-setproctitle
26Summary: Python module to customize a process title
27BuildRequires: python3-devel
28
29%description -n python3-setproctitle
30Python module allowing a process to change its title as displayed by
31system tool such as ps and top.
32
33It's useful in multi-process systems, allowing to identify tasks each
34forked process is busy with. This technique has been used by
35PostgreSQL and OpenSSH.
36
37It's based on PostgreSQL implementation which has proven to be
38portable.
39
40%prep
41%setup -q -n setproctitle-%{version}
42
43%build
44%{__python} setup.py \
45 build -b build-2
46%{__python3} setup.py \
47 build -b build-3
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
745f306d 52%py_install \
d843bf5f
AM
53 --root $RPM_BUILD_ROOT
54
55chmod 0755 $RPM_BUILD_ROOT%{py_sitedir}/setproctitle.so
56
745f306d 57%py3_install \
d843bf5f
AM
58 --root $RPM_BUILD_ROOT
59
60chmod 0755 $RPM_BUILD_ROOT%{py3_sitedir}/setproctitle*.so
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(644,root,root,755)
67%doc README.rst
68%attr(755,root,root) %{py_sitedir}/setproctitle.so
69%{py_sitedir}/setproctitle-*.egg-info
70
71%files -n python3-setproctitle
72%defattr(644,root,root,755)
73%doc README.rst
74%attr(755,root,root) %{py3_sitedir}/setproctitle.*.so
75%{py3_sitedir}/setproctitle-*.egg-info
This page took 0.318238 seconds and 4 git commands to generate.