]> git.pld-linux.org Git - packages/python3-pythran.git/blame - python3-pythran.spec
- python-pythran.spec updated to 0.11.0 for python3
[packages/python3-pythran.git] / python3-pythran.spec
CommitLineData
1f9164e0
JB
1# TODO: finish docs
2#
3# Conditional build:
4%bcond_with doc # Sphinx documentation
5%bcond_with tests # unit tests (missing in sdist)
1f9164e0
JB
6
7Summary: Ahead of Time compiler for numeric kernels
8Summary(pl.UTF-8): Kompilator z wyprzedzeniem dla jąder numerycznych
fe0de664
JB
9Name: python3-pythran
10Version: 0.11.0
1f9164e0
JB
11Release: 1
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/pythran/
15Source0: https://files.pythonhosted.org/packages/source/p/pythran/pythran-%{version}.tar.gz
fe0de664 16# Source0-md5: e09e90484771937ab499380858bdb18d
1f9164e0 17URL: https://pypi.org/project/pythran/
1f9164e0
JB
18BuildRequires: python3-modules >= 1:3.2
19BuildRequires: python3-pytest-runner
20BuildRequires: python3-setuptools >= 1:12.0.5
21%if %{with tests}
fe0de664
JB
22BuildRequires: python3-beniget >= 0.4.0
23BuildRequires: python3-beniget < 0.5
24BuildRequires: python3-gast >= 0.5.0
25BuildRequires: python3-gast < 0.6
1f9164e0
JB
26BuildRequires: python3-numpy
27BuildRequires: python3-ply >= 3.4
1f9164e0
JB
28%endif
29BuildRequires: rpm-pythonprov
30BuildRequires: rpmbuild(macros) >= 1.714
31%if %{with doc}
32BuildRequires: python3-guzzle_sphinx_theme
33BuildRequires: python3-nbsphinx
34BuildRequires: python3-numpy
35BuildRequires: python3-scipy
36BuildRequires: sphinx-pdg-3
37%endif
fe0de664 38Requires: python3-modules >= 1:3.2
1f9164e0
JB
39BuildArch: noarch
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43Pythran is an ahead of time compiler for a subset of the Python
44language, with a focus on scientific computing. It takes a Python
45module annotated with a few interface description and turns it into a
46native Python module with the same interface, but (hopefully) faster.
47
48%description -l pl.UTF-8
49Pythran to kompilator z wyprzedzeniem dla podzbioru języka Python,
50skupiający się na obliczeniach naukowych. Przyjmuje moduł Pythona z
51niewielkim opisem interfejsu i zamienia go na natywny moduł Pythona o
52tym samym interfejsie, ale (miejmy nadzieję) szybszy.
53
1f9164e0
JB
54%package apidocs
55Summary: API documentation for Python pythran module
56Summary(pl.UTF-8): Dokumentacja API modułu Pythona pythran
57Group: Documentation
58
59%description apidocs
60API documentation for Python pythran module.
61
62%description apidocs -l pl.UTF-8
63Dokumentacja API modułu Pythona pythran.
64
65%prep
66%setup -q -n pythran-%{version}
67
68%build
1f9164e0 69%py3_build %{?with_tests:test}
1f9164e0
JB
70
71%if %{with doc}
72%{__make} -C docs html \
73 SPHINXBUILD=sphinx-build-3
74%endif
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
1f9164e0
JB
79%py3_install
80
81%{__mv} $RPM_BUILD_ROOT%{_bindir}/pythran{,-3}
82%{__mv} $RPM_BUILD_ROOT%{_bindir}/pythran-config{,-3}
83ln -sf pythran-3 $RPM_BUILD_ROOT%{_bindir}/pythran
84ln -sf pythran-config-3 $RPM_BUILD_ROOT%{_bindir}/pythran-config
1f9164e0
JB
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
1f9164e0
JB
89%files
90%defattr(644,root,root,755)
fe0de664 91%doc AUTHORS Changelog LICENSE README.rst
1f9164e0
JB
92%attr(755,root,root) %{_bindir}/pythran
93%attr(755,root,root) %{_bindir}/pythran-3
94%attr(755,root,root) %{_bindir}/pythran-config
95%attr(755,root,root) %{_bindir}/pythran-config-3
96%{py3_sitescriptdir}/omp
97%{py3_sitescriptdir}/pythran
98%{py3_sitescriptdir}/pythran-%{version}-py*.egg-info
1f9164e0
JB
99
100%if %{with doc}
101%files apidocs
102%defattr(644,root,root,755)
103%doc docs/_build/html/*
104%endif
This page took 0.093927 seconds and 4 git commands to generate.