]> git.pld-linux.org Git - packages/python3-pytest-asyncio.git/blame - python3-pytest-asyncio.spec
- updated to 0.18.2
[packages/python3-pytest-asyncio.git] / python3-pytest-asyncio.spec
CommitLineData
bda4c6eb
JB
1#
2# Conditional build:
639e9c9b 3%bcond_without tests # unit tests
bda4c6eb
JB
4
5Summary: Pytest support for asyncio
6Summary(pl.UTF-8): Wsparcie do asyncio dla Pytesta
7Name: python3-pytest-asyncio
639e9c9b
JB
8Version: 0.18.2
9Release: 1
bda4c6eb
JB
10License: Apache v2.0
11Group: Libraries/Python
12#Source0Download: https://pypi.org/simple/pytest-asyncio/
13Source0: https://files.pythonhosted.org/packages/source/p/pytest-asyncio/pytest-asyncio-%{version}.tar.gz
639e9c9b 14# Source0-md5: b57bafeb4f3303afa99df154835caf45
bda4c6eb 15URL: https://pypi.org/project/pytest-asyncio/
639e9c9b 16BuildRequires: python3-modules >= 1:3.7
bda4c6eb
JB
17BuildRequires: python3-setuptools
18%if %{with tests}
639e9c9b 19BuildRequires: python3-flaky >= 3.5.0
bda4c6eb 20BuildRequires: python3-hypothesis >= 5.7.1
639e9c9b
JB
21BuildRequires: python3-pytest >= 6.1.0
22%if "%{py3_ver}" < "3.8"
23BuildRequires: python3-typing_extensions >= 3.7.2
24%endif
bda4c6eb
JB
25%endif
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.714
639e9c9b 28Requires: python3-modules >= 1:3.7
bda4c6eb
JB
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33pytest-asyncio is an Apache 2 licensed library, written in Python, for
34testing asyncio code with pytest.
35
36asyncio code is usually written in the form of coroutines, which makes
37it slightly more difficult to test using normal testing tools.
38pytest-asyncio provides useful fixtures and markers to make testing
39easier.
40
41%description -l pl.UTF-8
42pytest-asyncio to wydana na licencji Apache 2 biblioteka, napisana w
43Pythonie, służąca do testowania kodu asynchronicznego we/wy przy
44użyciu pytesta.
45
46Kod asyncio jest zwykle pisany w postaci korutyn, co nieco utrudnia
47testowanie przy użyciu zwykłych narzędzi testowych. pytest-asyncio
48dostarcza przydatne wyposażenie i znaczniki ułatwiające testowanie.
49
50%prep
51%setup -q -n pytest-asyncio-%{version}
52
53%build
54%py3_build
55
56%if %{with tests}
639e9c9b
JB
57# test_flaky_integration failure: no expected report found
58# test_legacy_mode failures: more warnings than expected
59PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
60PYTEST_PLUGINS="pytest_asyncio.plugin" \
61PYTHONPATH=$(pwd) \
62%{__python3} -m pytest tests -k 'not test_flaky_integration and not test_legacy_mode'
bda4c6eb
JB
63%endif
64
65%install
66rm -rf $RPM_BUILD_ROOT
67
68%py3_install
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%files
74%defattr(644,root,root,755)
75%doc README.rst
76%{py3_sitescriptdir}/pytest_asyncio
77%{py3_sitescriptdir}/pytest_asyncio-%{version}-py*.egg-info
This page took 0.174646 seconds and 4 git commands to generate.