]> git.pld-linux.org Git - packages/python3-pychromecast.git/blame - python3-pychromecast.spec
- updated to 10.2.3
[packages/python3-pychromecast.git] / python3-pychromecast.spec
CommitLineData
7a4a03d5 1#
c3b31952 2# Conditional build:
eb80e935 3%bcond_with tests # unit tests (not included)
c3b31952 4
c3b31952 5%define module pychromecast
c3b31952 6Summary: Library for Python 3 to communicate with the Google Chromecast
7a4a03d5 7Summary(pl.UTF-8): Biblioteka Pythona 3 do komunikacji z Google Chromecast
eb80e935
JB
8Name: python3-%{module}
9# 10.3+ require protobuf >= 3.19.1
10Version: 10.2.3
11Release: 1
c3b31952
AM
12License: MIT
13Group: Libraries/Python
eb80e935
JB
14#Source0Download: https://github.com/balloob/pychromecast/releases
15Source0: https://github.com/balloob/pychromecast/archive/%{version}/pychromecast-%{version}.tar.gz
16# Source0-md5: ed387a2f272ee321d98b34cc395a97a5
c3b31952 17URL: https://github.com/balloob/pychromecast
eb80e935 18BuildRequires: python3-modules >= 1:3.6
c3b31952 19BuildRequires: python3-setuptools
c3b31952 20%if %{with tests}
eb80e935
JB
21BuildRequires: python3-casttube >= 0.2.0
22BuildRequires: python3-protobuf >= 3.0.0
23BuildRequires: python3-zeroconf >= 0.25.1
c3b31952 24%endif
7a4a03d5
JB
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
eb80e935 27Requires: python3-modules >= 1:3.6
c3b31952
AM
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
eb80e935 32Library for Python 3.6+ to communicate with the Google Chromecast. It
c3b31952 33currently supports:
7a4a03d5
JB
34- Auto discovering connected Chromecasts on the network
35- Start the default media receiver and play any online media
36- Control playback of current playing media
37- Implement Google Chromecast API v2
38- Communicate with apps via channels
39- Easily extendable to add support for unsupported namespaces
40- Multi-room setups with Audio cast devices
c3b31952 41
7a4a03d5 42%description -l pl.UTF-8
eb80e935 43Biblioteka Pythona 3.6+ do komunikacji z Google Chromecast. Obecne
7a4a03d5
JB
44możliwości:
45- automatyczne wykrywanie podłączonych Chromecastów w sieci
46- uruchamianie domyślnego odbiornika i odtwarzanie treści online
47- sterowanie odtwarzaniem aktualnej treści
48- implementacja Google Chromecast API v2
49- komunikacja z aplikacjami poprzez kanały
50- łatwe rozszerzanie dodawania obsługi nowych przestrzeni nazw
51- konfiguracje wielopokojowe z urządzeniami Audio cast
c3b31952
AM
52
53%prep
eb80e935 54%setup -q -n %{module}-%{version}
c3b31952
AM
55
56%build
57%py3_build %{?with_tests:test}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%py3_install
63
eb80e935
JB
64install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
65cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
c3b31952
AM
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
eb80e935
JB
72%doc LICENSE README.rst
73%{py3_sitescriptdir}/pychromecast
74%{py3_sitescriptdir}/PyChromecast-%{version}-py*.egg-info
75%{_examplesdir}/python3-%{module}-%{version}
This page took 1.752427 seconds and 4 git commands to generate.