]> git.pld-linux.org Git - packages/python3-outcome.git/blame - python3-outcome.spec
- python-outcome.spec updated to 1.1.0 for python 3.6+
[packages/python3-outcome.git] / python3-outcome.spec
CommitLineData
455112cb
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_without tests # unit tests
455112cb
JB
5
6Summary: Capture the outcome of Python function calls
7Summary(pl.UTF-8): Przechwytywanie wyników wywołań funkcji pythonowych
77d8f197
JB
8Name: python3-outcome
9Version: 1.1.0
455112cb
JB
10Release: 1
11License: MIT or Apache v2.0
12Group: Libraries/Python
13#Source0Download: https://pypi.org/simple/outcome/
14Source0: https://files.pythonhosted.org/packages/source/o/outcome/outcome-%{version}.tar.gz
77d8f197 15# Source0-md5: 30184431b681fe2d5460a2344b904aba
455112cb 16URL: https://pypi.org/project/outcome/
77d8f197 17BuildRequires: python3-modules >= 1:3.6
455112cb
JB
18BuildRequires: python3-setuptools
19%if %{with tests}
455112cb
JB
20BuildRequires: python3-attrs >= 19.2.0
21BuildRequires: python3-pytest
22BuildRequires: python3-pytest-asyncio
23%endif
455112cb
JB
24BuildRequires: rpm-pythonprov
25BuildRequires: rpmbuild(macros) >= 1.714
26%if %{with doc}
27BuildRequires: python3-sphinx_rtd_theme
28BuildRequires: python3-sphinxcontrib-trio
29BuildRequires: sphinx-pdg-3
30%endif
77d8f197 31Requires: python3-modules >= 1:3.6
455112cb
JB
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36Capture the outcome of Python function calls.
37
38%description -l pl.UTF-8
39Przechwytywanie wyników wywołań funkcji pythonowych.
40
455112cb
JB
41%package apidocs
42Summary: API documentation for Python outcome module
43Summary(pl.UTF-8): Dokumentacja API modułu Pythona outcome
44Group: Documentation
45
46%description apidocs
47API documentation for Python outcome module.
48
49%description apidocs -l pl.UTF-8
50Dokumentacja API modułu Pythona outcome.
51
52%prep
53%setup -q -n outcome-%{version}
54
55%build
455112cb
JB
56%py3_build
57
58%if %{with tests}
59PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
60PYTEST_PLUGINS="pytest_asyncio.plugin" \
61PYTHONPATH=$(pwd)/src \
62%{__python3} -m pytest tests
63%endif
455112cb
JB
64
65%if %{with doc}
66PYTHONPATH=$(pwd)/src \
67%{__make} -C docs html \
68 SPHINXBUILD=sphinx-build-3
69%endif
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
455112cb 74%py3_install
455112cb
JB
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
455112cb
JB
79%files
80%defattr(644,root,root,755)
81%doc LICENSE LICENSE.MIT README.rst
455112cb
JB
82%{py3_sitescriptdir}/outcome
83%{py3_sitescriptdir}/outcome-%{version}-py*.egg-info
455112cb
JB
84
85%if %{with doc}
86%files apidocs
87%defattr(644,root,root,755)
88%doc docs/build/html/{_static,*.html,*.js}
89%endif
This page took 0.075894 seconds and 4 git commands to generate.