]> git.pld-linux.org Git - packages/python3-mdurl.git/blame - python3-mdurl.spec
rebuild with python 3.10
[packages/python3-mdurl.git] / python3-mdurl.spec
CommitLineData
8838c0a0
JB
1#
2# Conditional build:
3%bcond_with tests # unit tests (not included in sdist)
4
5Summary: Markdown URL utilities
6Summary(pl.UTF-8): Narzędzia do URL-i w formacie Markdown
7Name: python3-mdurl
8Version: 0.1.0
bfcf7c53 9Release: 2
8838c0a0
JB
10License: MIT
11Group: Libraries/Python
12#Source0Download: https://pypi.org/simple/mdurl/
13Source0: https://files.pythonhosted.org/packages/source/m/mdurl/mdurl-%{version}.tar.gz
14# Source0-md5: 148af8104f656a6fd70877505bc3fa2c
15URL: https://pypi.org/project/mdurl/
16BuildRequires: python3-modules >= 1:3.6
17BuildRequires: python3-setuptools
18%if %{with tests}
19BuildRequires: python3-pytest
20BuildRequires: python3-pytest-randomly
21%endif
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.714
24Requires: python3-modules >= 1:3.6
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29URL utilities for markdown-it parser.
30
31%description -l pl.UTF-8
32Narzędzia do URL-i dla parsera markdown-it.
33
34%prep
35%setup -q -n mdurl-%{version}
36
37# setuptools stub
38cat >setup.py <<EOF
39from setuptools import setup
40setup()
41EOF
42
43# (extracted from pyproject.toml - keep in sync!)
44cat >setup.cfg <<'EOF'
45[metadata]
46name = mdurl
47version = %{version}
48description = Markdown URL utilities
49author = Taneli Hukkinen
50author_email = hukkin@users.noreply.github.com
51license = MIT
52license_file = LICENSE
53classifiers =
54 License :: OSI Approved :: MIT License
55 Operating System :: MacOS
56 Operating System :: Microsoft :: Windows
57 Operating System :: POSIX :: Linux
58 Programming Language :: Python :: 3 :: Only
59 Programming Language :: Python :: 3.6
60 Programming Language :: Python :: 3.7
61 Programming Language :: Python :: 3.8
62 Programming Language :: Python :: 3.9
63 Programming Language :: Python :: 3.10
64 Programming Language :: Python :: Implementation :: CPython
65 Programming Language :: Python :: Implementation :: PyPy
66 Topic :: Software Development :: Libraries :: Python Modules
67 Typing :: Typed
68[options]
69packages = find:
70package_dir =
71 =src
72python_requires = >=3.6
73[options.packages.find]
74where=src
75EOF
76
77%build
78%py3_build
79
80%if %{with tests}
81PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
82PYTEST_PLUGINS="pytest_randomly" \
83%{__python3} -m pytest tests
84%endif
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89%py3_install
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(644,root,root,755)
96%doc LICENSE README.md
97%{py3_sitescriptdir}/mdurl
98%{py3_sitescriptdir}/mdurl-%{version}-py*.egg-info
This page took 0.111408 seconds and 4 git commands to generate.