]> git.pld-linux.org Git - packages/python3-libvirt.git/blame - python3-libvirt.spec
rebuild with tests and docs
[packages/python3-libvirt.git] / python3-libvirt.spec
CommitLineData
89f4ed07
JB
1#
2# Conditional build:
3%bcond_without lxc # LXC support
4%bcond_without qemu # Qemu support
5
6# qemu available only on x86 and ppc
7%ifnarch %{ix86} %{x8664} x32 ppc
8%undefine with_qemu
9%endif
10
11%define origname libvirt-python
12Summary: Python 3.x bindings to interact with virtualization capabilities
13Summary(pl.UTF-8): Wiązania Pythona 3.x do współpracy z funkcjami wirtualizacji
14Name: python3-libvirt
15Version: 6.6.0
e5954402 16Release: 6
89f4ed07
JB
17License: LGPL v2.1+
18Group: Development/Languages/Python
19Source0: https://libvirt.org/sources/python/%{origname}-%{version}.tar.gz
20# Source0-md5: f153718d1d47c2e101b2e152e75fabd3
21URL: https://libvirt.org/
22BuildRequires: libvirt-devel >= 6.6.0
23BuildRequires: pkgconfig
24BuildRequires: python3 >= 1:3.5
25BuildRequires: python3-devel >= 1:3.5
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.714
28BuildConflicts: python-PyXML < 0.8.4-13
29Requires: libvirt >= 6.6.0
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Libvirt is a C toolkit to interact with the virtualization
34capabilities of recent versions of Linux.
35
36This package contains the Python 3.x bindings for the libvirt library.
37
38%description -l pl.UTF-8
39Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
40obecnych wersji Linuksa.
41
42Ten pakiet zawiera wiązania Pythona 3.x do biblioteki libvirt.
43
44%prep
45%setup -q -n %{origname}-%{version}
46
47%build
48%py3_build
49
50%install
51rm -rf $RPM_BUILD_ROOT
52
53%py3_install
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
60%doc AUTHORS ChangeLog README
61%attr(755,root,root) %{py3_sitedir}/libvirtmod.cpython-*.so
62%{py3_sitedir}/libvirt.py
63%{py3_sitedir}/__pycache__/libvirt.cpython-*.py[co]
64%{py3_sitedir}/libvirtaio.py
65%{py3_sitedir}/__pycache__/libvirtaio.cpython-*.py[co]
66%if %{with lxc}
67%attr(755,root,root) %{py3_sitedir}/libvirtmod_lxc.cpython-*.so
68%{py3_sitedir}/libvirt_lxc.py
69%{py3_sitedir}/__pycache__/libvirt_lxc.cpython-*.py[co]
70%endif
71%if %{with qemu}
72%attr(755,root,root) %{py3_sitedir}/libvirtmod_qemu.cpython-*.so
73%{py3_sitedir}/libvirt_qemu.py
74%{py3_sitedir}/__pycache__/libvirt_qemu.cpython-*.py[co]
75%endif
76%{py3_sitedir}/libvirt_python-%{version}-py*.egg-info
This page took 0.184142 seconds and 4 git commands to generate.