]> git.pld-linux.org Git - packages/python3-hypothesis.git/blame - python3-hypothesis.spec
rebuild with python 3.10
[packages/python3-hypothesis.git] / python3-hypothesis.spec
CommitLineData
528fbc5b
JB
1#
2# Conditional build:
3%bcond_with tests # nothing currently
4
5Summary: Hypothesis - library for property based testing
6Summary(pl.UTF-8): Hypothesis - biblioteka do testowania opartego na własnościach
7Name: python3-hypothesis
9e944ea4 8Version: 5.49.0
3b1d8640 9Release: 3
528fbc5b
JB
10License: MPL v2.0
11Group: Libraries/Python
12#Source0Download: https://pypi.org/simple/hypothesis/
13Source0: https://files.pythonhosted.org/packages/source/h/hypothesis/hypothesis-%{version}.tar.gz
9e944ea4 14# Source0-md5: 350fda2e928cc59a38160d9c72f3631c
528fbc5b 15URL: https://github.com/DRMacIver/hypothesis
9e944ea4 16BuildRequires: python3-modules >= 1:3.6
528fbc5b
JB
17BuildRequires: python3-setuptools >= 1:36.2
18%if %{with tests}
19BuildRequires: python3-attrs >= 19.2.0
20BuildRequires: python3-sortedcontainers >= 2.1.0
21BuildRequires: python3-sortedcontainers < 3.0.0
22%endif
23BuildRequires: rpm-pythonprov
24BuildRequires: rpmbuild(macros) >= 1.714
9e944ea4 25Requires: python3-modules >= 1:3.6
528fbc5b
JB
26# for individual -extras modules:
27#Suggests: python3-dateutil >= 1.4
9e944ea4 28#Suggests: python3-django >= 2.2
528fbc5b
JB
29#Suggests: python3-dpcontracts >= 0.4
30#Suggests: python3-lark-parser >= 0.6.5
31#Suggests: python3-numpy >= 1.9.0
9e944ea4 32#Suggests: python3-pandas >= 0.25
528fbc5b
JB
33#Suggests: python3-pytest >= 4.3
34#Suggests: python3-pytz >= 2014.1
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Hypothesis is a library for testing your Python code against a much
40larger range of examples than you would ever want to write by hand.
41It's based on the Haskell library, Quickcheck, and is designed to
42integrate seamlessly into your existing Python unit testing work flow.
43
44%description -l pl.UTF-8
45Hypothesis to biblioteka do testowania kodu w Pythonie względem dużo
46większej liczby przykładów, niż kiedykolwiek chciałoby się pisać
47ręcznie. Jest oparta na bibliotece Quickcheck języka Haskell i została
48zaprojektowana tak, aby w sposób przezroczysty integrowała się z
49istniejącym przepływem testów jednostkowych w Pythonie.
50
51%prep
52%setup -q -n hypothesis-%{version}
53
54%build
55%py3_build
56
57%install
58rm -rf $RPM_BUILD_ROOT
59
60%py3_install
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(644,root,root,755)
67%doc README.rst
9e944ea4 68%attr(755,root,root) %{_bindir}/hypothesis
528fbc5b
JB
69%{py3_sitescriptdir}/hypothesis
70%{py3_sitescriptdir}/hypothesis-%{version}-py*.egg-info
This page took 0.124717 seconds and 4 git commands to generate.