]> git.pld-linux.org Git - packages/python3-cryptography.git/blame - python3-cryptography.spec
rel 1
[packages/python3-cryptography.git] / python3-cryptography.spec
CommitLineData
06232684
JB
1#
2# Conditional build:
f63b1331 3%bcond_without doc # Sphinx documentation
163a4ef8 4%bcond_without tests # unit test
06232684 5
7791f4ce
JP
6%define crates_ver 35.0.0
7
59f13c5c
JR
8Summary: Crypthography library for Python 3
9Summary(pl.UTF-8): Biblioteka Cryptography dla Pythona 3
10Name: python3-cryptography
11Version: 35.0.0
d6890838 12Release: 1
d6e7edf5 13License: Apache v2.0 or BSD
06232684 14Group: Libraries/Python
29d4b67b 15#Source0Download: https://pypi.org/simple/cryptography/
7df50b22 16Source0: https://files.pythonhosted.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
59f13c5c 17# Source0-md5: ba34eba3ae36cbf3d2e1ee3239f07732
163a4ef8
JB
18#Source1Download: https://pypi.org/simple/cryptography_vectors/
19Source1: https://files.pythonhosted.org/packages/source/c/cryptography-vectors/cryptography_vectors-%{version}.tar.gz
59f13c5c 20# Source1-md5: 8e9d050bd601d1788883fa361c69cf85
7791f4ce
JP
21# cd cryptography-%{version}/src/rust
22# cargo vendor
23# tar cJf python3-cryptography-crates-%{version}.tar.xz vendor Cargo.lock
24Source2: %{name}-crates-%{crates_ver}.tar.xz
25# Source2-md5: c3398eb08b99552f09b8b8f16d0d3910
06232684 26URL: https://cryptography.io/
0f792d56 27BuildRequires: openssl-devel >= 1.1.0
0f792d56
JB
28BuildRequires: python3-cffi >= 1.12
29BuildRequires: python3-devel >= 1:3.6
29d4b67b 30BuildRequires: python3-setuptools >= 18.5
c1d4b28c 31BuildRequires: python3-setuptools_rust
06232684 32BuildRequires: python3-six >= 1.4.1
7791f4ce
JP
33BuildRequires: rpm-pythonprov >= 5.4.15-48
34BuildRequires: rpmbuild(macros) >= 2.004
35BuildRequires: rust >= 1.41.0
049a803f 36%if %{with tests}
049a803f 37BuildRequires: python3-hypothesis >= 1.11.4
049a803f
JB
38BuildRequires: python3-iso8601
39BuildRequires: python3-pretend
29d4b67b 40BuildRequires: python3-pytest >= 3.6.0
f63b1331
JB
41BuildRequires: python3-pytz
42%endif
f63b1331
JB
43%if %{with doc}
44BuildRequires: python3-sphinx_rtd_theme
45BuildRequires: sphinx-pdg-3 >= 1.6.5
7791f4ce
JP
46BuildRequires: tar >= 1:1.22
47BuildRequires: xz
06232684 48%endif
0f792d56 49Requires: openssl >= 1.1.0
7791f4ce 50ExclusiveArch: %{rust_arches}
06232684
JB
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
59f13c5c 54cryptography is a package which provides cryptographic recipes and
06232684 55primitives to Python developers. Our goal is for it to be your
59f13c5c
JR
56"cryptographic standard library". It supports Python 3.6+ and
57PyPy3 7.2+.
06232684 58
59f13c5c
JR
59cryptography includes both high level recipes and low level interfaces
60to common cryptographic algorithms such as symmetric ciphers, message
61digests, and key derivation functions.
06232684
JB
62
63%description -l pl.UTF-8
64cryptography to pakiet zaprojektowany w celu udostępnienia funkcji i
65obiektów kryptograficznych programistom Pythona. Celem jest
66dostarczenie "standardowej biblioteki kryptograficznej". Obsługuje
59f13c5c 67Pythona 3.6+ oraz PyPy 7.2+.
06232684
JB
68
69cryptography zawiera zarówno funkcje wysokopoziomowe, jak i
70niskopoziomowe interfejsy do popularnych algorytmów kryptograficznych,
226a2f8d 71takich jak szyfry symetryczne, skróty wiadomości czy funkcje
06232684
JB
72wyprowadzające klucze.
73
f63b1331
JB
74%package apidocs
75Summary: API documentation for cryptography module
76Summary(pl.UTF-8): Dokumentacja API modułu cryptography
77Group: Documentation
094f23d7 78BuildArch: noarch
f63b1331
JB
79
80%description apidocs
81API documentation for cryptography module.
82
83%description apidocs -l pl.UTF-8
84Dokumentacja API modułu cryptography.
85
06232684 86%prep
163a4ef8
JB
87%setup -q -n cryptography-%{version} %{?with_tests:-a1}
88
89%if %{with tests}
90%{__mv} cryptography_vectors-%{version}/cryptography_vectors .
91%endif
06232684 92
7791f4ce
JP
93cd src/rust
94tar xf %{SOURCE2}
95# use our offline registry
96export CARGO_HOME="$(pwd)/.cargo"
97
98mkdir -p "$CARGO_HOME"
99cat >.cargo/config <<EOF
100[source.crates-io]
101registry = 'https://github.com/rust-lang/crates.io-index'
102replace-with = 'vendored-sources'
103
104[source.vendored-sources]
105directory = '$PWD/vendor'
106EOF
107
06232684 108%build
7791f4ce
JP
109export CARGO_HOME="$(pwd)/src/rust/.cargo"
110export CARGO_OFFLINE=true
111export RUSTFLAGS="%{rpmrustflags}"
112export CARGO_TERM_VERBOSE=true
113%ifarch x32
114export CARGO_BUILD_TARGET=x86_64-unknown-linux-gnux32
115%endif
116
06232684
JB
117export CFLAGS="%{rpmcflags}"
118
503cd915
JB
119%py3_build
120
121%if %{with tests}
122PYTHONPATH=$(echo $(pwd)/build-3/lib.*) \
123%{__python3} -m pytest tests
124%endif
06232684 125
f63b1331
JB
126%if %{with doc}
127%{__make} -C docs html \
128 SPHINXBUILD=sphinx-build-3
129%endif
130
06232684
JB
131%install
132rm -rf $RPM_BUILD_ROOT
133
7791f4ce
JP
134export CARGO_HOME="$(pwd)/src/rust/.cargo"
135export CARGO_OFFLINE=true
136export RUSTFLAGS="%{rpmrustflags}"
137export CARGO_TERM_VERBOSE=true
138%ifarch x32
139export CARGO_BUILD_TARGET=x86_64-unknown-linux-gnux32
140%endif
141
6d1f8f74 142%py3_install
06232684
JB
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
06232684
JB
147%files
148%defattr(644,root,root,755)
7a9c1d53 149%doc CHANGELOG.rst CONTRIBUTING.rst LICENSE LICENSE.APACHE LICENSE.BSD README.rst
06232684 150%dir %{py3_sitedir}/cryptography
06232684 151%{py3_sitedir}/cryptography/*.py
7a9c1d53 152%{py3_sitedir}/cryptography/py.typed
06232684
JB
153%{py3_sitedir}/cryptography/__pycache__
154%dir %{py3_sitedir}/cryptography/hazmat
155%{py3_sitedir}/cryptography/hazmat/*.py
156%{py3_sitedir}/cryptography/hazmat/__pycache__
157%dir %{py3_sitedir}/cryptography/hazmat/backends
158%{py3_sitedir}/cryptography/hazmat/backends/*.py
159%{py3_sitedir}/cryptography/hazmat/backends/__pycache__
06232684
JB
160%dir %{py3_sitedir}/cryptography/hazmat/backends/openssl
161%{py3_sitedir}/cryptography/hazmat/backends/openssl/*.py
162%{py3_sitedir}/cryptography/hazmat/backends/openssl/__pycache__
163%dir %{py3_sitedir}/cryptography/hazmat/bindings
164%{py3_sitedir}/cryptography/hazmat/bindings/*.py
165%{py3_sitedir}/cryptography/hazmat/bindings/__pycache__
d198b5a4 166%attr(755,root,root) %{py3_sitedir}/cryptography/hazmat/bindings/_*.so
7a9c1d53
JP
167%dir %{py3_sitedir}/cryptography/hazmat/bindings/_rust
168%{py3_sitedir}/cryptography/hazmat/bindings/_rust/*.pyi
06232684
JB
169%dir %{py3_sitedir}/cryptography/hazmat/bindings/openssl
170%{py3_sitedir}/cryptography/hazmat/bindings/openssl/*.py
171%{py3_sitedir}/cryptography/hazmat/bindings/openssl/__pycache__
172%dir %{py3_sitedir}/cryptography/hazmat/primitives
173%{py3_sitedir}/cryptography/hazmat/primitives/*.py
174%{py3_sitedir}/cryptography/hazmat/primitives/__pycache__
175%dir %{py3_sitedir}/cryptography/hazmat/primitives/asymmetric
176%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/*.py
177%{py3_sitedir}/cryptography/hazmat/primitives/asymmetric/__pycache__
178%dir %{py3_sitedir}/cryptography/hazmat/primitives/ciphers
179%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/*.py
180%{py3_sitedir}/cryptography/hazmat/primitives/ciphers/__pycache__
181%dir %{py3_sitedir}/cryptography/hazmat/primitives/kdf
182%{py3_sitedir}/cryptography/hazmat/primitives/kdf/*.py
183%{py3_sitedir}/cryptography/hazmat/primitives/kdf/__pycache__
f63b1331
JB
184%dir %{py3_sitedir}/cryptography/hazmat/primitives/serialization
185%{py3_sitedir}/cryptography/hazmat/primitives/serialization/*.py
186%{py3_sitedir}/cryptography/hazmat/primitives/serialization/__pycache__
f7d88309
AM
187%dir %{py3_sitedir}/cryptography/hazmat/primitives/twofactor
188%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/*.py
189%{py3_sitedir}/cryptography/hazmat/primitives/twofactor/__pycache__
d198b5a4
AM
190%dir %{py3_sitedir}/cryptography/x509
191%{py3_sitedir}/cryptography/x509/*.py
192%{py3_sitedir}/cryptography/x509/__pycache__
06232684 193%{py3_sitedir}/cryptography-%{version}-py*.egg-info
f63b1331
JB
194
195%if %{with doc}
196%files apidocs
197%defattr(644,root,root,755)
503cd915 198%doc docs/_build/html/{_downloads,_static,development,hazmat,x509,*.html,*.js}
f63b1331 199%endif
This page took 0.095832 seconds and 4 git commands to generate.