]> git.pld-linux.org Git - packages/python3-aiosignal.git/blame - python3-aiosignal.spec
- pl, cleanups, updated dependencies
[packages/python3-aiosignal.git] / python3-aiosignal.spec
CommitLineData
d954da7f
JR
1#
2# Conditional build:
3%bcond_without doc # API documentation
4%bcond_without tests # unit tests
5
6%define module aiosignal
7Summary: A list of registered asynchronous callbacks
1c0b2725 8Summary(pl.UTF-8): Lista zarejestrowanych asynchronicznych wywołań zwrotnych
d954da7f
JR
9Name: python3-%{module}
10Version: 1.2.0
11Release: 1
12License: Apache v2.0
13Group: Libraries/Python
14Source0: https://files.pythonhosted.org/packages/source/a/aiosignal/%{module}-%{version}.tar.gz
15# Source0-md5: 011700c3acc576a3a38deade6a4860cb
16URL: https://pypi.org/project/aiosignal/
1c0b2725 17BuildRequires: python3-modules >= 1:3.6
d954da7f
JR
18BuildRequires: python3-setuptools
19%if %{with tests}
1c0b2725 20BuildRequires: python3-frozenlist >= 1.1.0
d954da7f
JR
21%endif
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.714
24%if %{with doc}
1c0b2725
JB
25BuildRequires: python3-aiohttp_theme
26BuildRequires: python3-sphinxcontrib-asyncio
d954da7f
JR
27BuildRequires: sphinx-pdg-3
28%endif
1c0b2725 29Requires: python3-modules >= 1:3.6
d954da7f
JR
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34A project to manage callbacks in asyncio projects.
35
36Signal is a list of registered asynchronous callbacks.
37
1c0b2725
JB
38%description -l pl.UTF-8
39Projekt do zarządzania wywołaniami zwrotnymi w projektach asyncio.
40
41Sygnał to lista zarejestrowanych asynchronicznych wywołań zwrotnych.
42
d954da7f
JR
43%package apidocs
44Summary: API documentation for Python %{module} module
45Summary(pl.UTF-8): Dokumentacja API modułu Pythona %{module}
46Group: Documentation
47
48%description apidocs
49API documentation for Python %{module} module.
50
51%description apidocs -l pl.UTF-8
52Dokumentacja API modułu Pythona %{module}.
53
54%prep
55%setup -q -n %{module}-%{version}
56
57%build
58%py3_build
59
60%if %{with tests}
1c0b2725 61PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
d954da7f
JR
62%{__python3} -m pytest tests
63%endif
64
65%if %{with doc}
66%{__make} -C docs html \
67 SPHINXBUILD=sphinx-build-3
d954da7f
JR
68%endif
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73%py3_install
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
79%defattr(644,root,root,755)
80%doc CHANGES.rst CONTRIBUTORS.txt README.rst
81%dir %{py3_sitescriptdir}/%{module}
82%{py3_sitescriptdir}/%{module}/*.py
83%{py3_sitescriptdir}/%{module}/*.pyi
84%{py3_sitescriptdir}/%{module}/py.typed
85%{py3_sitescriptdir}/%{module}/__pycache__
86%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
87
88%if %{with doc}
89%files apidocs
90%defattr(644,root,root,755)
1c0b2725 91%doc docs/_build/html/{_static,*.html,*.js}
d954da7f 92%endif
This page took 0.126468 seconds and 4 git commands to generate.