]> git.pld-linux.org Git - packages/python3-PyQt-builder.git/blame - python3-PyQt-builder.spec
rebuild with python 3.10
[packages/python3-PyQt-builder.git] / python3-PyQt-builder.spec
CommitLineData
02386607
JR
1%define pypi_name PyQt-builder
2Summary: The PEP 517 compliant PyQt build system
3Name: python3-PyQt-builder
4Version: 1.10.1
1b1fa9aa 5Release: 3
02386607
JR
6License: BSD
7#Source0Download: https://pypi.org/simple/PyQt-builder
8Source0: https://files.pythonhosted.org/packages/source/P/PyQt-builder/%{pypi_name}-%{version}.tar.gz
9# Source0-md5: 1301fa247a5fe3cfa0da05b55100b661
10URL: https://www.riverbankcomputing.com/software/pyqt/
11BuildRequires: python3-devel
12BuildRequires: python3-setuptools
13BuildArch: noarch
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17PyQt-builder is the PEP 517 compliant build system for PyQt and
18projects that extend PyQt. It extends the sip build system and uses
19Qt's qmake to perform the actual compilation and installation of
20extension modules.Projects that use PyQt- builder provide an
21appropriate pyproject.toml file and an optional project.py.
22
23%prep
24%setup -q -n %{pypi_name}-%{version}
25
26%{__rm} -r PyQt_builder.egg-info
27
28%build
29%py3_build
30
31%install
32rm -rf $RPM_BUILD_ROOT
33%py3_install
34
35%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/pyqtbuild/bundle/dlls
36
37%clean
38rm -rf $RPM_BUILD_ROOT
39
40%files
41%defattr(644,root,root,755)
42%attr(755,root,root) %{_bindir}/pyqt-bundle
43%attr(755,root,root) %{_bindir}/pyqt-qt-wheel
44%{py3_sitescriptdir}/pyqtbuild
45%{py3_sitescriptdir}/PyQt_builder-%{version}-py*.egg-info
This page took 0.063005 seconds and 4 git commands to generate.