]> git.pld-linux.org Git - packages/python-zope.event.git/blame - python-zope.event.spec
- release 4 (by relup.sh)
[packages/python-zope.event.git] / python-zope.event.spec
CommitLineData
20ecb65d
JK
1#
2# Conditional build:
009fac46
JB
3%bcond_without doc # Sphinx documentation
4%bcond_without tests # unit tests
20ecb65d
JK
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
ca549da7 8%define module zope.event
32ee3d05 9Summary: Simple event system
aba200e4 10Summary(pl.UTF-8): Prosty system zdarzeń
ca549da7 11Name: python-%{module}
009fac46 12Version: 4.4
ec511219 13Release: 4
009fac46 14License: ZPL v2.1
32ee3d05 15Group: Libraries/Python
009fac46 16#Source0Download: https://pypi.org/simple/zope-event/
304869f6 17Source0: https://files.pythonhosted.org/packages/source/z/zope.event/zope.event-%{version}.tar.gz
009fac46
JB
18# Source0-md5: 54e5bf148548726d626ec47bb01bec41
19URL: https://www.zope.org/
20ecb65d 20%if %{with python2}
009fac46
JB
21BuildRequires: python >= 1:2.7
22BuildRequires: python-devel >= 1:2.7
956d0051 23BuildRequires: python-setuptools
009fac46
JB
24%if %{with tests}
25BuildRequires: python-zope.testrunner
26%endif
20ecb65d
JK
27%endif
28%if %{with python3}
009fac46
JB
29BuildRequires: python3 >= 1:3.4
30BuildRequires: python3-devel >= 1:3.4
20ecb65d 31BuildRequires: python3-setuptools
009fac46
JB
32%if %{with tests}
33BuildRequires: python3-zope.testrunner
34%endif
20ecb65d 35%endif
aba200e4 36BuildRequires: rpm-pythonprov
009fac46
JB
37BuildRequires: rpmbuild(macros) >= 1.714
38%if %{with doc}
39BuildRequires: sphinx-pdg
40%endif
41Requires: python-modules >= 1:2.7
42Requires: python-zope-base
ca549da7 43Obsoletes: Zope-Event
7e49dd1c 44BuildArch: noarch
905c77f3 45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
aba200e4 48The zope.event package provides a simple event system. It provides:
32ee3d05 49- an event publishing system
aba200e4
JB
50- a very simple event-dispatching system on which more sophisticated
51 event dispatching systems can be built. (For example, a type-based
52 event dispatching system that builds on zope.event can be found in
53 zope.component)
54
55%description -l pl.UTF-8
56Pakiet zope.event udostępnia prosty system zdarzeń. Zawiera:
57- system publikacji zdarzeń
58- bardzo prosty system przekazywania zdarzeń, w oparciu o który można
956d0051 59 stworzyć bardziej wyszukane systemy przekazywania zdarzeń (na przykład
60 system przekazywania zdarzeń oparty na typach, zbudowany w oparciu o
61 zope.event, można znaleźć w zope.component)
905c77f3 62
20ecb65d
JK
63%package -n python3-%{module}
64Summary: Simple event system
65Summary(pl.UTF-8): Prosty system zdarzeń
66Group: Libraries/Python
009fac46
JB
67Requires: python3-modules >= 1:3.4
68Requires: python3-zope-base
20ecb65d
JK
69
70%description -n python3-%{module}
71The zope.event package provides a simple event system. It provides:
72- an event publishing system
73- a very simple event-dispatching system on which more sophisticated
74 event dispatching systems can be built. (For example, a type-based
75 event dispatching system that builds on zope.event can be found in
76 zope.component)
77
78%description -n python3-%{module} -l pl.UTF-8
79Pakiet zope.event udostępnia prosty system zdarzeń. Zawiera:
80- system publikacji zdarzeń
81- bardzo prosty system przekazywania zdarzeń, w oparciu o który można
82 stworzyć bardziej wyszukane systemy przekazywania zdarzeń (na przykład
83 system przekazywania zdarzeń oparty na typach, zbudowany w oparciu o
84 zope.event, można znaleźć w zope.component)
85
009fac46
JB
86%package apidocs
87Summary: API documentation for Python zope.event module
88Summary(pl.UTF-8): Dokumentacja API modułu Pythona zope.event
89Group: Documentation
90
91%description apidocs
92API documentation for Python zope.event module.
93
94%description apidocs -l pl.UTF-8
95Dokumentacja API modułu Pythona zope.event.
96
905c77f3 97%prep
ca549da7 98%setup -q -n %{module}-%{version}
905c77f3 99
100%build
20ecb65d 101%if %{with python2}
009fac46
JB
102%py_build
103
104%if %{with tests}
105PYTHONPATH=$(pwd)/src \
106%{__python} -m zope.testrunner --test-path=src
107%endif
20ecb65d
JK
108%endif
109
110%if %{with python3}
009fac46
JB
111%py3_build
112
113%if %{with tests}
114PYTHONPATH=$(pwd)/src \
115%{__python3} -m zope.testrunner --test-path=src
116%endif
20ecb65d
JK
117%endif
118
009fac46
JB
119%if %{with doc}
120PYTHONPATH=$(pwd)/src \
4e39a7f3 121%{__make} -C docs html
009fac46 122%endif
905c77f3 123
124%install
125rm -rf $RPM_BUILD_ROOT
126
20ecb65d 127%if %{with python2}
406229c5 128%py_install \
7e49dd1c 129 --install-purelib=%{py_sitescriptdir}
905c77f3 130
aba200e4 131%py_postclean
20ecb65d
JK
132%endif
133
134%if %{with python3}
135%py3_install \
7e49dd1c 136 --install-purelib=%{py3_sitescriptdir}
20ecb65d 137%endif
905c77f3 138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
009fac46 142%if %{with python2}
905c77f3 143%files
144%defattr(644,root,root,755)
009fac46 145%doc CHANGES.rst COPYRIGHT.txt LICENSE.txt README.rst
7e49dd1c
AM
146%{py_sitescriptdir}/zope/event
147%{py_sitescriptdir}/zope.event-%{version}-py*.egg-info
148%{py_sitescriptdir}/zope.event-%{version}-py*-nspkg.pth
20ecb65d
JK
149%endif
150
009fac46 151%if %{with python3}
20ecb65d
JK
152%files -n python3-%{module}
153%defattr(644,root,root,755)
7e49dd1c
AM
154%{py3_sitescriptdir}/zope/event
155%{py3_sitescriptdir}/zope.event-%{version}-py*.egg-info
156%{py3_sitescriptdir}/zope.event-%{version}-py*-nspkg.pth
009fac46
JB
157%endif
158
159%if %{with doc}
160%files apidocs
161%defattr(644,root,root,755)
162%doc docs/_build/html/{_modules,_static,*.html,*.js}
20ecb65d 163%endif
This page took 0.092879 seconds and 4 git commands to generate.