]> git.pld-linux.org Git - packages/python-zeep.git/blame - python-zeep.spec
- release 3 (by relup.sh)
[packages/python-zeep.git] / python-zeep.spec
CommitLineData
e70d2785 1# Conditional build:
56f3a955 2%bcond_with tests # unit tests
e70d2785
AM
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module zeep
7%define egg_name zeep
8%define pypi_name zeep
9Summary: A fast and modern Python SOAP client
10Name: python-%{pypi_name}
77ae36ae 11Version: 3.4.0
41f8e14e 12Release: 3
e70d2785
AM
13License: MIT
14Group: Libraries/Python
15Source0: https://pypi.debian.net/zeep/zeep-%{version}.tar.gz
77ae36ae 16# Source0-md5: 70f1b5bc7c35173a69bfea4f5ffa77e7
e70d2785
AM
17URL: https://pypi.org/project/zeep/
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-cached_property
22BuildRequires: python-defusedxml
23BuildRequires: python-modules
e70d2785
AM
24BuildRequires: python-requests-toolbelt
25BuildRequires: python-setuptools
56f3a955
JR
26BuildRequires: python-isodate >= 0.5.4
27BuildRequires: python-attrs >= 17.2.0
28BuildRequires: python-pretend >= 1.0.8
29BuildRequires: python-pyflakes >= 1.5.0
30BuildRequires: python-pycodestyle >= 2.0.0
31BuildRequires: python-mccabe >= 0.6.0
32BuildRequires: python-configparser
33BuildRequires: python-tornado
34%if %{with tests}
35BuildRequires: python-flake8-imports >= 0.1.1
36BuildRequires: python-flake8-debugger >= 1.4.0
37BuildRequires: python-flake8-blind-except >= 0.1.1
38BuildRequires: python-flake8 >= 3.3.0
39BuildRequires: python-isort >= 4.2.15
40BuildRequires: python-freezegun >= 0.3.8
41BuildRequires: python-pretend
42BuildRequires: python-pytest >= 3.1.3
43BuildRequires: python-pytest-cov >= 2.5.1
44BuildRequires: python-pytest-tornado >= 0.4.5
45BuildRequires: python-requests_mock >= 0.7.0
46%endif
e70d2785
AM
47%endif
48%if %{with python3}
49BuildRequires: python3-cached_property
50BuildRequires: python3-defusedxml
51BuildRequires: python3-modules
e70d2785
AM
52BuildRequires: python3-requests-toolbelt
53BuildRequires: python3-setuptools
56f3a955
JR
54BuildRequires: python3-isodate >= 0.5.4
55BuildRequires: python3-attrs >= 17.2.0
56BuildRequires: python3-pretend >= 1.0.8
57BuildRequires: python3-pyflakes >= 1.5.0
58BuildRequires: python3-pycodestyle >= 2.0.0
59BuildRequires: python3-mccabe >= 0.6.0
60BuildRequires: python3-tornado
61%if %{with tests}
62BuildRequires: python3-flake8-imports >= 0.1.1
63BuildRequires: python3-flake8-debugger >= 1.4.0
64BuildRequires: python3-flake8-blind-except >= 0.1.1
65BuildRequires: python3-flake8 >= 3.3.0
66BuildRequires: python3-isort >= 4.2.15
67BuildRequires: python3-freezegun >= 0.3.8
68BuildRequires: python3-pretend
69BuildRequires: python3-pytest >= 3.1.3
70BuildRequires: python3-pytest-cov >= 2.5.1
71BuildRequires: python3-pytest-tornado >= 0.4.5
72BuildRequires: python3-requests_mock >= 0.7.0
73%endif
e70d2785
AM
74%endif
75Requires: python-modules
76BuildArch: noarch
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79%description
80Highlights:
81- Compatible with Python 2.7, 3.3, 3.4, 3.5, 3.6, 3.7 and PyPy
82- Build on top of lxml and requests
83- Support for Soap 1.1, Soap 1.2 and HTTP bindings
84- Support for WS-Addressing headers
85- Support for WSSE (UserNameToken / x.509 signing)
86- Support for tornado async transport via gen.coroutine (Python 2.7+)
87- Support for asyncio via aiohttp (Python 3.5+)
88- Experimental support for XOP messages
89
90%package -n python3-%{pypi_name}
91Summary: A fast and modern Python SOAP client
92Group: Libraries/Python
93Requires: python3-modules
94
95%description -n python3-%{pypi_name}
96Highlights:
97- Compatible with Python 2.7, 3.3, 3.4, 3.5, 3.6, 3.7 and PyPy
98- Build on top of lxml and requests
99- Support for Soap 1.1, Soap 1.2 and HTTP bindings
100- Support for WS-Addressing headers
101- Support for WSSE (UserNameToken / x.509 signing)
102- Support for tornado async transport via gen.coroutine (Python 2.7+)
103- Support for asyncio via aiohttp (Python 3.5+)
104- Experimental support for XOP messages
105
106%prep
107%setup -q -n %{pypi_name}-%{version}
108
109%build
110%if %{with python2}
111%py_build %{?with_tests:test}
112%endif
113
114%if %{with python3}
115%py3_build %{?with_tests:test}
116%endif
117
118%install
119rm -rf $RPM_BUILD_ROOT
120
121%if %{with python2}
122%py_install
123
124%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
125%py_comp $RPM_BUILD_ROOT%{py_sitedir}
126
127%py_postclean
128%endif
129
130%if %{with python3}
131%py3_install
132%endif
133
134# in case there are examples provided
135%if %{with python2}
136install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{pypi_name}-%{version}
137cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-%{pypi_name}-%{version}
138find $RPM_BUILD_ROOT%{_examplesdir}/python-%{pypi_name}-%{version} -name '*.py' \
139 | xargs sed -i '1s|^#!.*python\b|#!%{__python}|'
140%endif
141%if %{with python3}
142install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{pypi_name}-%{version}
143cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-%{pypi_name}-%{version}
144find $RPM_BUILD_ROOT%{_examplesdir}/python3-%{pypi_name}-%{version} -name '*.py' \
145 | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
146%endif
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%if %{with python2}
152%files
153%defattr(644,root,root,755)
154%doc CHANGES CONTRIBUTORS* README*
155%{py_sitescriptdir}/%{module}
156%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
157%{_examplesdir}/python-%{pypi_name}-%{version}
158%endif
159
160%if %{with python3}
161%files -n python3-%{pypi_name}
162%defattr(644,root,root,755)
163%doc CHANGES CONTRIBUTORS* README*
164%{py3_sitescriptdir}/%{module}
165%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
166%{_examplesdir}/python3-%{pypi_name}-%{version}
167%endif
This page took 0.041292 seconds and 4 git commands to generate.