]> git.pld-linux.org Git - packages/python-x2go.git/blame - python-x2go.spec
- release 3 (by relup.sh)
[packages/python-x2go.git] / python-x2go.spec
CommitLineData
8f10fb59
ER
1#
2# Conditional build:
3%bcond_without doc # don't build doc
4%bcond_without python2 # CPython 2.x module
5%bcond_with python3 # CPython 3.x module
6
7%define module x2go
8Summary: Python module providing X2Go client API
9Name: python-%{module}
10Version: 0.5.0.3
c2ca105c 11Release: 3
8f10fb59
ER
12License: AGPLv3+
13Group: Development/Languages
14Source0: http://code.x2go.org/releases/source/python-%{module}/%{name}-%{version}.tar.gz
15# Source0-md5: b5359cd80779b5e50586f6dbf35fd659
16Patch0: python-x2go-py3.patch
17URL: http://www.x2go.org/
447960a5 18BuildRequires: rpmbuild(macros) >= 1.710
8f10fb59
ER
19BuildRequires: python-setuptools
20BuildRequires: rpm-pythonprov
21%if %{with python3}
22BuildRequires: python3-devel
23# For 2to3
24BuildRequires: python-tools
25%endif
26%if %{with doc}
27# For doc build
28BuildRequires: epydoc
29BuildRequires: python-gevent
30BuildRequires: python-paramiko
31BuildRequires: python-requests
32BuildRequires: python-simplejson
33# For docs
34BuildRequires: python-Xlib
35%endif
9e32465d
ER
36# for nxproxy
37Requires: nx
8f10fb59
ER
38Requires: python-Xlib
39Requires: python-gevent
40Requires: python-paramiko
41Requires: python-requests
42Requires: python-simplejson
43BuildArch: noarch
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47X2Go is a server based computing environment with:
48- session resuming
49- low bandwidth support
50- session brokerage support
51- client side mass storage mounting support
52- audio support
53- authentication by smartcard and USB stick
54
55This Python module allows you to integrate X2Go client support into
56your Python applications by providing a Python-based X2Go client API.
57
58%package doc
59Summary: Python X2Go client API documentation
60Group: Documentation
61Requires: %{name} = %{version}-%{release}
62
63%description doc
64This package contains the Python X2Go client API documentation.
65
66%package -n python3-%{module}
67Summary: Python module providing X2Go client API
68Group: Development/Languages
69
70%description -n python3-%{module}
71X2Go is a server based computing environment with:
72 - session resuming
73 - low bandwidth support
74 - session brokerage support
75 - client side mass storage mounting support
76 - audio support
77 - authentication by smartcard and USB stick
78
79This Python module allows you to integrate X2Go client support into
80your Python applications by providing a Python-based X2Go client API.
81
82%prep
83%setup -q
84
85%if %{with python3}
86rm -rf py3
87cp -a . py3
88%endif
89
90%build
6070e350 91%py_build
8f10fb59
ER
92
93%if %{with python3}
94cd py3
952to3 --write --nobackups py3
6070e350 96%py3_build
8f10fb59
ER
97cd ..
98%endif
99
100%if %{with doc}
101# Build the docs
102mkdir -p epydoc/html
103epydoc --debug -n "Python X2Go" -u http://www.x2go.org -v --html --no-private -o epydoc/html x2go/
104%endif
105
106%install
107rm -rf $RPM_BUILD_ROOT
108%if %{with python3}
109cd py3
6070e350 110%py3_install
8f10fb59
ER
111cd ..
112%endif
113
6070e350 114%py_install
8f10fb59
ER
115
116%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/x2go/tests
117
118%py_postclean
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%files
124%defattr(644,root,root,755)
125%doc COPYING README* TODO
126%{py_sitescriptdir}/x2go
127%{py_sitescriptdir}/x2go-%{version}-py*.egg-info
128
129%if %{with doc}
130%files doc
131%defattr(644,root,root,755)
132%doc epydoc/html/*
133%endif
134
135%if %{with python3}
136%files -n python3-%{module}
137%defattr(644,root,root,755)
138%endif
This page took 0.118977 seconds and 4 git commands to generate.