]> git.pld-linux.org Git - packages/python-u2flib-server.git/blame - python-u2flib-server.spec
rebuild with python 3.10
[packages/python-u2flib-server.git] / python-u2flib-server.spec
CommitLineData
5357bb03
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Python 2 based U2F server library
8Summary(pl.UTF-8): Biblioteka serwera U2F dla Pythona 2
9Name: python-u2flib-server
10Version: 5.0.0
aa73638f 11Release: 5
5357bb03
JB
12License: BSD
13Group: Libraries/Python
14Source0: https://developers.yubico.com/python-u2flib-server/Releases/%{name}-%{version}.tar.gz
15# Source0-md5: c87bc9984adf96e97aa35323dfc1edd4
16URL: https://developers.yubico.com/python-u2flib-server/
17BuildRequires: asciidoc
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.7
22BuildRequires: python-setuptools
23%if %{with tests}
24BuildRequires: python-cryptography >= 1.2
25BuildRequires: python-enum34
26BuildRequires: python-six
27%endif
28%endif
29%if %{with python3}
30BuildRequires: python3-modules >= 1:3.3
31BuildRequires: python3-setuptools
32%if %{with tests}
33BuildRequires: python3-cryptography >= 1.2
34BuildRequires: python3-six
35%endif
36%endif
37Requires: python-modules >= 1:2.7
38BuildArch: noarch
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42Provides functionality for working with the server side aspects of the
43U2F protocol as defined in FIDO specifications
44(<http://fidoalliance.org/specifications/download>).
45
46%description -l pl.UTF-8
47Pakiet zawiera funkcje obsługujące serwerowe aspekty protokołu U2F
48zdefiniowane w specyfikacji FIDO
49(<http://fidoalliance.org/specifications/download>).
50
51%package -n python3-u2flib-server
52Summary: Python 3 based U2F server library
53Summary(pl.UTF-8): Biblioteka serwera U2F dla Pythona 3
54Group: Libraries/Python
55Requires: python3-modules >= 1:3.3
56
57%description -n python3-u2flib-server
58Provides functionality for working with the server side aspects of the
59U2F protocol as defined in FIDO specifications
60(<http://fidoalliance.org/specifications/download>).
61
62%description -n python3-u2flib-server -l pl.UTF-8
63Pakiet zawiera funkcje obsługujące serwerowe aspekty protokołu U2F
64zdefiniowane w specyfikacji FIDO
65(<http://fidoalliance.org/specifications/download>).
66
67%prep
68%setup -q
69
70%build
71%if %{with python2}
72%py_build %{?with_tests:test}
73%endif
74
75%if %{with python3}
76%py3_build %{?with_tests:test}
77%endif
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82%if %{with python2}
83%py_install
84
85%py_postclean
86%endif
87
88%if %{with python3}
89%py3_install
90%endif
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%if %{with python2}
96%files
97%defattr(644,root,root,755)
98%doc COPYING ChangeLog NEWS README
99%{py_sitescriptdir}/u2flib_server
100%{py_sitescriptdir}/python_u2flib_server-%{version}-py*.egg-info
101%endif
102
103%if %{with python3}
104%files -n python3-u2flib-server
105%defattr(644,root,root,755)
106%doc COPYING ChangeLog NEWS README
107%{py3_sitescriptdir}/u2flib_server
108%{py3_sitescriptdir}/python_u2flib_server-%{version}-py*.egg-info
109%endif
This page took 0.114527 seconds and 4 git commands to generate.