]> git.pld-linux.org Git - packages/python-typing_extensions.git/blame - python-typing_extensions.spec
up to 3.10.0.2
[packages/python-typing_extensions.git] / python-typing_extensions.spec
CommitLineData
cb60dcfb
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Backported and Experimental Type Hints for Python 3.5+
8Summary(pl.UTF-8): Backportowane i eksperymentalne podpowiedzi typów dla Pythona 3.5+
9Name: python-typing_extensions
49fa9d95
JP
10Version: 3.10.0.2
11Release: 1
cb60dcfb
JB
12License: PSF
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/typing-extensions/
15Source0: https://files.pythonhosted.org/packages/source/t/typing-extensions/typing_extensions-%{version}.tar.gz
49fa9d95 16# Source0-md5: ed80ecc8eac5cb15840535ca54eb43f3
cb60dcfb
JB
17URL: https://pypi.org/project/typing-extensions/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.7
20BuildRequires: python-setuptools
21%if %{with tests}
22BuildRequires: python-typing >= 3.7.4
23%endif
24%endif
25%if %{with python3}
26BuildRequires: python3-modules >= 1:3.4
27BuildRequires: python3-setuptools
28%if %{with tests}
29%if "%{py3_ver}" < "3.4"
30BuildRequires: python3-typing >= 3.7.4
31%endif
32%endif
33%endif
34BuildRequires: rpm-pythonprov
35BuildRequires: rpmbuild(macros) >= 1.714
36Requires: python-modules >= 1:2.7
37BuildArch: noarch
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41The typing_extensions module contains both backports of Python typing
42module changes from Python 3.6-3.7 (includes types like Text or
43Coroutine) as well as experimental types that will eventually be added
44to the typing module, such as Protocol or TypedDict.
45
46%description -l pl.UTF-8
47Moduł typing_extensions zawiera backporty zmian modułu Pythona typing
48z wersji 3.6-3.7 (w tym typy takie jak Text czy Coroutine), a także
49eksperymentalne typy, które być może zostaną dodane do modułu typing,
50takie jak Protocol czy TypedDict.
51
52%package -n python3-typing_extensions
53Summary: Backported and Experimental Type Hints for Python 3.5+
54Summary(pl.UTF-8): Backportowane i eksperymentalne podpowiedzi typów dla Pythona 3.5+
55Group: Libraries/Python
56Requires: python3-modules >= 1:3.4
57
58%description -n python3-typing_extensions
59The typing_extensions module contains both backports of Python typing
60module changes from Python 3.5-3.7 (includes types like Text or
61Coroutine) as well as experimental types that will eventually be added
62to the typing module, such as Protocol or TypedDict.
63
64%description -n python3-typing_extensions -l pl.UTF-8
65Moduł typing_extensions zawiera backporty zmian modułu Pythona typing
66z wersji 3.6-3.7 (w tym typy takie jak Text czy Coroutine), a także
67eksperymentalne typy, które być może zostaną dodane do modułu typing,
68takie jak Protocol czy TypedDict.
69
70%prep
71%setup -q -n typing_extensions-%{version}
72
73%build
74%if %{with python2}
75%py_build
76
77%if %{with tests}
78%{__python} -m unittest discover -s src_py2
79%endif
80%endif
81
82%if %{with python3}
83%py3_build
84
85%if %{with tests}
86%{__python3} -m unittest discover -s src_py3
87%endif
88%endif
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93%if %{with python2}
94%py_install
95
96%py_postclean
97%endif
98
99%if %{with python3}
100%py3_install
101%endif
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%if %{with python2}
107%files
108%defattr(644,root,root,755)
109%doc LICENSE README.rst
110%{py_sitescriptdir}/typing_extensions.py[co]
111%{py_sitescriptdir}/typing_extensions-%{version}-py*.egg-info
112%endif
113
114%if %{with python3}
115%files -n python3-typing_extensions
116%defattr(644,root,root,755)
117%doc LICENSE README.rst
118%{py3_sitescriptdir}/typing_extensions.py
119%{py3_sitescriptdir}/__pycache__/typing_extensions.cpython-*.py[co]
120%{py3_sitescriptdir}/typing_extensions-%{version}-py*.egg-info
121%endif
This page took 0.139535 seconds and 4 git commands to generate.