]> git.pld-linux.org Git - packages/python-tox.git/blame - python-tox.spec
rebuild with tests and docs
[packages/python-tox.git] / python-tox.spec
CommitLineData
492d659a 1# TODO:
47bbc0f7 2# - packaging of
492d659a
MK
3# /usr/bin/tox
4# /usr/bin/tox-quickstart
a17b6a4a 5# - fix tests on builders
492d659a 6
492d659a 7# Conditional build:
492d659a
MK
8%bcond_without tests # do not perform "make test"
9%bcond_without python2 # CPython 2.x module
10%bcond_without python3 # CPython 3.x module
11
83312487 12%define module tox
492d659a
MK
13Summary: Virtualenv-based automation of test activities
14Summary(pl.UTF-8): Oparta na Virtualenv automatyka testów
15Name: python-%{module}
ec3b4bc6 16Version: 3.23.0
0d7ecfe1 17Release: 4
492d659a
MK
18License: MIT
19Group: Libraries/Python
83312487 20Source0: https://files.pythonhosted.org/packages/source/t/tox/tox-%{version}.tar.gz
ec3b4bc6 21# Source0-md5: bd96f55bb0b50be9aec5bab6094a3eb1
9ccf3ca2 22Patch0: virtualenv.patch
492d659a
MK
23URL: http://tox.testrun.org/
24BuildRequires: rpm-pythonprov
25BuildRequires: rpmbuild(macros) >= 1.714
26%if %{with python2}
ec3b4bc6
AM
27BuildRequires: python-filelock
28BuildRequires: python-flaky
492d659a
MK
29BuildRequires: python-modules
30BuildRequires: python-pluggy
31BuildRequires: python-virtualenv
ebc11277
MK
32BuildRequires: python-pytest >= 2.3.5
33BuildRequires: python-pytest-timeout
9c8d9d57 34BuildRequires: python-py
492d659a
MK
35%endif
36%if %{with python3}
ec3b4bc6
AM
37BuildRequires: python3-filelock
38BuildRequires: python3-flaky
492d659a
MK
39BuildRequires: python3-modules
40BuildRequires: python3-pluggy
41BuildRequires: python3-virtualenv
ebc11277
MK
42BuildRequires: python3-pytest >= 2.3.5
43BuildRequires: python3-pytest-timeout
9c8d9d57 44BuildRequires: python3-py
492d659a
MK
45%endif
46Requires: python-modules
47BuildArch: noarch
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
47bbc0f7
ER
51Tox is a generic virtualenv management and test command line tool you
52can use for:
53- checking your package installs correctly with different Python
54 versions and interpreters
55- running your tests in each of the environments, configuring your
56 test tool of choice
57- acting as a frontend to Continuous Integration servers, greatly
58 reducing boilerplate and merging CI and shell-based testing.
492d659a
MK
59
60%description -l pl.UTF-8
47bbc0f7
ER
61Tox jest ogólnym, operatym na virtualenv narzędziem linii poleceń
62które może być użyte do:
63- testowania czy pakiet instaluje się poprawnie z róznymi wersjami
64 Pythona
65- uruchamionia testów dla każdego ze środowisk, konfigurując narzędzia
66 testowe
67- jako frontend dla serwerów Continuous Integration,
492d659a
MK
68
69%package -n python3-%{module}
70Summary: Virtualenv-based automation of test activities
71Summary(pl.UTF-8): Oparta na Virtualenv automatyka testów
72Group: Libraries/Python
73Requires: python3-modules
74
75%description -n python3-%{module}
47bbc0f7
ER
76Tox is a generic virtualenv management and test command line tool you
77can use for:
78- checking your package installs correctly with different Python
79 versions and interpreters
80- running your tests in each of the environments, configuring your
81 test tool of choice
82- acting as a frontend to Continuous Integration servers, greatly
83 reducing boilerplate and merging CI and shell-based testing.
492d659a
MK
84
85%description -n python3-%{module} -l pl.UTF-8
47bbc0f7
ER
86Tox jest ogólnym, operatym na virtualenv narzędziem linii poleceń
87które może być użyte do:
88- testowania czy pakiet instaluje się poprawnie z róznymi wersjami
89 Pythona
90- uruchamionia testów dla każdego ze środowisk, konfigurując narzędzia
91 testowe
92- jako frontend dla serwerów Continuous Integration,
492d659a
MK
93
94%package apidocs
95Summary: %{module} API documentation
96Summary(pl.UTF-8): Dokumentacja API %{module}
97Group: Documentation
98
99%description apidocs
100API documentation for %{module}.
101
102%description apidocs -l pl.UTF-8
103Dokumentacja API %{module}.
104
105%prep
106%setup -q -n %{module}-%{version}
9ccf3ca2 107%patch0 -p1
492d659a
MK
108
109%build
110%if %{with python2}
111%py_build %{?with_tests:test}
112%endif
113
114%if %{with python3}
115%py3_build %{?with_tests:test}
116%endif
117
118%if %{with doc}
119cd docs
120%{__make} -j1 html
121rm -rf _build/html/_sources
122%endif
123
124%install
125rm -rf $RPM_BUILD_ROOT
492d659a
MK
126%if %{with python2}
127%py_install
492d659a
MK
128%py_postclean
129%endif
130
131%if %{with python3}
132%py3_install
133%endif
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%if %{with python2}
139%files
140%defattr(644,root,root,755)
ec3b4bc6 141%doc CONTRIBUTORS README.md
492d659a 142%{py_sitescriptdir}/%{module}
492d659a
MK
143%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
144%endif
492d659a
MK
145
146%if %{with python3}
147%files -n python3-%{module}
148%defattr(644,root,root,755)
ec3b4bc6
AM
149%doc CONTRIBUTORS README.md
150%attr(755,root,root) %{_bindir}/tox
151%attr(755,root,root) %{_bindir}/tox-quickstart
492d659a
MK
152%{py3_sitescriptdir}/%{module}
153%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
154%endif
155
156%if %{with doc}
157%files apidocs
158%defattr(644,root,root,755)
159%doc docs/_build/html/*
160%endif
This page took 0.357474 seconds and 4 git commands to generate.