]> git.pld-linux.org Git - packages/python-toposort.git/blame - python-toposort.spec
rebuild with python 3.10
[packages/python-toposort.git] / python-toposort.spec
CommitLineData
12d72a47
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Topological sort algorithm
8Summary(pl.UTF-8): Algorytm sortowania topologicznego
9Name: python-toposort
10Version: 1.5
6a5034f4 11Release: 4
12d72a47
JB
12License: Apache v2.0
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/toposort/
15Source0: https://files.pythonhosted.org/packages/source/t/toposort/toposort-%{version}.tar.gz
16# Source0-md5: 472cf86871d19b66d7cb18412c026959
17URL: https://pypi.org/project/toposort/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.7
20BuildRequires: python-setuptools
21%endif
22%if %{with python3}
23BuildRequires: python3-modules >= 1:3.3
24BuildRequires: python3-setuptools
25%endif
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.714
28Requires: python-modules >= 1:2.7
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33This module implements a topological sort algorithm.
34
35Topological sort (topsort, toposort) or topological ordering of a
36directed graph is a linear ordering of its vertices such that for
37every directed edge uv from vertex u to vertex v, u comes before v in
38the ordering.
39
40%description -l pl.UTF-8
41Ten moduł implementuje algorytm sortowania topologicznego.
42
43Sortowanie topologiczne (topsort, toposort), inaczej porządek
44topologiczny grafu skierowanego to porządek liniowy wierzchołków tego
45grafu taki, że dla każdej skierowanej krawędzi uv od wierzchołka u do
46wierzchołka v, u występuje przed v.
47
48%package -n python3-toposort
49Summary: Topological sort algorithm
50Summary(pl.UTF-8): Algorytm sortowania topologicznego
51Group: Libraries/Python
52Requires: python3-modules >= 1:3.3
53
54%description -n python3-toposort
55This module implements a topological sort algorithm.
56
57Topological sort (topsort, toposort) or topological ordering of a
58directed graph is a linear ordering of its vertices such that for
59every directed edge uv from vertex u to vertex v, u comes before v in
60the ordering.
61
62%description -n python3-toposort -l pl.UTF-8
63Ten moduł implementuje algorytm sortowania topologicznego.
64
65Sortowanie topologiczne (topsort, toposort), inaczej porządek
66topologiczny grafu skierowanego to porządek liniowy wierzchołków tego
67grafu taki, że dla każdej skierowanej krawędzi uv od wierzchołka u do
68wierzchołka v, u występuje przed v.
69
70%prep
71%setup -q -n toposort-%{version}
72
73%build
74%if %{with python2}
75%py_build
76
77%if %{with tests}
78%{__python} -m test.test_toposort
79%endif
80%endif
81
82%if %{with python3}
83%py3_build
84
85%if %{with tests}
86%{__python3} -m test.test_toposort
87%endif
88%endif
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93%if %{with python2}
94%py_install
95
96%py_postclean
97%endif
98
99%if %{with python3}
100%py3_install
101%endif
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%if %{with python2}
107%files
108%defattr(644,root,root,755)
109%doc CHANGES.txt NOTICE README.txt
110%{py_sitescriptdir}/toposort.py[co]
111%{py_sitescriptdir}/toposort-%{version}-py*.egg-info
112%endif
113
114%if %{with python3}
115%files -n python3-toposort
116%defattr(644,root,root,755)
117%doc CHANGES.txt NOTICE README.txt
118%{py3_sitescriptdir}/toposort.py
119%{py3_sitescriptdir}/__pycache__/toposort.cpython-*.py[co]
120%{py3_sitescriptdir}/toposort-%{version}-py*.egg-info
121%endif
This page took 0.116396 seconds and 4 git commands to generate.