]> git.pld-linux.org Git - packages/python-texext.git/blame - python-texext.spec
rebuild with python 3.10
[packages/python-texext.git] / python-texext.spec
CommitLineData
8832f1be
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Sphinx extensions for working with LaTeX math
8Summary(pl.UTF-8): Rozszerzenia Sphinksa do pracy z LaTeXowymi wzorami matematycznymi
9Name: python-texext
199a55e3 10Version: 0.6.5
289e6c00 11Release: 3
8832f1be
JB
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/texext/
15Source0: https://files.pythonhosted.org/packages/source/t/texext/texext-%{version}.tar.gz
199a55e3 16# Source0-md5: 4f86a0cd2e75f1779b713b8342c7cdc6
8832f1be
JB
17URL: https://pypi.org/project/texext/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.7
20BuildRequires: python-setuptools
21%if %{with tests}
22BuildRequires: python-Sphinx >= 1.3.1
199a55e3
JB
23BuildRequires: python-docutils >= 0.12
24BuildRequires: python-matplotlib >= 1.4.3
8832f1be 25BuildRequires: python-pytest
199a55e3
JB
26BuildRequires: python-six >= 1.4.0
27BuildRequires: python-sphinxtesters >= 0.2
28BuildRequires: python-sympy >= 0.7
8832f1be
JB
29%endif
30%endif
31%if %{with python3}
199a55e3 32BuildRequires: python3-modules >= 1:3.4
8832f1be
JB
33BuildRequires: python3-setuptools
34%if %{with tests}
35BuildRequires: python3-Sphinx >= 1.3.1
199a55e3
JB
36BuildRequires: python3-docutils >= 0.12
37BuildRequires: python3-matplotlib >= 1.4.3
8832f1be 38BuildRequires: python3-pytest
199a55e3
JB
39BuildRequires: python3-six >= 1.4.0
40BuildRequires: python3-sphinxtesters >= 0.2
41BuildRequires: python3-sympy >= 0.7
8832f1be
JB
42%endif
43%endif
44BuildRequires: rpm-pythonprov
45BuildRequires: rpmbuild(macros) >= 1.714
46Requires: python-modules >= 1:2.7
47BuildArch: noarch
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51texext contains a couple of Sphinx extensions for working with LaTeX
52math.
53
54%description -l pl.UTF-8
55texext zawiera kilka rozszerzeń Sphinksa do pracy z LaTeXowymi wzorami
56matematycznymi.
57
58%package -n python3-texext
59Summary: Sphinx extensions for working with LaTeX math
60Summary(pl.UTF-8): Rozszerzenia Sphinksa do pracy z LaTeXowymi wzorami matematycznymi
61Group: Libraries/Python
199a55e3 62Requires: python3-modules >= 1:3.4
8832f1be
JB
63
64%description -n python3-texext
65texext contains a couple of Sphinx extensions for working with LaTeX
66math.
67
68%description -n python3-texext -l pl.UTF-8
69texext zawiera kilka rozszerzeń Sphinksa do pracy z LaTeXowymi wzorami
70matematycznymi.
71
72%prep
73%setup -q -n texext-%{version}
74
75%build
76%if %{with python2}
77%py_build
78
79%if %{with tests}
80PYTHONPATH=$(pwd)/build-2/lib \
81%{__python} -m pytest texext/tests
82%endif
83%endif
84
85%if %{with python3}
86%py3_build
87
88%if %{with tests}
89PYTHONPATH=$(pwd)/build-2/lib \
90%{__python3} -m pytest texext/tests
91%endif
92%endif
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97%if %{with python2}
98%py_install
99
100%py_postclean
101%endif
102
103%if %{with python3}
104%py3_install
105%endif
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%if %{with python2}
111%files
112%defattr(644,root,root,755)
113%doc LICENSE README.rst
114%{py_sitescriptdir}/texext
115%{py_sitescriptdir}/texext-%{version}-py*.egg-info
116%endif
117
118%if %{with python3}
119%files -n python3-texext
120%defattr(644,root,root,755)
121%doc LICENSE README.rst
122%{py3_sitescriptdir}/texext
123%{py3_sitescriptdir}/texext-%{version}-py*.egg-info
124%endif
This page took 0.095154 seconds and 4 git commands to generate.