]> git.pld-linux.org Git - packages/python-texext.git/blame - python-texext.spec
- release 3 (by relup.sh)
[packages/python-texext.git] / python-texext.spec
CommitLineData
8832f1be
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Sphinx extensions for working with LaTeX math
8Summary(pl.UTF-8): Rozszerzenia Sphinksa do pracy z LaTeXowymi wzorami matematycznymi
9Name: python-texext
10Version: 0.6.1
25e47650 11Release: 3
8832f1be
JB
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/texext/
15Source0: https://files.pythonhosted.org/packages/source/t/texext/texext-%{version}.tar.gz
16# Source0-md5: a8bf2d509afdbc1307a0e7bfc4bd3eaf
17URL: https://pypi.org/project/texext/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.7
20BuildRequires: python-setuptools
21%if %{with tests}
22BuildRequires: python-Sphinx >= 1.3.1
23BuildRequires: python-pytest
24BuildRequires: python-six
39326f2d 25BuildRequires: python-sphinxtesters
8832f1be
JB
26BuildRequires: python-sympy
27%endif
28%endif
29%if %{with python3}
30BuildRequires: python3-modules >= 1:3.3
31BuildRequires: python3-setuptools
32%if %{with tests}
33BuildRequires: python3-Sphinx >= 1.3.1
34BuildRequires: python3-pytest
35BuildRequires: python3-six
39326f2d 36BuildRequires: python3-sphinxtesters
8832f1be
JB
37BuildRequires: python3-sympy
38%endif
39%endif
40BuildRequires: rpm-pythonprov
41BuildRequires: rpmbuild(macros) >= 1.714
42Requires: python-modules >= 1:2.7
43BuildArch: noarch
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47texext contains a couple of Sphinx extensions for working with LaTeX
48math.
49
50%description -l pl.UTF-8
51texext zawiera kilka rozszerzeń Sphinksa do pracy z LaTeXowymi wzorami
52matematycznymi.
53
54%package -n python3-texext
55Summary: Sphinx extensions for working with LaTeX math
56Summary(pl.UTF-8): Rozszerzenia Sphinksa do pracy z LaTeXowymi wzorami matematycznymi
57Group: Libraries/Python
58Requires: python3-modules >= 1:3.3
59
60%description -n python3-texext
61texext contains a couple of Sphinx extensions for working with LaTeX
62math.
63
64%description -n python3-texext -l pl.UTF-8
65texext zawiera kilka rozszerzeń Sphinksa do pracy z LaTeXowymi wzorami
66matematycznymi.
67
68%prep
69%setup -q -n texext-%{version}
70
71%build
72%if %{with python2}
73%py_build
74
75%if %{with tests}
76PYTHONPATH=$(pwd)/build-2/lib \
77%{__python} -m pytest texext/tests
78%endif
79%endif
80
81%if %{with python3}
82%py3_build
83
84%if %{with tests}
85PYTHONPATH=$(pwd)/build-2/lib \
86%{__python3} -m pytest texext/tests
87%endif
88%endif
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93%if %{with python2}
94%py_install
95
96%py_postclean
97%endif
98
99%if %{with python3}
100%py3_install
101%endif
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%if %{with python2}
107%files
108%defattr(644,root,root,755)
109%doc LICENSE README.rst
110%{py_sitescriptdir}/texext
111%{py_sitescriptdir}/texext-%{version}-py*.egg-info
112%endif
113
114%if %{with python3}
115%files -n python3-texext
116%defattr(644,root,root,755)
117%doc LICENSE README.rst
118%{py3_sitescriptdir}/texext
119%{py3_sitescriptdir}/texext-%{version}-py*.egg-info
120%endif
This page took 0.071657 seconds and 4 git commands to generate.