]> git.pld-linux.org Git - packages/python-sympy.git/blame - python-sympy.spec
- fixed doc build without sympy installed
[packages/python-sympy.git] / python-sympy.spec
CommitLineData
b336f80a
JR
1#
2# Conditional build:
cd938da9
JB
3%bcond_without doc # HTML and PDF documentation
4%bcond_without tests # unit tests
b336f80a
JR
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
cd938da9
JB
8Summary: Python 2 library for symbolic mathematics
9Summary(pl.UTF-8): Biblioteka Pythona 2 do matematyki symbolicznej
b336f80a 10Name: python-sympy
cd938da9 11Version: 1.4
afb29cf8 12Release: 1
b336f80a
JR
13License: BSD
14Group: Libraries/Python
cd938da9 15#Source0Download: https://github.com/sympy/sympy/releases
b336f80a 16Source0: https://github.com/sympy/sympy/releases/download/sympy-%{version}/sympy-%{version}.tar.gz
cd938da9
JB
17# Source0-md5: 478072d75b564c9356990e3027d464e6
18Patch0: %{name}-nodisplay.patch
19URL: https://www.sympy.org/
b336f80a
JR
20BuildRequires: gettext
21BuildRequires: graphviz
cd938da9
JB
22BuildRequires: rpmbuild(macros) >= 1.714
23BuildRequires: sed >= 4.0
b336f80a 24%if %{with python2}
cd938da9
JB
25BuildRequires: python-devel >= 1:2.7
26BuildRequires: python-setuptools
27%if %{with tests}
28BuildRequires: python-devel-tools
29BuildRequires: python-mpmath >= 0.19
b336f80a
JR
30BuildRequires: python-numpy
31%endif
cd938da9 32%endif
b336f80a 33%if %{with python3}
cd938da9
JB
34BuildRequires: python3-devel >= 1:3.4
35BuildRequires: python3-setuptools
36%if %{with tests}
b336f80a 37BuildRequires: python3-devel-tools
cd938da9 38BuildRequires: python3-mpmath >= 0.19
b336f80a
JR
39BuildRequires: python3-numpy
40%endif
cd938da9
JB
41%endif
42%if %{with doc}
9f977fe2 43BuildRequires: pydoc3
13fba096 44BuildRequires: python3-matplotlib
558a01dc 45BuildRequires: python3-mpmath >= 0.19
13fba096 46BuildRequires: sphinx-pdg-3
8a467d57 47BuildRequires: texlive-format-pdflatex
b336f80a
JR
48BuildRequires: texlive-latex
49BuildRequires: texlive-latex-pgf
cd938da9 50%endif
b336f80a 51Requires: python-matplotlib
cd938da9 52Requires: python-modules >= 1:2.7
b336f80a
JR
53Requires: python-mpmath
54Requires: python-pyglet
55BuildArch: noarch
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58%description
59SymPy aims to become a full-featured computer algebra system (CAS)
60while keeping the code as simple as possible in order to be
61comprehensible and easily extensible. SymPy is written entirely in
62Python and does not require any external libraries.
63
cd938da9
JB
64%description -l pl.UTF-8
65SymPy ma być w pełni funkcjonalnym systemem algebry komputerowej
66(CAS), a jednocześnie mieć jak najprostszy, czytelny i łatwo
67rozszerzalny kod. Jest pisany całkowicie w Pythonie i nie wymaga
68żadnych zewnętrznych bibliotek.
69
b336f80a 70%package -n python3-sympy
cd938da9
JB
71Summary: Python 3 library for symbolic mathematics
72Summary(pl.UTF-8): Biblioteka Pythona 3 do matematyki symbolicznej
b336f80a
JR
73Group: Libraries/Python
74Requires: python3-matplotlib
cd938da9 75Requires: python3-modules >= 1:3.4
b336f80a
JR
76Requires: python3-mpmath
77Requires: python3-pyglet
78
79%description -n python3-sympy
80SymPy aims to become a full-featured computer algebra system (CAS)
81while keeping the code as simple as possible in order to be
82comprehensible and easily extensible. SymPy is written entirely in
83Python and does not require any external libraries.
84
cd938da9
JB
85%description -n python3-sympy -l pl.UTF-8
86SymPy ma być w pełni funkcjonalnym systemem algebry komputerowej
87(CAS), a jednocześnie mieć jak najprostszy, czytelny i łatwo
88rozszerzalny kod. Jest pisany całkowicie w Pythonie i nie wymaga
89żadnych zewnętrznych bibliotek.
90
b336f80a 91%package doc
cd938da9
JB
92Summary: Documentation for SymPy module
93Summary(pl.UTF-8): Dokumentacja do SymPy
94Group: Documentation
b336f80a
JR
95
96%description doc
cd938da9
JB
97HTML documentation for SymPy.
98
99%description doc -l pl.UTF-8
100Dokumentacja do SymPy w formacie HTML.
b336f80a
JR
101
102%prep
103%setup -q -n sympy-%{version}
e7d4bee6 104%patch0 -p1
b336f80a
JR
105
106%build
107%if %{with python2}
2ac80b5d 108%py_build %{?with_tests:test}
b336f80a
JR
109%endif
110
111%if %{with python3}
2ac80b5d 112%py3_build %{?with_tests:test}
b336f80a
JR
113%endif
114
cd938da9 115%if %{with doc}
558a01dc 116pydir=$(pwd)/build-3/lib
b336f80a 117cd doc
558a01dc 118PYTHONPATH=$pydir \
13fba096
JB
119%{__make} html \
120 SPHINXBUILD=sphinx-build-3
b336f80a 121%{__make} cheatsheet
cd938da9 122%endif
b336f80a
JR
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127%if %{with python3}
2ac80b5d 128%py3_install
b336f80a
JR
129
130%{__mv} $RPM_BUILD_ROOT%{_bindir}/isympy{,3}
131
132install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-sympy-%{version}
133cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-sympy-%{version}
134find $RPM_BUILD_ROOT%{_examplesdir}/python3-sympy-%{version} -name '*.py' \
135 | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
136%endif
137
138%if %{with python2}
2ac80b5d 139%py_install
b336f80a
JR
140
141%py_postclean
142
143install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
144cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
cd938da9
JB
145find $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} -name '*.py' \
146 | xargs sed -i '1s|^#!.*python\b|#!%{__python}|'
b336f80a
JR
147%endif
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
cd938da9 152%if %{with python2}
b336f80a
JR
153%files
154%defattr(644,root,root,755)
cd938da9 155%doc AUTHORS LICENSE README.rst
b336f80a 156%attr(755,root,root) %{_bindir}/isympy
cd938da9 157%{py_sitescriptdir}/isympy.py[co]
b336f80a
JR
158%{py_sitescriptdir}/sympy
159%{py_sitescriptdir}/sympy-%{version}-*.egg-info
160%{_mandir}/man1/isympy.1*
161%{_examplesdir}/%{name}-%{version}
cd938da9 162%endif
b336f80a 163
cd938da9 164%if %{with python3}
b336f80a
JR
165%files -n python3-sympy
166%defattr(644,root,root,755)
cd938da9 167%doc AUTHORS LICENSE README.rst
b336f80a 168%attr(755,root,root) %{_bindir}/isympy3
cd938da9
JB
169%{py3_sitescriptdir}/isympy.py
170%{py3_sitescriptdir}/__pycache__/isympy.cpython-*.py[co]
b336f80a
JR
171%{py3_sitescriptdir}/sympy
172%{py3_sitescriptdir}/sympy-%{version}-*.egg-info
173%{_examplesdir}/python3-sympy-%{version}
cd938da9 174%endif
b336f80a 175
cd938da9 176%if %{with doc}
b336f80a
JR
177%files doc
178%defattr(644,root,root,755)
cd938da9
JB
179%doc doc/_build/html/* doc/_build/cheatsheet/cheatsheet.pdf
180%endif
This page took 0.134579 seconds and 4 git commands to generate.