]> git.pld-linux.org Git - packages/python-sympy.git/blame - python-sympy.spec
- doc BR: texlive-latex-ams
[packages/python-sympy.git] / python-sympy.spec
CommitLineData
b336f80a
JR
1#
2# Conditional build:
cd938da9
JB
3%bcond_without doc # HTML and PDF documentation
4%bcond_without tests # unit tests
b336f80a
JR
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
cd938da9
JB
8Summary: Python 2 library for symbolic mathematics
9Summary(pl.UTF-8): Biblioteka Pythona 2 do matematyki symbolicznej
b336f80a 10Name: python-sympy
cd938da9 11Version: 1.4
afb29cf8 12Release: 1
b336f80a
JR
13License: BSD
14Group: Libraries/Python
cd938da9 15#Source0Download: https://github.com/sympy/sympy/releases
b336f80a 16Source0: https://github.com/sympy/sympy/releases/download/sympy-%{version}/sympy-%{version}.tar.gz
cd938da9
JB
17# Source0-md5: 478072d75b564c9356990e3027d464e6
18Patch0: %{name}-nodisplay.patch
19URL: https://www.sympy.org/
b336f80a
JR
20BuildRequires: gettext
21BuildRequires: graphviz
cd938da9
JB
22BuildRequires: rpmbuild(macros) >= 1.714
23BuildRequires: sed >= 4.0
b336f80a 24%if %{with python2}
cd938da9
JB
25BuildRequires: python-devel >= 1:2.7
26BuildRequires: python-setuptools
27%if %{with tests}
28BuildRequires: python-devel-tools
29BuildRequires: python-mpmath >= 0.19
b336f80a
JR
30BuildRequires: python-numpy
31%endif
cd938da9 32%endif
b336f80a 33%if %{with python3}
cd938da9
JB
34BuildRequires: python3-devel >= 1:3.4
35BuildRequires: python3-setuptools
36%if %{with tests}
b336f80a 37BuildRequires: python3-devel-tools
cd938da9 38BuildRequires: python3-mpmath >= 0.19
b336f80a
JR
39BuildRequires: python3-numpy
40%endif
cd938da9
JB
41%endif
42%if %{with doc}
9f977fe2 43BuildRequires: pydoc3
13fba096 44BuildRequires: python3-matplotlib
558a01dc 45BuildRequires: python3-mpmath >= 0.19
13fba096 46BuildRequires: sphinx-pdg-3
8a467d57 47BuildRequires: texlive-format-pdflatex
b336f80a 48BuildRequires: texlive-latex
225dae17 49BuildRequires: texlive-latex-ams
b336f80a 50BuildRequires: texlive-latex-pgf
cd938da9 51%endif
b336f80a 52Requires: python-matplotlib
cd938da9 53Requires: python-modules >= 1:2.7
b336f80a
JR
54Requires: python-mpmath
55Requires: python-pyglet
56BuildArch: noarch
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59%description
60SymPy aims to become a full-featured computer algebra system (CAS)
61while keeping the code as simple as possible in order to be
62comprehensible and easily extensible. SymPy is written entirely in
63Python and does not require any external libraries.
64
cd938da9
JB
65%description -l pl.UTF-8
66SymPy ma być w pełni funkcjonalnym systemem algebry komputerowej
67(CAS), a jednocześnie mieć jak najprostszy, czytelny i łatwo
68rozszerzalny kod. Jest pisany całkowicie w Pythonie i nie wymaga
69żadnych zewnętrznych bibliotek.
70
b336f80a 71%package -n python3-sympy
cd938da9
JB
72Summary: Python 3 library for symbolic mathematics
73Summary(pl.UTF-8): Biblioteka Pythona 3 do matematyki symbolicznej
b336f80a
JR
74Group: Libraries/Python
75Requires: python3-matplotlib
cd938da9 76Requires: python3-modules >= 1:3.4
b336f80a
JR
77Requires: python3-mpmath
78Requires: python3-pyglet
79
80%description -n python3-sympy
81SymPy aims to become a full-featured computer algebra system (CAS)
82while keeping the code as simple as possible in order to be
83comprehensible and easily extensible. SymPy is written entirely in
84Python and does not require any external libraries.
85
cd938da9
JB
86%description -n python3-sympy -l pl.UTF-8
87SymPy ma być w pełni funkcjonalnym systemem algebry komputerowej
88(CAS), a jednocześnie mieć jak najprostszy, czytelny i łatwo
89rozszerzalny kod. Jest pisany całkowicie w Pythonie i nie wymaga
90żadnych zewnętrznych bibliotek.
91
b336f80a 92%package doc
cd938da9
JB
93Summary: Documentation for SymPy module
94Summary(pl.UTF-8): Dokumentacja do SymPy
95Group: Documentation
b336f80a
JR
96
97%description doc
cd938da9
JB
98HTML documentation for SymPy.
99
100%description doc -l pl.UTF-8
101Dokumentacja do SymPy w formacie HTML.
b336f80a
JR
102
103%prep
104%setup -q -n sympy-%{version}
e7d4bee6 105%patch0 -p1
b336f80a
JR
106
107%build
108%if %{with python2}
2ac80b5d 109%py_build %{?with_tests:test}
b336f80a
JR
110%endif
111
112%if %{with python3}
2ac80b5d 113%py3_build %{?with_tests:test}
b336f80a
JR
114%endif
115
cd938da9 116%if %{with doc}
558a01dc 117pydir=$(pwd)/build-3/lib
b336f80a 118cd doc
558a01dc 119PYTHONPATH=$pydir \
13fba096
JB
120%{__make} html \
121 SPHINXBUILD=sphinx-build-3
b336f80a 122%{__make} cheatsheet
cd938da9 123%endif
b336f80a
JR
124
125%install
126rm -rf $RPM_BUILD_ROOT
127
128%if %{with python3}
2ac80b5d 129%py3_install
b336f80a
JR
130
131%{__mv} $RPM_BUILD_ROOT%{_bindir}/isympy{,3}
132
133install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-sympy-%{version}
134cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/python3-sympy-%{version}
135find $RPM_BUILD_ROOT%{_examplesdir}/python3-sympy-%{version} -name '*.py' \
136 | xargs sed -i '1s|^#!.*python\b|#!%{__python3}|'
137%endif
138
139%if %{with python2}
2ac80b5d 140%py_install
b336f80a
JR
141
142%py_postclean
143
144install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
145cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
cd938da9
JB
146find $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} -name '*.py' \
147 | xargs sed -i '1s|^#!.*python\b|#!%{__python}|'
b336f80a
JR
148%endif
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
cd938da9 153%if %{with python2}
b336f80a
JR
154%files
155%defattr(644,root,root,755)
cd938da9 156%doc AUTHORS LICENSE README.rst
b336f80a 157%attr(755,root,root) %{_bindir}/isympy
cd938da9 158%{py_sitescriptdir}/isympy.py[co]
b336f80a
JR
159%{py_sitescriptdir}/sympy
160%{py_sitescriptdir}/sympy-%{version}-*.egg-info
161%{_mandir}/man1/isympy.1*
162%{_examplesdir}/%{name}-%{version}
cd938da9 163%endif
b336f80a 164
cd938da9 165%if %{with python3}
b336f80a
JR
166%files -n python3-sympy
167%defattr(644,root,root,755)
cd938da9 168%doc AUTHORS LICENSE README.rst
b336f80a 169%attr(755,root,root) %{_bindir}/isympy3
cd938da9
JB
170%{py3_sitescriptdir}/isympy.py
171%{py3_sitescriptdir}/__pycache__/isympy.cpython-*.py[co]
b336f80a
JR
172%{py3_sitescriptdir}/sympy
173%{py3_sitescriptdir}/sympy-%{version}-*.egg-info
174%{_examplesdir}/python3-sympy-%{version}
cd938da9 175%endif
b336f80a 176
cd938da9 177%if %{with doc}
b336f80a
JR
178%files doc
179%defattr(644,root,root,755)
cd938da9
JB
180%doc doc/_build/html/* doc/_build/cheatsheet/cheatsheet.pdf
181%endif
This page took 0.10749 seconds and 4 git commands to generate.