]> git.pld-linux.org Git - packages/python-sphinxtesters.git/blame - python-sphinxtesters.spec
- disable pytest plugins
[packages/python-sphinxtesters.git] / python-sphinxtesters.spec
CommitLineData
44fd9df5
JB
1#
2# Conditional build:
5d6d3666 3%bcond_without tests # unit tests [py3 tests fail with sphinx3.x+docutils0.18 combo]
44fd9df5
JB
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Utilities for testing Sphinx extensions
8Summary(pl.UTF-8): Narzędzia do testowania rozszerzeń Sphinksa
9Name: python-sphinxtesters
10Version: 0.2.3
095e8b06 11Release: 4
44fd9df5
JB
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/sphinxtesters/
15Source0: https://files.pythonhosted.org/packages/source/s/sphinxtesters/sphinxtesters-%{version}.tar.gz
16# Source0-md5: 3df3720ba757d3d8270fed5aff622852
5d6d3666 17Patch0: %{name}-noconf.patch
44fd9df5
JB
18URL: https://pypi.org/project/sphinxtesters/
19%if %{with python2}
20BuildRequires: python-modules >= 1:2.7
21BuildRequires: python-setuptools
22%if %{with tests}
23BuildRequires: python-Sphinx >= 1.4
24BuildRequires: python-pytest
25%endif
26%endif
27%if %{with python3}
28BuildRequires: python3-modules >= 1:3.3
29BuildRequires: python3-setuptools
30%if %{with tests}
31BuildRequires: python3-Sphinx >= 1.4
32BuildRequires: python3-pytest
33%endif
34%endif
35BuildRequires: rpm-pythonprov
36BuildRequires: rpmbuild(macros) >= 1.714
37Requires: python-Sphinx >= 1.4
38Requires: python-modules >= 1:2.7
39BuildArch: noarch
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43Utilities for testing Sphinx extensions.
44
45%description -l pl.UTF-8
46Narzędzia do testowania rozszerzeń Sphinksa.
47
48%package -n python3-sphinxtesters
49Summary: Utilities for testing Sphinx extensions
50Summary(pl.UTF-8): Narzędzia do testowania rozszerzeń Sphinksa
51Group: Libraries/Python
52Requires: python3-Sphinx >= 1.4
53Requires: python3-modules >= 1:3.3
54
55%description -n python3-sphinxtesters
56Utilities for testing Sphinx extensions.
57
58%description -n python3-sphinxtesters -l pl.UTF-8
59Narzędzia do testowania rozszerzeń Sphinksa.
60
61%prep
62%setup -q -n sphinxtesters-%{version}
5d6d3666 63%patch0 -p1
44fd9df5
JB
64
65%build
66%if %{with python2}
67%py_build
68
5d6d3666
JB
69%if %{with tests}
70PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
71%{__python} -m pytest sphinxtesters/tests
72%endif
44fd9df5
JB
73%endif
74
75%if %{with python3}
76%py3_build
77
5d6d3666
JB
78%if %{with tests}
79PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
80%{__python3} -m pytest sphinxtesters/tests
81%endif
44fd9df5
JB
82%endif
83
84%install
85rm -rf $RPM_BUILD_ROOT
86
87%if %{with python2}
88%py_install
89
90%py_postclean
91%endif
92
93%if %{with python3}
94%py3_install
95%endif
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%if %{with python2}
101%files
102%defattr(644,root,root,755)
103%doc LICENSE README.rst
104%{py_sitescriptdir}/sphinxtesters
105%{py_sitescriptdir}/sphinxtesters-%{version}-py*.egg-info
106%endif
107
108%if %{with python3}
109%files -n python3-sphinxtesters
110%defattr(644,root,root,755)
111%doc LICENSE README.rst
112%{py3_sitescriptdir}/sphinxtesters
113%{py3_sitescriptdir}/sphinxtesters-%{version}-py*.egg-info
114%endif
This page took 0.076568 seconds and 4 git commands to generate.