]> git.pld-linux.org Git - packages/python-sphinxtesters.git/blame - python-sphinxtesters.spec
rebuild with python 3.10
[packages/python-sphinxtesters.git] / python-sphinxtesters.spec
CommitLineData
44fd9df5
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Utilities for testing Sphinx extensions
8Summary(pl.UTF-8): Narzędzia do testowania rozszerzeń Sphinksa
9Name: python-sphinxtesters
10Version: 0.2.3
095e8b06 11Release: 4
44fd9df5
JB
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/sphinxtesters/
15Source0: https://files.pythonhosted.org/packages/source/s/sphinxtesters/sphinxtesters-%{version}.tar.gz
16# Source0-md5: 3df3720ba757d3d8270fed5aff622852
17URL: https://pypi.org/project/sphinxtesters/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.7
20BuildRequires: python-setuptools
21%if %{with tests}
22BuildRequires: python-Sphinx >= 1.4
23BuildRequires: python-pytest
24%endif
25%endif
26%if %{with python3}
27BuildRequires: python3-modules >= 1:3.3
28BuildRequires: python3-setuptools
29%if %{with tests}
30BuildRequires: python3-Sphinx >= 1.4
31BuildRequires: python3-pytest
32%endif
33%endif
34BuildRequires: rpm-pythonprov
35BuildRequires: rpmbuild(macros) >= 1.714
36Requires: python-Sphinx >= 1.4
37Requires: python-modules >= 1:2.7
38BuildArch: noarch
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42Utilities for testing Sphinx extensions.
43
44%description -l pl.UTF-8
45Narzędzia do testowania rozszerzeń Sphinksa.
46
47%package -n python3-sphinxtesters
48Summary: Utilities for testing Sphinx extensions
49Summary(pl.UTF-8): Narzędzia do testowania rozszerzeń Sphinksa
50Group: Libraries/Python
51Requires: python3-Sphinx >= 1.4
52Requires: python3-modules >= 1:3.3
53
54%description -n python3-sphinxtesters
55Utilities for testing Sphinx extensions.
56
57%description -n python3-sphinxtesters -l pl.UTF-8
58Narzędzia do testowania rozszerzeń Sphinksa.
59
60%prep
61%setup -q -n sphinxtesters-%{version}
62
63%build
64%if %{with python2}
65%py_build
66
67%{?with_tests:%{__python} -m pytest sphinxtesters/tests}
68%endif
69
70%if %{with python3}
71%py3_build
72
73%{?with_tests:%{__python3} -m pytest sphinxtesters/tests}
74%endif
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79%if %{with python2}
80%py_install
81
82%py_postclean
83%endif
84
85%if %{with python3}
86%py3_install
87%endif
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%if %{with python2}
93%files
94%defattr(644,root,root,755)
95%doc LICENSE README.rst
96%{py_sitescriptdir}/sphinxtesters
97%{py_sitescriptdir}/sphinxtesters-%{version}-py*.egg-info
98%endif
99
100%if %{with python3}
101%files -n python3-sphinxtesters
102%defattr(644,root,root,755)
103%doc LICENSE README.rst
104%{py3_sitescriptdir}/sphinxtesters
105%{py3_sitescriptdir}/sphinxtesters-%{version}-py*.egg-info
106%endif
This page took 0.122088 seconds and 4 git commands to generate.