]> git.pld-linux.org Git - packages/python-sphinxcontrib-log-cabinet.git/blame - python-sphinxcontrib-log-cabinet.spec
Release 5 (by relup.sh)
[packages/python-sphinxcontrib-log-cabinet.git] / python-sphinxcontrib-log-cabinet.spec
CommitLineData
159e5882
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Sphinx extension to organize changelogs
7Summary(pl.UTF-8): Rozszerzenie Sphinksa do porządkowania changelogów
8Name: python-sphinxcontrib-log-cabinet
9Version: 1.0.1
976163e6 10Release: 5
159e5882
JB
11License: BSD
12Group: Libraries/Python
13#Source0Download: https://pypi.org/simple/sphinxcontrib-log-cabinet/
14Source0: https://files.pythonhosted.org/packages/source/s/sphinxcontrib-log-cabinet/sphinxcontrib-log-cabinet-%{version}.tar.gz
15# Source0-md5: 50e9b6e692689c605862a3f9b5c6c936
16URL: https://pypi.org/project/sphinxcontrib-log-cabinet/
17%if %{with python2}
18BuildRequires: python-modules >= 1:2.5
19BuildRequires: python-setuptools
20%endif
21%if %{with python3}
22BuildRequires: python3-modules >= 1:3.2
23BuildRequires: python3-setuptools
24%endif
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
27Requires: python-modules >= 1:2.5
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Sphinx extension to organize changelogs generated by versionadded,
33versionchanged, deprecated directives. The log will be sorted by
34newest to oldest version. For HTML docs, older versions will be
35collapsed by default.
36
37%description -l pl.UTF-8
38Rozszerzenie Sphinksa do porządkowania changelogów wygenerowanych
39przez dyrektywy versionadded, versionchanged i deprecated. Log jest
40sortowany od najnowszej do najstarszej wersji. W przypadku
41dokumentacji HTML starsze wersje są domyślnie zwijane.
42
43%package -n python3-sphinxcontrib-log-cabinet
44Summary: Sphinx extension to organize changelogs
45Summary(pl.UTF-8): Rozszerzenie Sphinksa do porządkowania changelogów
46Group: Libraries/Python
47Requires: python3-modules >= 1:3.2
48
49%description -n python3-sphinxcontrib-log-cabinet
50Sphinx extension to organize changelogs generated by versionadded,
51versionchanged, deprecated directives. The log will be sorted by
52newest to oldest version. For HTML docs, older versions will be
53collapsed by default.
54
55%description -n python3-sphinxcontrib-log-cabinet -l pl.UTF-8
56Rozszerzenie Sphinksa do porządkowania changelogów wygenerowanych
57przez dyrektywy versionadded, versionchanged i deprecated. Log jest
58sortowany od najnowszej do najstarszej wersji. W przypadku
59dokumentacji HTML starsze wersje są domyślnie zwijane.
60
61%prep
62%setup -q -n sphinxcontrib-log-cabinet-%{version}
63
64%build
65%if %{with python2}
66%py_build
67%endif
68
69%if %{with python3}
70%py3_build
71%endif
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76%if %{with python2}
77%py_install
78
79%py_postclean
80%endif
81
82%if %{with python3}
83%py3_install
84%endif
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%if %{with python2}
90%files
91%defattr(644,root,root,755)
92%doc CHANGES.rst LICENSE.rst README.rst
93# XXX: shared dir
94%dir %{py_sitescriptdir}/sphinxcontrib
95%{py_sitescriptdir}/sphinxcontrib/log_cabinet.py[co]
96%{py_sitescriptdir}/sphinxcontrib_log_cabinet-%{version}-py*.egg-info
97%{py_sitescriptdir}/sphinxcontrib_log_cabinet-%{version}-py*-nspkg.pth
98%endif
99
100%if %{with python3}
101%files -n python3-sphinxcontrib-log-cabinet
102%defattr(644,root,root,755)
103%doc CHANGES.rst LICENSE.rst README.rst
104# XXX: shared dirs
105%dir %{py3_sitescriptdir}/sphinxcontrib
106%dir %{py3_sitescriptdir}/sphinxcontrib/__pycache__
107%{py3_sitescriptdir}/sphinxcontrib/log_cabinet.py
108%{py3_sitescriptdir}/sphinxcontrib/__pycache__/log_cabinet.cpython-*.py[co]
109%{py3_sitescriptdir}/sphinxcontrib_log_cabinet-%{version}-py*.egg-info
110%{py3_sitescriptdir}/sphinxcontrib_log_cabinet-%{version}-py*-nspkg.pth
111%endif
This page took 0.086594 seconds and 4 git commands to generate.