]> git.pld-linux.org Git - packages/python-sphinx_math_dollar.git/blame - python-sphinx_math_dollar.spec
rebuild with tests and docs
[packages/python-sphinx_math_dollar.git] / python-sphinx_math_dollar.spec
CommitLineData
a372aa0d
JB
1#
2# Conditional build:
3%bcond_with tests # unit tests (missing test-build data?)
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Sphinx extension to let you write LaTeX math using $$
8Summary(pl.UTF-8): Rozszerzenie Sphinksa pozwalające pisać wzory matematyczne w LaTeXu przy użyciu $$
9Name: python-sphinx_math_dollar
ee29139c 10Version: 1.2
593a3752 11Release: 2
a372aa0d
JB
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/sphinx-math-dollar/
15Source0: https://files.pythonhosted.org/packages/source/s/sphinx-math-dollar/sphinx-math-dollar-%{version}.tar.gz
ee29139c 16# Source0-md5: 60fe316279834d8cba3a88711ede8731
a372aa0d
JB
17URL: https://pypi.org/project/sphinx-math-dollar/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.5
20BuildRequires: python-setuptools
21%if %{with tests}
22BuildRequires: python-Sphinx
23BuildRequires: python-pytest
24BuildRequires: python-sphinx_testing
25%endif
26%endif
27%if %{with python3}
28BuildRequires: python3-modules >= 1:3.2
29BuildRequires: python3-setuptools
30%if %{with tests}
31BuildRequires: python3-Sphinx
32BuildRequires: python3-pytest
33BuildRequires: python3-sphinx_testing
34%endif
35%endif
36BuildRequires: rpm-pythonprov
37BuildRequires: rpmbuild(macros) >= 1.714
38Requires: python-modules >= 1:2.5
39BuildArch: noarch
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42%description
43sphinx-math-dollar is a Sphinx extension to let you write LaTeX math
44using $$.
45
46%description -l pl.UTF-8
47sphinx-math-dollar to rozszerzenie Sphinksa pozwalające pisać wzory
48matematyczne w LaTeXu przy użyciu $$.
49
50%package -n python3-sphinx_math_dollar
51Summary: Sphinx extension to let you write LaTeX math using $$
52Summary(pl.UTF-8): Rozszerzenie Sphinksa pozwalające pisać wzory matematyczne w LaTeXu przy użyciu $$
53Group: Libraries/Python
54Requires: python3-modules >= 1:3.2
55
56%description -n python3-sphinx_math_dollar
57sphinx-math-dollar is a Sphinx extension to let you write LaTeX math
58using $$.
59
60%description -n python3-sphinx_math_dollar -l pl.UTF-8
61sphinx-math-dollar to rozszerzenie Sphinksa pozwalające pisać wzory
62matematyczne w LaTeXu przy użyciu $$.
63
64%prep
65%setup -q -n sphinx-math-dollar-%{version}
66
67%build
68%if %{with python2}
69%py_build
70
71%if %{with tests}
72%{__python} -m pytest sphinx_math_dollar/tests
73%endif
74%endif
75
76%if %{with python3}
77%py3_build
78
79%if %{with tests}
80%{__python3} -m pytest sphinx_math_dollar/tests
81%endif
82%endif
83
84%install
85rm -rf $RPM_BUILD_ROOT
86
87%if %{with python2}
88%py_install
89
90%py_postclean
91%endif
92
93%if %{with python3}
94%py3_install
95%endif
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%if %{with python2}
101%files
102%defattr(644,root,root,755)
103%doc LICENSE README.rst
104%{py_sitescriptdir}/sphinx_math_dollar
105%{py_sitescriptdir}/sphinx_math_dollar-%{version}-py*.egg-info
106%endif
107
108%if %{with python3}
109%files -n python3-sphinx_math_dollar
110%defattr(644,root,root,755)
111%doc LICENSE README.rst
112%{py3_sitescriptdir}/sphinx_math_dollar
113%{py3_sitescriptdir}/sphinx_math_dollar-%{version}-py*.egg-info
114%endif
This page took 0.17894 seconds and 4 git commands to generate.