]> git.pld-linux.org Git - packages/python-sphinx_issues.git/blame - python-sphinx_issues.spec
rebuild with tests and docs
[packages/python-sphinx_issues.git] / python-sphinx_issues.spec
CommitLineData
96b88733
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
89e6773f 5%bcond_with tests # unit tests [not included in release tarball]
96b88733
JB
6
7Summary: Sphinx extension for linking to your project's issue tracker
8Summary(pl.UTF-8): Rozszerzenie Sphinksa do dowiązań do systemu śledzenia problemów projektu
9Name: python-sphinx_issues
89e6773f 10Version: 1.2.0
cda51422 11Release: 7
96b88733
JB
12License: MIT
13Group: Libraries/Python
89e6773f 14#Source0-Download: https://pypi.org/simple/sphinx-issues/
96b88733 15Source0: https://files.pythonhosted.org/packages/source/s/sphinx-issues/sphinx-issues-%{version}.tar.gz
89e6773f 16# Source0-md5: 0f40881c9c95c40c6e752abce61882cc
96b88733
JB
17URL: https://github.com/sloria/sphinx-issues
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.7
22BuildRequires: python-setuptools
89e6773f
JB
23%if %{with tests}
24BuildRequires: python-mock
25BuildRequires: python-pytest
26%endif
96b88733
JB
27%endif
28%if %{with python3}
89e6773f 29BuildRequires: python3-modules >= 1:3.5
96b88733 30BuildRequires: python3-setuptools
89e6773f
JB
31%if %{with tests}
32BuildRequires: python3-pytest
33%endif
96b88733
JB
34%endif
35Requires: python-modules >= 1:2.7
36BuildArch: noarch
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40A Sphinx extension for linking to your project's issue tracker.
41Includes roles for linking to both issues and user profiles, with
42built-in support for GitHub (though this works with other services).
43
44%description -l pl.UTF-8
45Rozszerzenie Sphinksa służące do dowiązywania do systemu śledzenia
46problemów projektu. Zawiera role do dowiązywania zarówno do zgłoszeń
47problemów, jak i profili użytkowników; ma wbudowaną obsługę serwisu
48GitHub (ale działa także z innymi serwisami).
49
50%package -n python3-sphinx_issues
51Summary: Sphinx extension for linking to your project's issue tracker
52Summary(pl.UTF-8): Rozszerzenie Sphinksa do dowiązań do systemu śledzenia problemów projektu
53Group: Libraries/Python
89e6773f 54Requires: python3-modules >= 1:3.5
96b88733
JB
55
56%description -n python3-sphinx_issues
57A Sphinx extension for linking to your project's issue tracker.
58Includes roles for linking to both issues and user profiles, with
59built-in support for GitHub (though this works with other services).
60
61%description -n python3-sphinx_issues -l pl.UTF-8
62Rozszerzenie Sphinksa służące do dowiązywania do systemu śledzenia
63problemów projektu. Zawiera role do dowiązywania zarówno do zgłoszeń
64problemów, jak i profili użytkowników; ma wbudowaną obsługę serwisu
65GitHub (ale działa także z innymi serwisami).
66
67%prep
68%setup -q -n sphinx-issues-%{version}
69
70%build
71%if %{with python2}
72%py_build
73%endif
74
75%if %{with python3}
76%py3_build
77%endif
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82%if %{with python2}
83%py_install
84
85%py_postclean
86%endif
87
88%if %{with python3}
89%py3_install
90%endif
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%if %{with python2}
96%files
97%defattr(644,root,root,755)
98%doc LICENSE README.rst
99%{py_sitescriptdir}/sphinx_issues.py[co]
100%{py_sitescriptdir}/sphinx_issues-%{version}-py*.egg-info
101%endif
102
103%if %{with python3}
104%files -n python3-sphinx_issues
105%defattr(644,root,root,755)
106%doc LICENSE README.rst
107%{py3_sitescriptdir}/sphinx_issues.py
108%{py3_sitescriptdir}/__pycache__/sphinx_issues.cpython-*.py[co]
109%{py3_sitescriptdir}/sphinx_issues-%{version}-py*.egg-info
110%endif
This page took 0.129882 seconds and 4 git commands to generate.