]> git.pld-linux.org Git - packages/python3-sphinx_copybutton.git/blame - python-sphinx_copybutton.spec
- new
[packages/python3-sphinx_copybutton.git] / python-sphinx_copybutton.spec
CommitLineData
4152d114
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Add a copy button to each of your code cells
7Summary(pl.UTF-8): Dodanie przycisku do kopiowania do każdej komórki z kodem
8Name: python-sphinx_copybutton
9# keep 0.2.6 here for python2 support
10Version: 0.2.6
11Release: 1
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/sphinx-copybutton/
15Source0: https://files.pythonhosted.org/packages/source/s/sphinx-copybutton/sphinx-copybutton-%{version}.tar.gz
16# Source0-md5: 0c3380264ff0b7543bdff0f0f154c87f
17Patch0: %{name}-deps.patch
18URL: https://pypi.org/project/sphinx-copybutton/
19%if %{with python2}
20BuildRequires: python-modules >= 1:2.5
21BuildRequires: python-setuptools
22%endif
23%if %{with python3}
24BuildRequires: python3-modules >= 1:3.2
25BuildRequires: python3-setuptools
26%endif
27BuildRequires: rpm-pythonprov
28BuildRequires: rpmbuild(macros) >= 1.714
29Requires: python-modules >= 1:2.5
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34A small Sphinx extension to add a "copy" button to code blocks.
35
36%description -l pl.UTF-8
37Małe rozszerzenie Sphinksa dodające przycisk kopiujący do fragmentów
38kodu.
39
40%package -n python3-sphinx_copybutton
41Summary: Add a copy button to each of your code cells
42Summary(pl.UTF-8): Dodanie przycisku do kopiowania do każdej komórki z kodem
43Group: Libraries/Python
44Requires: python3-modules >= 1:3.2
45
46%description -n python3-sphinx_copybutton
47A small Sphinx extension to add a "copy" button to code blocks.
48
49%description -n python3-sphinx_copybutton -l pl.UTF-8
50Małe rozszerzenie Sphinksa dodające przycisk kopiujący do fragmentów
51kodu.
52
53%prep
54%setup -q -n sphinx-copybutton-%{version}
55%patch0 -p1
56
57%build
58%if %{with python2}
59%py_build
60%endif
61
62%if %{with python3}
63%py3_build
64%endif
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69%if %{with python2}
70%py_install
71
72%py_postclean
73%endif
74
75%if %{with python3}
76%py3_install
77%endif
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%if %{with python2}
83%files
84%defattr(644,root,root,755)
85%doc README.md
86%{py_sitescriptdir}/sphinx_copybutton
87%{py_sitescriptdir}/sphinx_copybutton-%{version}-py*.egg-info
88%endif
89
90%if %{with python3}
91%files -n python3-sphinx_copybutton
92%defattr(644,root,root,755)
93%doc README.md
94%{py3_sitescriptdir}/sphinx_copybutton
95%{py3_sitescriptdir}/sphinx_copybutton-%{version}-py*.egg-info
96%endif
This page took 0.105684 seconds and 4 git commands to generate.