]> git.pld-linux.org Git - packages/python-speg.git/blame - python-speg.spec
rebuild with python 3.10
[packages/python-speg.git] / python-speg.spec
CommitLineData
56ccd908
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: PEG-based parser interpreter with memoization
7Summary(pl.UTF-8): Interpreter parserów opartych na PEG z zapamiętywaniem
8Name: python-speg
9Version: 0.3
66dd08f5 10Release: 4
56ccd908
JB
11License: MIT
12Group: Libraries/Python
13#Source0Download: https://pypi.org/simple/speg/
14Source0: https://files.pythonhosted.org/packages/source/s/speg/speg-%{version}.zip
15# Source0-md5: 06c714460913b0cfd73cbbc33fa93eb9
16URL: https://pypi.org/project/speg/
17%if %{with python2}
18BuildRequires: python-modules >= 2
19BuildRequires: python-setuptools
20%endif
21%if %{with python3}
22BuildRequires: python3-modules >= 1:3.2
23BuildRequires: python3-setuptools
24%endif
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
27BuildRequires: unzip
28Requires: python-modules >= 2
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33PEG-based parser interpreter with memoization.
34
35%description -l pl.UTF-8
36Interpreter parserów opartych na PEG z zapamiętywaniem.
37
38%package -n python3-speg
39Summary: PEG-based parser interpreter with memoization
40Summary(pl.UTF-8): Interpreter parserów opartych na PEG z zapamiętywaniem
41Group: Libraries/Python
42Requires: python3-modules >= 1:3.2
43
44%description -n python3-speg
45PEG-based parser interpreter with memoization.
46
47%description -n python3-speg -l pl.UTF-8
48Interpreter parserów opartych na PEG z zapamiętywaniem.
49
50%prep
51%setup -q -n speg-%{version}
52
53%build
54%if %{with python2}
55%py_build
56%endif
57
58%if %{with python3}
59%py3_build
60%endif
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65%if %{with python2}
66%py_install
67
68%py_postclean
69%endif
70
71%if %{with python3}
72%py3_install
73%endif
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%if %{with python2}
79%files
80%defattr(644,root,root,755)
81%{py_sitescriptdir}/speg
82%{py_sitescriptdir}/speg-%{version}-py*.egg-info
83%endif
84
85%if %{with python3}
86%files -n python3-speg
87%defattr(644,root,root,755)
88%{py3_sitescriptdir}/speg
89%{py3_sitescriptdir}/speg-%{version}-py*.egg-info
90%endif
This page took 0.092121 seconds and 4 git commands to generate.