]> git.pld-linux.org Git - packages/python-speaklater.git/blame - python-speaklater.spec
- release 8 (by relup.sh)
[packages/python-speaklater.git] / python-speaklater.spec
CommitLineData
541670cc
MK
1#
2# Conditional build:
3# %bcond_without doc # don't build doc
4%bcond_without tests # do not perform "make test"
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module speaklater
9Summary: Implements a lazy string for python
10Summary(pl.UTF-8): Implementacja wartościowania leniwego dla Pythona
11# Name must match the python module/package name (as in 'import' statement)
12Name: python-%{module}
13Version: 1.3
c4ca2b21 14Release: 8
541670cc
MK
15License: BSD-like
16Group: Libraries/Python
17Source0: https://pypi.python.org/packages/source/s/%{module}/%{module}-%{version}.tar.gz
18# Source0-md5: e8d5dbe36e53d5a35cff227e795e8bbf
19URL: http://github.com/mitsuhiko/speaklater
387aff4d 20BuildRequires: rpmbuild(macros) >= 1.710
541670cc
MK
21BuildRequires: rpm-pythonprov
22%if %{with python2}
23BuildRequires: python-distribute
24%endif
25%if %{with python3}
26BuildRequires: python3-distribute
27BuildRequires: python3-modules
28%endif
29Requires: python-modules
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34A module that provides lazy strings for translations. Basically you
35get an object that appears to be a string but changes the value every
36time the value is evaluated based on a callable you provide.
37
38# %description -l pl.UTF-8
39
40%package -n python3-%{module}
41Summary: -
42Summary(pl.UTF-8): -
43Group: Libraries/Python
44Requires: python3-modules
45
46%description -n python3-%{module}
47
48%description -n python3-%{module} -l pl.UTF-8
49
50%package apidocs
51Summary: %{module} API documentation
52Summary(pl.UTF-8): Dokumentacja API %{module}
53Group: Documentation
54
55%description apidocs
56API documentation for %{module}.
57
58%description apidocs -l pl.UTF-8
59Dokumentacja API %{module}.
60
61%prep
62%setup -q -n %{module}-%{version}
63
64%build
65%if %{with python2}
e5360f83 66%py_build %{?with_tests:test}
541670cc
MK
67%endif
68
69%if %{with python3}
e5360f83 70%py3_build %{?with_tests:test}
541670cc
MK
71%endif
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76%if %{with python2}
e5360f83 77%py_install
541670cc
MK
78
79%py_postclean
80%endif
81
82%if %{with python3}
e5360f83 83%py3_install
541670cc
MK
84%endif
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%if %{with python2}
90%files
91%defattr(644,root,root,755)
92%doc LICENSE README
93%{py_sitescriptdir}/*.py[co]
94%if "%{py_ver}" > "2.4"
95%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
96%endif
97%endif
98
99%if %{with python3}
100%files -n python3-%{module}
101%defattr(644,root,root,755)
102%doc LICENSE README
103%{py3_sitescriptdir}/%{module}.py
104%{py3_sitescriptdir}/__pycache__/*.py[co]
105%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
106%endif
107
108
This page took 0.161835 seconds and 4 git commands to generate.