]> git.pld-linux.org Git - packages/python-sortedcontainers.git/blame - python-sortedcontainers.spec
rebuild with python 3.10
[packages/python-sortedcontainers.git] / python-sortedcontainers.spec
CommitLineData
22860be9
JB
1#
2# Conditional build:
3%bcond_with tests # tests (tox based)
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: Sorted Containers - Sorted List, Sorted Dict, Sorted Set
8Summary(pl.UTF-8): Posortowane kontenery - lista, słownik, zbiór
9Name: python-sortedcontainers
908f88ad 10Version: 2.4.0
f413dcb7 11Release: 2
22860be9
JB
12License: Apache v2.0
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/sortedcontainers/
15Source0: https://files.pythonhosted.org/packages/source/s/sortedcontainers/sortedcontainers-%{version}.tar.gz
908f88ad 16# Source0-md5: 50eeb6cb739568b590b28f9a3f445c78
22860be9
JB
17URL: https://pypi.org/project/sortedcontainers/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.7
20BuildRequires: python-setuptools
21%if %{with tests}
22BuildRequires: python-tox
23%endif
24%endif
25%if %{with python3}
26BuildRequires: python3-modules >= 1:3.2
27BuildRequires: python3-setuptools
28%if %{with tests}
29BuildRequires: python3-tox
30%endif
31%endif
32BuildRequires: rpm-pythonprov
33BuildRequires: rpmbuild(macros) >= 1.714
908f88ad 34Requires: python-modules >= 1:2.7
22860be9
JB
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Sorted Containers is an Apache2 licensed sorted collections library,
40written in pure-Python, and fast as C-extensions.
41
42%description -l pl.UTF-8
43Sorted Containers to wydana na licencji Apache2 biblioteka sortowanych
44kolekcji, napisana w czystym Pythonie, szybka jak rozszerzenia w C.
45
46%package -n python3-sortedcontainers
47Summary: Sorted Containers - Sorted List, Sorted Dict, Sorted Set
48Summary(pl.UTF-8): Posortowane kontenery - lista, słownik, zbiór
49Group: Libraries/Python
908f88ad 50Requires: python3-modules >= 1:3.2
22860be9
JB
51
52%description -n python3-sortedcontainers
53Sorted Containers is an Apache2 licensed sorted collections library,
54written in pure-Python, and fast as C-extensions.
55
56%description -n python3-sortedcontainers -l pl.UTF-8
57Sorted Containers to wydana na licencji Apache2 biblioteka sortowanych
58kolekcji, napisana w czystym Pythonie, szybka jak rozszerzenia w C.
59
60%prep
61%setup -q -n sortedcontainers-%{version}
62
63%build
64%if %{with python2}
65%py_build %{?with_tests:test}
66%endif
67
68%if %{with python3}
69%py3_build %{?with_tests:test}
70%endif
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75%if %{with python2}
76%py_install
77
78%py_postclean
79%endif
80
81%if %{with python3}
82%py3_install
83%endif
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%if %{with python2}
89%files
90%defattr(644,root,root,755)
91%doc LICENSE README.rst
92%{py_sitescriptdir}/sortedcontainers
93%{py_sitescriptdir}/sortedcontainers-%{version}-py*.egg-info
94%endif
95
96%if %{with python3}
97%files -n python3-sortedcontainers
98%defattr(644,root,root,755)
99%doc LICENSE README.rst
100%{py3_sitescriptdir}/sortedcontainers
101%{py3_sitescriptdir}/sortedcontainers-%{version}-py*.egg-info
102%endif
This page took 0.123023 seconds and 4 git commands to generate.