]> git.pld-linux.org Git - packages/python-soaplib.git/blame - python-soaplib.spec
cp-friendly url
[packages/python-soaplib.git] / python-soaplib.spec
CommitLineData
440f65cf 1# TODO
2# - better group
3
4%define _rc beta2
5%define module soaplib
fc7b9023 6Summary: A transport and architecture agnostic soap (de)serialization library that focuses on making small, rpc-like messaging work
440f65cf 7Name: python-%{module}
8Version: 2.0.0
9Release: 0.1_%{_rc}
10License: LGPL
11Group: Development/Languages/Python
12Source0: http://pypi.python.org/packages/source/s/%{module}/%{module}-%{version}-%{_rc}.tar.gz
13# Source0-md5: 294bc8db05011bfa14e00a6a9368e2ae
fc7b9023 14URL: http://pypi.python.org/pypi/soaplib
440f65cf 15BuildRequires: python-distribute
16BuildRequires: rpm-pythonprov
17BuildRequires: rpmbuild(macros) >= 1.228
18Requires(post,preun): /sbin/chkconfig
19BuildArch: noarch
fc7b9023 20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
440f65cf 21
22%description
fc7b9023
ER
23This is a simple, easily extendible soap library that provides several
24useful tools for creating and publishing soap web services in python.
25This package features on-demand wsdl generation for the published
26services, a wsgi-compliant web application, support for complex class
27structures, binary attachments, and a simple framework for creating
28additional serialization mechanisms.
29
30This project uses lxml as it's XML API, providing full namespace
31support.
32
440f65cf 33%prep
34%setup -q -n %{module}-%{version}-%{_rc}
35
36%build
37%{__python} setup.py build
38
39%install
40rm -rf $RPM_BUILD_ROOT
41%{__python} setup.py install \
42 --skip-build \
43 --optimize=2 \
44 --root=$RPM_BUILD_ROOT
45
46%py_postclean
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(644,root,root,755)
53%doc PKG-INFO
54
55%{py_sitescriptdir}/%{module}
56%if "%{py_ver}" > "2.4"
57%{py_sitescriptdir}/%{module}-*.egg-info
58%endif
fc7b9023 59%{py_sitescriptdir}/%{module}-*pth
This page took 0.054648 seconds and 4 git commands to generate.