]> git.pld-linux.org Git - packages/python-snowballstemmer.git/blame - python-snowballstemmer.spec
- updated to 2.0.0; 10 more languages
[packages/python-snowballstemmer.git] / python-snowballstemmer.spec
CommitLineData
b58c937c
JK
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module snowballstemmer
7Summary: Stemmer algorithms generated from Snowball algorithms
d7d11dbc 8Summary(pl.UTF-8): Algorytmy wyznaczające rdzeniesłów wygenerowane z algorytmów Snowball
b58c937c 9Name: python-%{module}
927503cc
JB
10Version: 2.0.0
11Release: 1
b58c937c
JK
12License: BSD
13Group: Libraries/Python
927503cc
JB
14#Source0Download: https://pypi.org/simple/snowballstemmer
15Source0: https://files.pythonhosted.org/packages/source/s/snowballstemmer/%{module}-%{version}.tar.gz
16# Source0-md5: c05ec4a897be3c953c8b8b844c4241d4
17URL: https://github.com/snowballstem/snowball
b58c937c 18BuildRequires: rpm-pythonprov
8349803c 19BuildRequires: rpmbuild(macros) >= 1.714
b58c937c 20%if %{with python2}
927503cc 21BuildRequires: python-modules >= 1:2.6
b58c937c
JK
22BuildRequires: python-setuptools
23%endif
24%if %{with python3}
927503cc 25BuildRequires: python3-modules >= 1:3.4
b58c937c
JK
26BuildRequires: python3-setuptools
27%endif
927503cc 28Requires: python-modules >= 1:2.6
b58c937c
JK
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
927503cc
JB
33This package provides 26 stemmer algorithms (25 languages + Porter
34English stemmer) generated from Snowball algorithms.
b58c937c
JK
35
36It includes following language algorithms:
927503cc
JB
37 - Arabic
38 - Basque
39 - Catalan
b58c937c
JK
40 - Danish
41 - Dutch
42 - English (Standard, Porter)
43 - Finnish
44 - French
45 - German
927503cc
JB
46 - Greek
47 - Hindi
b58c937c 48 - Hungarian
927503cc
JB
49 - Indonesian
50 - Irish
b58c937c 51 - Italian
927503cc
JB
52 - Lithuanian
53 - Nepali
b58c937c
JK
54 - Norwegian
55 - Portuguese
56 - Romanian
57 - Russian
58 - Spanish
59 - Swedish
927503cc 60 - Tamil
b58c937c
JK
61 - Turkish
62
63This is a pure Python stemming library. If PyStemmer is available,
64this module uses it to accelerate.
65
d7d11dbc 66%description -l pl.UTF-8
927503cc
JB
67Ten pakiet udostępnia 26 algorytmów znajdujących rdzenie słów (25
68języków + angielski Portera), wygenerowane z algorytmów Snowball.
d7d11dbc
JB
69
70Zawiera algorytmy dla następujących języków:
927503cc
JB
71 - arabski
72 - baskijski
73 - kataloński
d7d11dbc
JB
74 - duński
75 - holenderski
76 - angielski (standardowy i Portera)
77 - fiński
78 - francuski
79 - niemiecki
927503cc
JB
80 - grecki
81 - hindi
d7d11dbc 82 - węgierski
927503cc
JB
83 - indonezyjski
84 - irlandzki
d7d11dbc 85 - włoski
927503cc
JB
86 - litewski
87 - nepalski
d7d11dbc
JB
88 - norweski
89 - portugalski
90 - rumuński
91 - rosyjski
92 - hiszpański
93 - szwedzki
927503cc 94 - tamilski
d7d11dbc
JB
95 - turecki
96
97Ta biblioteka jest napisana w czystym Pythonie. Jeśli dostępny jest
98PyStemmer, jest używany w celu przyspieszenia.
99
b58c937c
JK
100%package -n python3-%{module}
101Summary: Stemmer algorithms generated from Snowball algorithms
d7d11dbc 102Summary(pl.UTF-8): Algorytmy wyznaczające rdzeniesłów wygenerowane z algorytmów Snowball
b58c937c 103Group: Libraries/Python
927503cc 104Requires: python3-modules >= 1:3.4
b58c937c
JK
105
106%description -n python3-%{module}
927503cc
JB
107This package provides 26 stemmer algorithms (25 languages + Porter
108English stemmer) generated from Snowball algorithms.
b58c937c
JK
109
110It includes following language algorithms:
927503cc
JB
111 - Arabic
112 - Basque
113 - Catalan
b58c937c
JK
114 - Danish
115 - Dutch
116 - English (Standard, Porter)
117 - Finnish
118 - French
119 - German
927503cc
JB
120 - Greek
121 - Hindi
b58c937c 122 - Hungarian
927503cc
JB
123 - Indonesian
124 - Irish
b58c937c 125 - Italian
927503cc
JB
126 - Lithuanian
127 - Nepali
b58c937c
JK
128 - Norwegian
129 - Portuguese
130 - Romanian
131 - Russian
132 - Spanish
133 - Swedish
927503cc 134 - Tamil
b58c937c
JK
135 - Turkish
136
137This is a pure Python stemming library. If PyStemmer is available,
138this module uses it to accelerate.
139
d7d11dbc 140%description -n python3-%{module} -l pl.UTF-8
927503cc
JB
141Ten pakiet udostępnia 26 algorytmów znajdujących rdzenie słów (25
142języków + angielski Portera), wygenerowane z algorytmów Snowball.
d7d11dbc
JB
143
144Zawiera algorytmy dla następujących języków:
927503cc
JB
145 - arabski
146 - baskijski
147 - kataloński
d7d11dbc
JB
148 - duński
149 - holenderski
150 - angielski (standardowy i Portera)
151 - fiński
152 - francuski
153 - niemiecki
927503cc
JB
154 - grecki
155 - hindi
d7d11dbc 156 - węgierski
927503cc
JB
157 - indonezyjski
158 - irlandzki
d7d11dbc 159 - włoski
927503cc
JB
160 - litewski
161 - nepalski
d7d11dbc
JB
162 - norweski
163 - portugalski
164 - rumuński
165 - rosyjski
166 - hiszpański
167 - szwedzki
927503cc 168 - tamilski
d7d11dbc
JB
169 - turecki
170
171Ta biblioteka jest napisana w czystym Pythonie. Jeśli dostępny jest
172PyStemmer, jest używany w celu przyspieszenia.
173
b58c937c
JK
174%prep
175%setup -q -n %{module}-%{version}
176
177%build
178%if %{with python2}
97fcd53e 179%py_build
b58c937c
JK
180%endif
181
182%if %{with python3}
97fcd53e 183%py3_build
b58c937c
JK
184%endif
185
186%install
187rm -rf $RPM_BUILD_ROOT
188
189%if %{with python2}
97fcd53e 190%py_install
b58c937c
JK
191
192%py_postclean
193%endif
194
195%if %{with python3}
97fcd53e 196%py3_install
b58c937c
JK
197%endif
198
199%clean
200rm -rf $RPM_BUILD_ROOT
201
202%if %{with python2}
203%files
204%defattr(644,root,root,755)
927503cc 205%doc CHANGES.rst COPYING README.rst
b58c937c
JK
206%{py_sitescriptdir}/%{module}
207%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
208%endif
209
210%if %{with python3}
211%files -n python3-%{module}
212%defattr(644,root,root,755)
927503cc 213%doc CHANGES.rst COPYING README.rst
b58c937c
JK
214%{py3_sitescriptdir}/%{module}
215%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
216%endif
This page took 0.125958 seconds and 4 git commands to generate.