]> git.pld-linux.org Git - packages/python-simplejson.git/blame - python-simplejson.spec
- changed arch to noarch
[packages/python-simplejson.git] / python-simplejson.spec
CommitLineData
1cf09880 1# $Revision: 1.3 $
fe64986d 2%define module simplejson
5a5d60dd 3%define python_version 2.4
fe64986d 4Summary: Simple, fast, extensible JSON encoder/decoder for Python
5Summary(pl): Prosty, szybki, rozszerzalny (de)koder JSON dla Pythona
6Name: python-%{module}
7Version: 1.4
1cf09880 8Release: 0.3
fe64986d 9License: MIT
10Group: Libraries
11Source0: http://cheeseshop.python.org/packages/source/s/%{module}/%{module}-%{version}.tar.gz
12# Source0-md5: 5fbad786a4b151d44a9b1e1e157e5510
13URL: http://undefined.org/python/#simplejson
5a5d60dd 14Requires: python >= %{python_version}
1cf09880 15BuildArch: noarch
fe64986d 16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
19simplejson is a simple, fast, complete, correct and extensible JSON
20<http://json.org> encoder and decoder for Python 2.3+. It is pure Python
21code with no dependencies.
22
23%prep
24%setup -qn %{module}-%{version}
25
26%build
27python setup.py build
28
29%install
30rm -rf $RPM_BUILD_ROOT
31
32python setup.py install \
33 --root=$RPM_BUILD_ROOT \
34 --optimize=2
35
36%clean
37rm -rf $RPM_BUILD_ROOT
38
39%files
40%defattr(644,root,root,755)
41%dir %{py_sitescriptdir}/%{module}
5a5d60dd 42%{py_sitescriptdir}/%{module}
43%{py_sitescriptdir}/%{module}-%{version}-py%{python_version}.egg-info
This page took 0.087368 seconds and 4 git commands to generate.