]> git.pld-linux.org Git - packages/python-shortuuid.git/blame - python-shortuuid.spec
- rebuild with python 3.8
[packages/python-shortuuid.git] / python-shortuuid.spec
CommitLineData
269ac505 1#
269ac505 2# Conditional build:
269ac505
MK
3%bcond_without tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
269ac505
MK
7%define module shortuuid
8Summary: Generator library for concise, unambiguous and URL-safe UUIDs
9Summary(pl.UTF-8): Biblioteka generacji jednoznacznych UUIDów dla URLi
269ac505
MK
10Name: python-%{module}
11Version: 0.4.3
0488bd68 12Release: 4
269ac505
MK
13License: BSD
14Group: Libraries/Python
15Source0: https://pypi.python.org/packages/e9/41/d867be1470af87dd8af1b3462e5eae44f78ffd33cec54630d40ca6b2d0bd/shortuuid-%{version}.tar.gz
16# Source0-md5: 4f70db8174c0b7b8cad36de48b529947
17URL: https://github.com/stochastic-technologies/shortuuid/
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules
22BuildRequires: python-pep8
f52ee01d 23BuildRequires: python-setuptools
269ac505
MK
24%endif
25%if %{with python3}
26BuildRequires: python3-modules
27BuildRequires: python3-pep8
f52ee01d 28BuildRequires: python3-setuptools
269ac505
MK
29%endif
30Requires: python-modules
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Library that generates short, pretty, unambiguous unique IDs by using
36an extensive, case-sensitive alphabet and omitting similar-looking
37letters and numbers.
38
39%description -l pl.UTF-8
40Biblioteka która generuje krótkie, ładne, jednoznaczne i unikalne IDy
41używając obszernego, uwzlgedniającego wielkość liter alfabetu i
42omijając podbone znaki i liczby.
43
44%package -n python3-%{module}
45Summary: Generator library for concise, unambiguous and URL-safe UUIDs
46Summary(pl.UTF-8): Biblioteka generacji jednoznacznych UUIDów dla URLi
47Group: Libraries/Python
48Requires: python3-modules
49
50%description -n python3-%{module}
51Library that generates short, pretty, unambiguous unique IDs by using
52an extensive, case-sensitive alphabet and omitting similar-looking
53letters and numbers.
54
55%description -n python3-%{module} -l pl.UTF-8
56Biblioteka która generuje krótkie, ładne, jednoznaczne i unikalne IDy
57używając obszernego, uwzlgedniającego wielkość liter alfabetu i
58omijając podbone znaki i liczby.
59
60%package apidocs
61Summary: %{module} API documentation
62Summary(pl.UTF-8): Dokumentacja API %{module}
63Group: Documentation
64
65%description apidocs
66API documentation for %{module}.
67
68%description apidocs -l pl.UTF-8
69Dokumentacja API %{module}.
70
71%prep
72%setup -q -n %{module}-%{version}
73
74%build
75%if %{with python2}
76%py_build %{?with_tests:test}
77%endif
78
79%if %{with python3}
80%py3_build %{?with_tests:test}
81%endif
82
83%if %{with doc}
84cd docs
85%{__make} -j1 html
86rm -rf _build/html/_sources
87%endif
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92%if %{with python2}
93%py_install
94
95%py_postclean
96%endif
97
98%if %{with python3}
99%py3_install
100%endif
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%if %{with python2}
106%files
107%defattr(644,root,root,755)
108%doc README.rst
109%{py_sitescriptdir}/%{module}
269ac505
MK
110%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
111%endif
269ac505
MK
112
113%if %{with python3}
114%files -n python3-%{module}
115%defattr(644,root,root,755)
116%doc README.rst
117%{py3_sitescriptdir}/%{module}
118%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
119%endif
120
121%if %{with doc}
122%files apidocs
123%defattr(644,root,root,755)
124%doc docs/_build/html/*
125%endif
This page took 0.112779 seconds and 4 git commands to generate.