]> git.pld-linux.org Git - packages/python-setuptools_scm_git_archive.git/blame - python-setuptools_scm_git_archive.spec
- release 2
[packages/python-setuptools_scm_git_archive.git] / python-setuptools_scm_git_archive.spec
CommitLineData
487300fc
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: setuptools_scm plugin for git archives
8Summary(pl.UTF-8): Wtyczka setuptools_scm do archiwów gita
9Name: python-setuptools_scm_git_archive
10Version: 1.1
2fec4416 11Release: 2
487300fc
JB
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/setuptools_scm_git_archive/
15Source0: https://files.pythonhosted.org/packages/source/s/setuptools_scm_git_archive/setuptools_scm_git_archive-%{version}.tar.gz
16# Source0-md5: 1c9351fa5cebd12e76488737a7c78f2e
17URL: https://pypi.org/project/setuptools_scm_git_archive/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.5
20BuildRequires: python-setuptools
21BuildRequires: python-setuptools_scm
22%if %{with tests}
23BuildRequires: python-pytest
24%endif
25%endif
26%if %{with python3}
27BuildRequires: python3-modules >= 1:3.2
28BuildRequires: python3-setuptools
29BuildRequires: python3-setuptools_scm
30%if %{with tests}
31BuildRequires: python3-pytest
32%endif
33%endif
34BuildRequires: rpm-pythonprov
35BuildRequires: rpmbuild(macros) >= 1.714
36Requires: python-modules >= 1:2.5
37BuildArch: noarch
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41This is a setuptools_scm plugin that adds support for git archives
42(for example the ones GitHub automatically generates).
43
44%description -l pl.UTF-8
45Ten moduł to wtyczka setuptools_scm, dodająca obsługę archiwów git
46(np. takich, jak automatycznie generowane przez GitHuba).
47
48%package -n python3-setuptools_scm_git_archive
49Summary: setuptools_scm plugin for git archives
50Summary(pl.UTF-8): Wtyczka setuptools_scm do archiwów gita
51Group: Libraries/Python
52Requires: python3-modules >= 1:3.2
53
54%description -n python3-setuptools_scm_git_archive
55This is a setuptools_scm plugin that adds support for git archives
56(for example the ones GitHub automatically generates).
57
58%description -n python3-setuptools_scm_git_archive -l pl.UTF-8
59Ten moduł to wtyczka setuptools_scm, dodająca obsługę archiwów git
60(np. takich, jak automatycznie generowane przez GitHuba).
61
62%prep
63%setup -q -n setuptools_scm_git_archive-%{version}
64
65%build
66%if %{with python2}
67%py_build
68
69%if %{with tests}
70PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
71%{__python} -m pytest tests.py
72%endif
73%endif
74
75%if %{with python3}
76%py3_build
77
78%if %{with tests}
79PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
80%{__python3} -m pytest tests.py
81%endif
82%endif
83
84%install
85rm -rf $RPM_BUILD_ROOT
86
87%if %{with python2}
88%py_install
89
90%py_postclean
91%endif
92
93%if %{with python3}
94%py3_install
95%endif
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%if %{with python2}
101%files
102%defattr(644,root,root,755)
103%doc LICENSE README.rst
104%{py_sitescriptdir}/setuptools_scm_git_archive
105%{py_sitescriptdir}/setuptools_scm_git_archive-%{version}-py*.egg-info
106%endif
107
108%if %{with python3}
109%files -n python3-setuptools_scm_git_archive
110%defattr(644,root,root,755)
111%doc LICENSE README.rst
112%{py3_sitescriptdir}/setuptools_scm_git_archive
113%{py3_sitescriptdir}/setuptools_scm_git_archive-%{version}-py*.egg-info
114%endif
This page took 0.124479 seconds and 4 git commands to generate.