]> git.pld-linux.org Git - packages/python-setuptools_pep8.git/blame - python-setuptools_pep8.spec
rebuild with python 3.10
[packages/python-setuptools_pep8.git] / python-setuptools_pep8.spec
CommitLineData
bed93cc5
JB
1#
2# Conditional build:
3%bcond_with tests # unit tests (fixtures missing in pypi tarball)
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
214b60e7
JB
7Summary: pep8 command for setuptools
8Summary(pl.UTF-8): Polecenie pep8 dla setuptools
bed93cc5
JB
9Name: python-setuptools_pep8
10Version: 0.9.0
4562956d 11Release: 3
bed93cc5
JB
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/setuptools-pep8/
15Source0: https://files.pythonhosted.org/packages/source/s/setuptools-pep8/setuptools-pep8-%{version}.tar.gz
16# Source0-md5: 8d21d3dbee4e82652b15b1873e789e6c
17URL: https://pypi.org/project/setuptools-pep8/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.5
20BuildRequires: python-setuptools
21%if %{with tests}
22BuildRequires: python-pep8 >= 1.4.6
23%endif
24%endif
25%if %{with python3}
26BuildRequires: python3-modules >= 1:3.2
27BuildRequires: python3-setuptools
28%if %{with tests}
29BuildRequires: python3-pep8 >= 1.4.6
30%endif
31%endif
32BuildRequires: rpm-pythonprov
33BuildRequires: rpmbuild(macros) >= 1.714
34Requires: python-modules >= 1:2.5
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
214b60e7
JB
39This package exposes the pep8 style guide checker as a sub-command of
40setup.py.
bed93cc5
JB
41
42%description -l pl.UTF-8
214b60e7
JB
43Ten pakiet udostępnia sprawdzanie stylu wg pep8 jako podpolecenie
44setup.py.
bed93cc5
JB
45
46%package -n python3-setuptools_pep8
214b60e7
JB
47Summary: pep8 command for setuptools
48Summary(pl.UTF-8): Polecenie pep8 dla setuptools
bed93cc5
JB
49Group: Libraries/Python
50Requires: python3-modules >= 1:3.2
51
52%description -n python3-setuptools_pep8
214b60e7
JB
53This package exposes the pep8 style guide checker as a sub-command of
54setup.py.
bed93cc5
JB
55
56%description -n python3-setuptools_pep8 -l pl.UTF-8
214b60e7
JB
57Ten pakiet udostępnia sprawdzanie stylu wg pep8 jako podpolecenie
58setup.py.
bed93cc5
JB
59
60%prep
61%setup -q -n setuptools-pep8-%{version}
62
63%build
64%if %{with python2}
65%py_build
66
67%if %{with tests}
68PYTHONPATH=$(pwd)/src \
69%{__python} src/tests/test_pep8_command.py
70%endif
71%endif
72
73%if %{with python3}
74%py3_build
75
76%if %{with tests}
77PYTHONPATH=$(pwd)/src \
78%{__python3} src/tests/test_pep8_command.py
79%endif
80%endif
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85%if %{with python2}
86%py_install
87
88%{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
89%py_postclean
90%endif
91
92%if %{with python3}
93%py3_install
94
95%{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/tests
96%endif
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%if %{with python2}
102%files
103%defattr(644,root,root,755)
104%doc NEWS.rst README.rst
105%{py_sitescriptdir}/setuptools_pep8
106%{py_sitescriptdir}/setuptools_pep8-%{version}-py*.egg-info
107%endif
108
109%if %{with python3}
110%files -n python3-setuptools_pep8
111%defattr(644,root,root,755)
112%doc NEWS.rst README.rst
113%{py3_sitescriptdir}/setuptools_pep8
114%{py3_sitescriptdir}/setuptools_pep8-%{version}-py*.egg-info
115%endif
This page took 0.080313 seconds and 4 git commands to generate.