]> git.pld-linux.org Git - packages/python-selectors2.git/blame - python-selectors2.spec
- release 2 (by relup.sh)
[packages/python-selectors2.git] / python-selectors2.spec
CommitLineData
ed610af8
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_with python3 # CPython 3.x module (for Python 3.3, 3.4)
6
7Summary: Back-ported, durable, and portable selectors
8Summary(pl.UTF-8): Zbackportowane, trwałe i przenośne selektory
9Name: python-selectors2
10Version: 2.0.2
a8bc9cd6 11Release: 2
ed610af8
JB
12License: MIT
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/selectors2/
15Source0: https://files.pythonhosted.org/packages/source/s/selectors2/selectors2-%{version}.tar.gz
16# Source0-md5: 77089bc7a640bf09f784cc029195c24a
17URL: https://pypi.org/project/selectors2/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.6
20BuildRequires: python-setuptools
21%if %{with tests}
22BuildRequires: python-mock >= 2.0.0
23BuildRequires: python-nose >= 1.3.7
24BuildRequires: python-psutil >= 5.2.2
25%if "%{py_ver}" < "2.7"
26BuildRequires: python-unittest2
27%endif
28%endif
29%endif
30%if %{with python3}
31BuildRequires: python3-modules >= 1:3.3
32BuildRequires: python3-modules < 1:3.5
33BuildRequires: python3-setuptools
34%if %{with tests}
35BuildRequires: python3-mock >= 2.0.0
36BuildRequires: python3-nose >= 1.3.7
37BuildRequires: python3-psutil >= 5.2.2
38%endif
39%endif
40BuildRequires: rpm-pythonprov
41BuildRequires: rpmbuild(macros) >= 1.714
42Requires: python-modules >= 1:2.6
43BuildArch: noarch
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47Backported, durable, and portable selectors designed to replace the
48standard library selectors module.
49
50%description -l pl.UTF-8
51Zbackportowane, trwałe i przenośne selektory, zaprojektowane w celu
52zastąpienia modułu biblioteki standardowej selectors.
53
54%package -n python3-selectors2
55Summary: Back-ported, durable, and portable selectors
56Summary(pl.UTF-8): Zbackportowane, trwałe i przenośne selektory
57Group: Libraries/Python
58Requires: python3-modules >= 1:3.3
59
60%description -n python3-selectors2
61Backported, durable, and portable selectors designed to replace the
62standard library selectors module.
63
64%description -n python3-selectors2 -l pl.UTF-8
65Zbackportowane, trwałe i przenośne selektory, zaprojektowane w celu
66zastąpienia modułu biblioteki standardowej selectors.
67
68%prep
69%setup -q -n selectors2-%{version}
70
71%build
72%if %{with python2}
73%py_build
74
75%if %{with tests}
76nosetests-%{py_ver} tests/test_selectors2.py
77%endif
78%endif
79
80%if %{with python3}
81%py3_build
82
83%if %{with tests}
84nosetests-%{py3_ver} tests/test_selectors2.py
85%endif
86%endif
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91%if %{with python2}
92%py_install
93
94%py_postclean
95%endif
96
97%if %{with python3}
98%py3_install
99%endif
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%if %{with python2}
105%files
106%defattr(644,root,root,755)
107%doc CHANGELOG.rst LICENSE README.rst
108%{py_sitescriptdir}/selectors2.py[co]
109%{py_sitescriptdir}/selectors2-%{version}-py*.egg-info
110%endif
111
112%if %{with python3}
113%files -n python3-selectors2
114%defattr(644,root,root,755)
115%doc CHANGELOG.rst LICENSE README.rst
116%{py3_sitescriptdir}/selectors2.py
117%{py3_sitescriptdir}/__pycache__/selectors2.cpython-*.py[co]
118%{py3_sitescriptdir}/selectors2-%{version}-py*.egg-info
119%endif
This page took 0.129461 seconds and 4 git commands to generate.