]> git.pld-linux.org Git - packages/python-s3transfer.git/blame - python-s3transfer.spec
disable python3 here
[packages/python-s3transfer.git] / python-s3transfer.spec
CommitLineData
5a27e7c4
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
1e7bf035 5%bcond_with python3 # CPython 3.x module
5a27e7c4
JB
6
7Summary: Amazon S3 Transfer Manager
8Summary(pl.UTF-8): Zarządca transferu danych Amazon S3
9Name: python-s3transfer
10Version: 0.3.4
6b208219 11Release: 2
5a27e7c4
JB
12License: Apache v2.0
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/s3transfer/
15Source0: https://files.pythonhosted.org/packages/source/s/s3transfer/s3transfer-%{version}.tar.gz
16# Source0-md5: b0145fc2087107262b6c4d0f077ad3e2
17Patch0: %{name}-mock.patch
18Patch1: %{name}-tests.patch
19URL: https://pypi.org/project/s3transfer/
20%if %{with python2}
21BuildRequires: python-modules >= 1:2.7
22BuildRequires: python-setuptools
23%if %{with tests}
24BuildRequires: python-botocore >= 1.12.36
25BuildRequires: python-futures >= 2.2.0
26BuildRequires: python-mock >= 1.3.0
27BuildRequires: python-nose >= 1.3.3
28BuildRequires: python-six
29%endif
30%endif
31%if %{with python3}
32BuildRequires: python3-modules >= 1:3.4
33BuildRequires: python3-setuptools
34%if %{with tests}
35BuildRequires: python3-botocore >= 1.12.36
36BuildRequires: python3-nose >= 1.3.3
37BuildRequires: python3-six
38%endif
39%endif
40BuildRequires: rpm-pythonprov
41BuildRequires: rpmbuild(macros) >= 1.714
42Requires: python-modules >= 1:2.7
43BuildArch: noarch
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47S3transfer is a Python library for managing Amazon S3 transfers.
48
49%description -l pl.UTF-8
50S3transfer to pythonowa biblioteka do zarządzania przesyłami danych
51Amazon S3.
52
53%package -n python3-s3transfer
54Summary: Amazon S3 Transfer Manager
55Summary(pl.UTF-8): Zarządca transferu danych Amazon S3
56Group: Libraries/Python
57Requires: python3-modules >= 1:3.4
58
59%description -n python3-s3transfer
60S3transfer is a Python library for managing Amazon S3 transfers.
61
62%description -n python3-s3transfer -l pl.UTF-8
63S3transfer to pythonowa biblioteka do zarządzania przesyłami danych
64Amazon S3.
65
66%prep
67%setup -q -n s3transfer-%{version}
68%patch0 -p1
69%patch1 -p1
70
71%build
72%if %{with python2}
73%py_build
74
75%if %{with tests}
76%{__python} -m unittest discover -s tests/unit
77%endif
78%endif
79
80%if %{with python3}
81%py3_build
82
83%if %{with tests}
84%{__python3} -m unittest discover -s tests/unit
85%endif
86%endif
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91%if %{with python2}
92%py_install
93
94%py_postclean
95%endif
96
97%if %{with python3}
98%py3_install
99%endif
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%if %{with python2}
105%files
106%defattr(644,root,root,755)
107%doc README.rst
108%{py_sitescriptdir}/s3transfer
109%{py_sitescriptdir}/s3transfer-%{version}-py*.egg-info
110%endif
111
112%if %{with python3}
113%files -n python3-s3transfer
114%defattr(644,root,root,755)
115%doc README.rst
116%{py3_sitescriptdir}/s3transfer
117%{py3_sitescriptdir}/s3transfer-%{version}-py*.egg-info
118%endif
This page took 0.148697 seconds and 4 git commands to generate.