]> git.pld-linux.org Git - packages/python-rpdb.git/blame - python-rpdb.spec
rebuild with python 3.10
[packages/python-rpdb.git] / python-rpdb.spec
CommitLineData
9070e283
AM
1#
2# Conditional build:
3%bcond_without python2 # Python 2.x module
4%bcond_without python3 # Python 3.x module
03c7cb18 5
9070e283 6%define module rpdb
9070e283
AM
7Summary: pdb wrapper with remote access via tcp socket
8Name: python-rpdb
9Version: 0.1.3
bdcb6c75 10Release: 11
9070e283
AM
11License: ?
12Group: Development/Languages/Python
13Source0: https://pypi.python.org/packages/source/r/rpdb/rpdb-%{version}.tar.gz
14# Source0-md5: 4f350f523446a9100395d41b0b05c6cb
15URL: https://pypi.python.org/pypi/rpdb/
03c7cb18 16BuildRequires: rpm-pythonprov
24710fca 17BuildRequires: rpmbuild(macros) >= 1.710
9070e283
AM
18%if %{with python2}
19BuildRequires: python-devel
20BuildRequires: python-modules
9070e283
AM
21%endif
22%if %{with python3}
23BuildRequires: python3-2to3
24BuildRequires: python3-devel
25BuildRequires: python3-modules
26%endif
03c7cb18 27Requires: python
9070e283
AM
28Requires: python-devel-src
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33A wrapper around pdb that will re-route stdin and stdout to a socket
34handler.
35
03c7cb18 36%package -n python3-%{module}
9070e283 37Summary: pdb wrapper with remote access via tcp socket
9070e283
AM
38Group: Libraries/Python
39Requires: python3
40Requires: python3-devel-tools
41
42%description -n python3-%{module}
43A wrapper around pdb that will re-route stdin and stdout to a socket
44handler.
45
46%prep
47%setup -q -n %{module}-%{version}
48
49%build
50%if %{with python2}
43a48a66 51%py_build
9070e283
AM
52%endif
53%if %{with python3}
43a48a66 54%py3_build
9070e283
AM
55%endif
56
57%install
58rm -rf $RPM_BUILD_ROOT
59%if %{with python2}
43a48a66 60%py_install
03c7cb18
ER
61
62%py_postclean
9070e283 63%endif
03c7cb18 64
9070e283
AM
65%if %{with python3}
66install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
43a48a66 67%py3_install
9070e283
AM
68%endif
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%if %{with python2}
74%files
75%defattr(644,root,root,755)
76%doc PKG-INFO
03c7cb18
ER
77%{py_sitescriptdir}/rpdb
78%{py_sitescriptdir}/rpdb-%{version}-py*.egg-info
9070e283
AM
79%endif
80
81%if %{with python3}
82%files -n python3-%{module}
83%defattr(644,root,root,755)
84%doc PKG-INFO
03c7cb18
ER
85%{py3_sitescriptdir}/rpdb
86%{py3_sitescriptdir}/rpdb-%{version}-py*.egg-info
9070e283 87%endif
This page took 0.089273 seconds and 4 git commands to generate.