]> git.pld-linux.org Git - packages/python-repoze.sphinx.autointerface.git/blame - python-repoze.sphinx.autointerface.spec
Release 5 (by relup.sh)
[packages/python-repoze.sphinx.autointerface.git] / python-repoze.sphinx.autointerface.spec
CommitLineData
53ef8f28
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Sphinx extension: auto-generate API docs from Zope interfaces
7Summary(pl.UTF-8): Rozszerzenie Sphinksa: automatyczne generowanie dokumentacji API z interfejsów Zope
8Name: python-repoze.sphinx.autointerface
9Version: 0.8
d68b7921 10Release: 5
53ef8f28
JB
11License: BSD-like
12Group: Libraries/Python
13#Source0Download: https://pypi.org/simple/repoze-sphinx-autointerface/
14Source0: https://files.pythonhosted.org/packages/source/r/repoze.sphinx.autointerface/repoze.sphinx.autointerface-%{version}.tar.gz
15# Source0-md5: 8e05cb8421b0a3bea8ec3b0aa3695310
16URL: https://pypi.org/project/repoze.sphinx.autointerface/
17%if %{with python2}
18BuildRequires: python-modules >= 1:2.7
19BuildRequires: python-setuptools
20%endif
21%if %{with python3}
22BuildRequires: python3-modules >= 1:3.3
23BuildRequires: python3-setuptools
24%endif
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
27Requires: python-modules >= 1:2.7
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32This package defines an extension for the Sphinx documentation system.
33The extension allows generation of API documentation by introspection
34of zope.interface instances in code.
35
36%description -l pl.UTF-8
37Ten pakiet definiuje rozszerzenie systemu dokumentacji Sphinx,
38pozwalające generować dokumentację API poprzez wgląd w instancje
39zope.interface w kodzie.
40
41%package -n python3-repoze.sphinx.autointerface
42Summary: Sphinx extension: auto-generate API docs from Zope interfaces
43Summary(pl.UTF-8): Rozszerzenie Sphinksa: automatyczne generowanie dokumentacji API z interfejsów Zope
44Group: Libraries/Python
45Requires: python3-modules >= 1:3.3
46
47%description -n python3-repoze.sphinx.autointerface
48This package defines an extension for the Sphinx documentation system.
49The extension allows generation of API documentation by introspection
50of zope.interface instances in code.
51
52%description -n python3-repoze.sphinx.autointerface -l pl.UTF-8
53Ten pakiet definiuje rozszerzenie systemu dokumentacji Sphinx,
54pozwalające generować dokumentację API poprzez wgląd w instancje
55zope.interface w kodzie.
56
57%prep
58%setup -q -n repoze.sphinx.autointerface-%{version}
59
60%build
61%if %{with python2}
62%py_build
63%endif
64
65%if %{with python3}
66%py3_build
67%endif
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%if %{with python2}
73%py_install
74
75%py_postclean
76%endif
77
78%if %{with python3}
79%py3_install
80%endif
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%if %{with python2}
86%files
87%defattr(644,root,root,755)
88%doc CHANGES.rst CONTRIBUTORS.txt COPYRIGHT.txt LICENSE.txt README.rst TODO.txt
89# XXX: shared dir
90%dir %{py_sitescriptdir}/repoze
91%dir %{py_sitescriptdir}/repoze/sphinx
92%{py_sitescriptdir}/repoze/sphinx/autointerface.py[co]
93%{py_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*.egg-info
94%{py_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*-nspkg.pth
95%endif
96
97%if %{with python3}
98%files -n python3-repoze.sphinx.autointerface
99%defattr(644,root,root,755)
100%doc CHANGES.rst CONTRIBUTORS.txt COPYRIGHT.txt LICENSE.txt README.rst TODO.txt
101%dir %{py3_sitescriptdir}/repoze
102%dir %{py3_sitescriptdir}/repoze/sphinx
103%{py3_sitescriptdir}/repoze/sphinx/autointerface.py
104%{py3_sitescriptdir}/repoze/sphinx/__pycache__
105%{py3_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*.egg-info
106%{py3_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*-nspkg.pth
107%endif
This page took 0.157136 seconds and 4 git commands to generate.