]> git.pld-linux.org Git - packages/python-repoze.sphinx.autointerface.git/blame - python-repoze.sphinx.autointerface.spec
- python2 note
[packages/python-repoze.sphinx.autointerface.git] / python-repoze.sphinx.autointerface.spec
CommitLineData
53ef8f28
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Sphinx extension: auto-generate API docs from Zope interfaces
7Summary(pl.UTF-8): Rozszerzenie Sphinksa: automatyczne generowanie dokumentacji API z interfejsów Zope
8Name: python-repoze.sphinx.autointerface
5393004e 9# keep 0.x here for python2 support
53ef8f28 10Version: 0.8
1b40954f 11Release: 6
53ef8f28
JB
12License: BSD-like
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/repoze-sphinx-autointerface/
15Source0: https://files.pythonhosted.org/packages/source/r/repoze.sphinx.autointerface/repoze.sphinx.autointerface-%{version}.tar.gz
16# Source0-md5: 8e05cb8421b0a3bea8ec3b0aa3695310
17URL: https://pypi.org/project/repoze.sphinx.autointerface/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.7
20BuildRequires: python-setuptools
21%endif
22%if %{with python3}
23BuildRequires: python3-modules >= 1:3.3
24BuildRequires: python3-setuptools
25%endif
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.714
28Requires: python-modules >= 1:2.7
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33This package defines an extension for the Sphinx documentation system.
34The extension allows generation of API documentation by introspection
35of zope.interface instances in code.
36
37%description -l pl.UTF-8
38Ten pakiet definiuje rozszerzenie systemu dokumentacji Sphinx,
39pozwalające generować dokumentację API poprzez wgląd w instancje
40zope.interface w kodzie.
41
42%package -n python3-repoze.sphinx.autointerface
43Summary: Sphinx extension: auto-generate API docs from Zope interfaces
44Summary(pl.UTF-8): Rozszerzenie Sphinksa: automatyczne generowanie dokumentacji API z interfejsów Zope
45Group: Libraries/Python
46Requires: python3-modules >= 1:3.3
47
48%description -n python3-repoze.sphinx.autointerface
49This package defines an extension for the Sphinx documentation system.
50The extension allows generation of API documentation by introspection
51of zope.interface instances in code.
52
53%description -n python3-repoze.sphinx.autointerface -l pl.UTF-8
54Ten pakiet definiuje rozszerzenie systemu dokumentacji Sphinx,
55pozwalające generować dokumentację API poprzez wgląd w instancje
56zope.interface w kodzie.
57
58%prep
59%setup -q -n repoze.sphinx.autointerface-%{version}
60
61%build
62%if %{with python2}
63%py_build
64%endif
65
66%if %{with python3}
67%py3_build
68%endif
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73%if %{with python2}
74%py_install
75
76%py_postclean
77%endif
78
79%if %{with python3}
80%py3_install
81%endif
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%if %{with python2}
87%files
88%defattr(644,root,root,755)
89%doc CHANGES.rst CONTRIBUTORS.txt COPYRIGHT.txt LICENSE.txt README.rst TODO.txt
90# XXX: shared dir
91%dir %{py_sitescriptdir}/repoze
92%dir %{py_sitescriptdir}/repoze/sphinx
93%{py_sitescriptdir}/repoze/sphinx/autointerface.py[co]
94%{py_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*.egg-info
95%{py_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*-nspkg.pth
96%endif
97
98%if %{with python3}
99%files -n python3-repoze.sphinx.autointerface
100%defattr(644,root,root,755)
101%doc CHANGES.rst CONTRIBUTORS.txt COPYRIGHT.txt LICENSE.txt README.rst TODO.txt
102%dir %{py3_sitescriptdir}/repoze
103%dir %{py3_sitescriptdir}/repoze/sphinx
104%{py3_sitescriptdir}/repoze/sphinx/autointerface.py
105%{py3_sitescriptdir}/repoze/sphinx/__pycache__
106%{py3_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*.egg-info
107%{py3_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*-nspkg.pth
108%endif
This page took 0.151525 seconds and 4 git commands to generate.