]> git.pld-linux.org Git - packages/python-remoto.git/blame - python-remoto.spec
rebuild with tests and docs
[packages/python-remoto.git] / python-remoto.spec
CommitLineData
261cf1fa
JK
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module remoto
7Summary: Execute remote commands or processes
a13c7aa2 8Summary(pl.UTF-8): Uruchamianie zdalnych poleceń lub procesów
261cf1fa
JK
9Name: python-%{module}
10Version: 0.0.25
6a9b9874 11Release: 10
261cf1fa
JK
12License: MIT
13Group: Libraries/Python
14Source0: https://pypi.python.org/packages/source/r/remoto/%{module}-%{version}.tar.gz
15# Source0-md5: 94fa964c08d9c4619ef63201c58091e3
16URL: https://github.com/alfredodeza/remoto
17BuildRequires: rpm-pythonprov
73daae8d 18BuildRequires: rpmbuild(macros) >= 1.714
261cf1fa 19%if %{with python2}
73daae8d 20BuildRequires: python-setuptools >= 1:7.0
261cf1fa
JK
21%endif
22%if %{with python3}
23BuildRequires: python3-modules
73daae8d 24BuildRequires: python3-setuptools >= 1:7.0
261cf1fa
JK
25%endif
26Requires: python-execnet
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31A very simplistic remote-command-executor using ssh and Python in the
32remote end.
33
34All the heavy lifting is done by execnet, while this minimal API
35provides the bare minimum to handle easy logging and connections from
36the remote end.
37
a13c7aa2
JB
38%description -l pl.UTF-8
39Bardzo proste narzędzie do uruchamiania zdalnych poleceń przez SSH z
40Pythonem po drugiej stronie.
41
42Cała ciężka robota jest wykonywana przez execnet, a ten moduł jest
43minimalnym API zapewniającym minimum do obsługi łatwego logowania i
44połączeń ze zdalnej strony.
45
261cf1fa
JK
46%package -n python3-%{module}
47Summary: Execute remote commands or processes
a13c7aa2 48Summary(pl.UTF-8): Uruchamianie zdalnych poleceń lub procesów
261cf1fa
JK
49Group: Libraries/Python
50Requires: python3-execnet
51
52%description -n python3-%{module}
53A very simplistic remote-command-executor using ssh and Python in the
54remote end.
55
56All the heavy lifting is done by execnet, while this minimal API
57provides the bare minimum to handle easy logging and connections from
58the remote end.
59
a13c7aa2
JB
60%description -n python3-%{module} -l pl.UTF-8
61Bardzo proste narzędzie do uruchamiania zdalnych poleceń przez SSH z
62Pythonem po drugiej stronie.
63
64Cała ciężka robota jest wykonywana przez execnet, a ten moduł jest
65minimalnym API zapewniającym minimum do obsługi łatwego logowania i
66połączeń ze zdalnej strony.
67
261cf1fa
JK
68%prep
69%setup -q -n %{module}-%{version}
70
71%build
72export REMOTO_NO_VENDOR=1
73%if %{with python2}
7c91f9b5 74%py_build
261cf1fa
JK
75%endif
76
77%if %{with python3}
7c91f9b5 78%py3_build
261cf1fa
JK
79%endif
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84export REMOTO_NO_VENDOR=1
85%if %{with python2}
7c91f9b5 86%py_install
261cf1fa
JK
87# no %%py_postclean !
88# remoto needs the source code to run it on the target
89%endif
90
91%if %{with python3}
7c91f9b5 92%py3_install
261cf1fa
JK
93%endif
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%if %{with python2}
99%files
100%defattr(644,root,root,755)
101%doc README.rst
102%{py_sitescriptdir}/%{module}
103%if "%{py_ver}" > "2.4"
104%{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
105%endif
106%endif
107
108%if %{with python3}
109%files -n python3-%{module}
110%defattr(644,root,root,755)
111%doc README.rst
112%{py3_sitescriptdir}/%{module}
113%{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
114%endif
This page took 0.131279 seconds and 4 git commands to generate.