]> git.pld-linux.org Git - packages/python-pytest-runner.git/blame - python-pytest-runner.spec
- release 3 (by relup.sh)
[packages/python-pytest-runner.git] / python-pytest-runner.spec
CommitLineData
5b6b56be
JB
1#
2# Conditional build:
3%bcond_without doc # documentation (uses python2)
4%bcond_with tests # perform "make test" (broken with \--build-base)
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%if %{without python2}
9%undefine with_doc
10%endif
11Summary: Invoke py.test as distutils command with dependency resolution
12Summary(pl.UTF-8): Wywoływanie py.test jako polecenia distutils z rozwiązywaniem zależności
13Name: python-pytest-runner
14Version: 2.5.1
93c075fa 15Release: 3
5b6b56be
JB
16License: MIT
17Group: Libraries/Python
18#Source0Download: https://pypi.python.org/pypi/pytest-runner
19Source0: https://pypi.python.org/packages/source/p/pytest-runner/pytest-runner-%{version}.zip
20# Source0-md5: 2eef117c2f9db55d6639f5ef733575a6
21URL: https://bitbucket.org/pytest-dev/pytest-runner
22BuildRequires: rpm-pythonprov
23BuildRequires: rpmbuild(macros) >= 1.616
24%if %{with python2}
25BuildRequires: python-modules >= 1:2.6
26BuildRequires: python-setuptools
27BuildRequires: python-setuptools_scm
28%{?with_doc:BuildRequires: sphinx-pdg}
29%endif
30%if %{with python3}
31BuildRequires: python3-modules >= 1:3.2
32BuildRequires: python3-setuptools
33BuildRequires: python3-setuptools_scm
34%endif
35Requires: python-modules
36BuildArch: noarch
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40Setup scripts can use pytest-runner to add setup.py test support for
41pytest runner.
42
43%description -l pl.UTF-8
44Skrypty setup mogą wykorzystywać moduł pytest-runner do dodawania
45obsługi testów pytest runnera w setup.py.
46
47%package -n python3-pytest-runner
48Summary: Invoke py.test as distutils command with dependency resolution
49Summary(pl.UTF-8): Wywoływanie py.test jako polecenia distutils z rozwiązywaniem zależności
50Group: Libraries/Python
51Requires: python3-modules
52
53%description -n python3-pytest-runner
54Setup scripts can use pytest-runner to add setup.py test support for
55pytest runner.
56
57%description -n python3-pytest-runner -l pl.UTF-8
58Skrypty setup mogą wykorzystywać moduł pytest-runner do dodawania
59obsługi testów pytest runnera w setup.py.
60
61%package apidocs
62Summary: pytest-runner module documentation
63Summary(pl.UTF-8): Dokumentacja modułu pytest-runner
64Group: Documentation
65
66%description apidocs
67Documentation for pytest-runner module.
68
69%description apidocs -l pl.UTF-8
70Dokumentacja modułu pytest-runner.
71
72%prep
73%setup -q -n pytest-runner-%{version}
74
75%build
76%if %{with python2}
1ab68473 77%py_build %{?with_tests:test}
5b6b56be
JB
78
79%if %{with doc}
80%{__python} setup.py build_sphinx
81%endif
82%endif
83
84%if %{with python3}
1ab68473 85%py3_build %{?with_tests:test}
5b6b56be
JB
86%endif
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91%if %{with python2}
1ab68473 92%py_install
5b6b56be
JB
93
94%py_postclean
95%endif
96
97%if %{with python3}
1ab68473 98%py3_install
5b6b56be
JB
99%endif
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%if %{with python2}
105%files
106%defattr(644,root,root,755)
107%doc CHANGES.txt README.txt
108%{py_sitescriptdir}/ptr.py[co]
109%{py_sitescriptdir}/pytest_runner-%{version}-py*.egg-info
110%endif
111
112%if %{with python3}
113%files -n python3-pytest-runner
114%defattr(644,root,root,755)
115%doc CHANGES.txt README.txt
116%{py3_sitescriptdir}/ptr.py
117%{py3_sitescriptdir}/__pycache__/ptr.cpython-*.py[co]
118%{py3_sitescriptdir}/pytest_runner-%{version}-py*.egg-info
119%endif
120
121%if %{with doc}
122%files apidocs
123%defattr(644,root,root,755)
124%doc build/sphinx/html/*
125%endif
This page took 0.097597 seconds and 4 git commands to generate.