]> git.pld-linux.org Git - packages/python-pytest-flake8.git/blame - python-pytest-flake8.spec
rebuild with python 3.10
[packages/python-pytest-flake8.git] / python-pytest-flake8.spec
CommitLineData
9debd1ef
JB
1#
2# Conditional build:
3%bcond_without tests # py.test tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: py.test plugin to check FLAKE8 requirements
8Summary(pl.UTF-8): Wtyczka py.test do sprawdzania wymagań FLAKE8
9Name: python-pytest-flake8
611136f8 10# keep 1.0.x here for python2 support
e0c03548 11Version: 1.0.7
de03d1a2 12Release: 3
9debd1ef
JB
13License: BSD
14Group: Libraries/Python
74fc926a 15#Source0Download: https://pypi.org/simple/pytest-flake8/
9debd1ef 16Source0: https://files.pythonhosted.org/packages/source/p/pytest-flake8/pytest-flake8-%{version}.tar.gz
e0c03548 17# Source0-md5: e50df912c25866bfcb1a7266d6e266ef
9debd1ef
JB
18URL: https://github.com/tholo/pytest-flake8
19%if %{with python2}
20BuildRequires: python-modules >= 1:2.7
21BuildRequires: python-setuptools
22%if %{with tests}
74fc926a
JB
23BuildRequires: python-flake8 >= 3.5
24BuildRequires: python-pytest >= 3.5
9debd1ef
JB
25%endif
26%endif
27%if %{with python3}
28BuildRequires: python3-modules >= 1:3.4
29BuildRequires: python3-setuptools
30%if %{with tests}
74fc926a
JB
31BuildRequires: python3-flake8 >= 3.5
32BuildRequires: python3-pytest >= 3.5
9debd1ef
JB
33%endif
34%endif
35BuildRequires: rpm-pythonprov
36BuildRequires: rpmbuild(macros) >= 1.714
37Requires: python-modules >= 1:2.7
38BuildArch: noarch
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42py.test plugin for efficiently checking PEP8 compliance.
43
44%description -l pl.UTF-8
45Wtyczka py.test do efektywnego sprawdzania zgodności z PEP8.
46
47%package -n python3-pytest-flake8
48Summary: py.test plugin to check FLAKE8 requirements
49Summary(pl.UTF-8): Wtyczka py.test do sprawdzania wymagań FLAKE8
50Group: Libraries/Python
51Requires: python3-modules >= 1:3.4
52
53%description -n python3-pytest-flake8
54py.test plugin for efficiently checking PEP8 compliance.
55
56%description -n python3-pytest-flake8 -l pl.UTF-8
57Wtyczka py.test do efektywnego sprawdzania zgodności z PEP8.
58
59%prep
60%setup -q -n pytest-flake8-%{version}
9debd1ef
JB
61
62%build
63%if %{with python2}
64%py_build
65
e0c03548
JB
66%if %{with tests}
67PYTHONPATH=$(pwd) \
68PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
69PYTEST_PLUGINS="pytest_flake8" \
70%{__python} -m pytest
71%endif
9debd1ef
JB
72%endif
73
74%if %{with python3}
75%py3_build
76
e0c03548
JB
77%if %{with tests}
78PYTHONPATH=$(pwd) \
79PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
80PYTEST_PLUGINS="pytest_flake8" \
81%{__python3} -m pytest
82%endif
9debd1ef
JB
83%endif
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88%if %{with python2}
89%py_install
90
91%py_postclean
92%endif
93
94%if %{with python3}
95%py3_install
96%endif
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%if %{with python2}
102%files
103%defattr(644,root,root,755)
104%doc CHANGELOG LICENSE README.rst
105%{py_sitescriptdir}/pytest_flake8.py[co]
106%{py_sitescriptdir}/pytest_flake8-%{version}-py*.egg-info
107%endif
108
109%if %{with python3}
110%files -n python3-pytest-flake8
111%defattr(644,root,root,755)
112%doc CHANGELOG LICENSE README.rst
113%{py3_sitescriptdir}/pytest_flake8.py
114%{py3_sitescriptdir}/__pycache__/pytest_flake8.cpython-*.py[co]
115%{py3_sitescriptdir}/pytest_flake8-%{version}-py*.egg-info
116%endif
This page took 0.351502 seconds and 4 git commands to generate.